summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2012-06-06 09:40:50 +0000
committerAndreas Proschofsky <suka@gentoo.org>2012-06-06 09:40:50 +0000
commit9d6aeade418cb69d2f42d90f0250a14b5b305899 (patch)
treee6a86a45166af2a6c20734403fdf3bbf01cf49c1 /gnome-extra/gnome-boxes/gnome-boxes-3.5.2.ebuild
parentAdd new gnome-documents with SkyDrive support (and libzapojit providing this) (diff)
downloadsuka-9d6aeade418cb69d2f42d90f0250a14b5b305899.tar.gz
suka-9d6aeade418cb69d2f42d90f0250a14b5b305899.tar.bz2
suka-9d6aeade418cb69d2f42d90f0250a14b5b305899.zip
And another round of GNOME 3.5.2 updates
svn path=/; revision=342
Diffstat (limited to 'gnome-extra/gnome-boxes/gnome-boxes-3.5.2.ebuild')
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-3.5.2.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-3.5.2.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-3.5.2.ebuild
new file mode 100644
index 0000000..da1fd28
--- /dev/null
+++ b/gnome-extra/gnome-boxes/gnome-boxes-3.5.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="no"
+
+inherit linux-info gnome2
+if [[ ${PV} = 9999 ]]; then
+ inherit gnome2-live
+fi
+
+DESCRIPTION="Simple GNOME 3 application to access remote or virtual systems"
+HOMEPAGE="https://live.gnome.org/Design/Apps/Boxes"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="bindist"
+if [[ ${PV} = 9999 ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64" # qemu-kvm[spice] is 64bit-only
+fi
+
+# CHECK: We're hard-depending on qemu-kvm[spice]. Does app-emulation/qemu
+# support spice or not?
+# NOTE: sys-fs/* stuff is called via exec()
+RDEPEND="
+ >=dev-libs/libxml2-2.7.8:2
+ >=sys-fs/udev-165[gudev]
+ >=dev-libs/glib-2.29.90:2
+ >=dev-libs/gobject-introspection-0.9.6
+ >=sys-libs/libosinfo-0.1.1
+ app-emulation/qemu-kvm[spice]
+ >=app-emulation/libvirt-0.9.3[libvirtd,qemu]
+ >=app-emulation/libvirt-glib-0.0.8
+ >=x11-libs/gtk+-3.3.5:3
+ >=net-libs/gtk-vnc-0.4.4[gtk3]
+ >=net-misc/spice-gtk-0.9[gtk3]
+ >=app-misc/tracker-0.14[iso]
+ >=gnome-base/libgnomekbd-3
+
+ sys-fs/fuse
+ sys-fs/fuseiso
+ sys-fs/mtools"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig"
+
+if [[ ${PV} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ >=dev-lang/vala-0.14.0:0.14
+ sys-libs/libosinfo[introspection,vala]
+ app-emulation/libvirt-glib[introspection,vala]
+ net-libs/gtk-vnc[introspection,vala]
+ net-misc/spice-gtk[introspection,vala]"
+fi
+
+pkg_pretend() {
+ linux_config_exists
+
+ if ! { linux_chkconfig_present KVM_AMD || \
+ linux_chkconfig_present KVM_INTEL; }; then
+ ewarn "You need KVM support in your kernel to use GNOME Boxes!"
+ fi
+}
+
+pkg_setup() {
+ DOCS="AUTHORS README NEWS THANKS TODO"
+ G2CONF="--disable-schemas-compile
+ --disable-strict-cc
+ $(use_enable !bindist logos)
+ VALAC=$(type -P valac-0.14)"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "Before running gnome-boxes, you will need to load the KVM modules"
+ elog "If you have an Intel Processor, run:"
+ elog " modprobe kvm-intel"
+ einfo
+ elog "If you have an AMD Processor, run:"
+ elog " modprobe kvm-amd"
+}