summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2012-06-06 09:40:50 +0000
committerAndreas Proschofsky <suka@gentoo.org>2012-06-06 09:40:50 +0000
commit9d6aeade418cb69d2f42d90f0250a14b5b305899 (patch)
treee6a86a45166af2a6c20734403fdf3bbf01cf49c1 /gnome-extra/gnome-color-manager/gnome-color-manager-3.5.1.ebuild
parentAdd new gnome-documents with SkyDrive support (and libzapojit providing this) (diff)
downloadsuka-9d6aeade418cb69d2f42d90f0250a14b5b305899.tar.gz
suka-9d6aeade418cb69d2f42d90f0250a14b5b305899.tar.bz2
suka-9d6aeade418cb69d2f42d90f0250a14b5b305899.zip
And another round of GNOME 3.5.2 updates
svn path=/; revision=342
Diffstat (limited to 'gnome-extra/gnome-color-manager/gnome-color-manager-3.5.1.ebuild')
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-3.5.1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-3.5.1.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-3.5.1.ebuild
new file mode 100644
index 0000000..0e443c5
--- /dev/null
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-3.5.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/gnome-color-manager-3.4.0.ebuild,v 1.1 2012/05/13 23:36:49 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Color profile manager for the GNOME desktop"
+HOMEPAGE="http://projects.gnome.org/gnome-color-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="clutter packagekit raw"
+
+# FIXME: fix detection of docbook2man
+COMMON_DEPEND=">=dev-libs/glib-2.31.10:2
+ gnome-base/gnome-desktop:3
+ >=media-libs/lcms-2.2:2
+ >=media-libs/libcanberra-0.10[gtk3]
+ media-libs/libexif
+ media-libs/tiff
+
+ x11-libs/libX11
+ x11-libs/libXrandr
+ >=x11-libs/gtk+-2.91:3
+ >=x11-libs/vte-0.25.1:2.90
+ >=x11-misc/colord-0.1.12
+
+ clutter? (
+ >=media-libs/clutter-1.9.11:1.0
+ media-libs/clutter-gtk:1.0
+ media-libs/mash:0.2 )
+ packagekit? ( app-admin/packagekit-base )
+ raw? ( media-gfx/exiv2 )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-gfx/shared-color-profiles
+"
+# docbook-sgml-{utils,dtd:4.1} needed to generate man pages
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-sgml-dtd:4.1
+ app-text/docbook-sgml-utils
+ app-text/gnome-doc-utils
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+# FIXME: run test-suite with files on live file-system
+RESTRICT="test"
+
+pkg_setup() {
+ # Always enable tests since they are check_PROGRAMS anyway
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --enable-tests
+ $(use_enable clutter)
+ $(use_enable packagekit)
+ $(use_enable raw exiv)"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "If you want to do display or scanner calibration, you will need to"
+ elog "install media-gfx/argyllcms"
+}