summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2008-02-04 11:49:49 +0000
committerAndreas Proschofsky <suka@gentoo.org>2008-02-04 11:49:49 +0000
commitd2db36c19ef6b2145d6cc3ea7adc7fe00af0ad0b (patch)
tree5fc32f815fd553354f7286a08cb08ff8d2efea03 /gnome-extra
parentUpdate manifest, ooops (diff)
downloadsuka-d2db36c19ef6b2145d6cc3ea7adc7fe00af0ad0b.tar.gz
suka-d2db36c19ef6b2145d6cc3ea7adc7fe00af0ad0b.tar.bz2
suka-d2db36c19ef6b2145d6cc3ea7adc7fe00af0ad0b.zip
Add Policykit and policykit-gnome, needed for new gnome-panel clock, depend on it
svn path=/; revision=46
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/policykit-gnome/files/policykit-gnome-0.7-no-gtk-doc-check.patch32
-rw-r--r--gnome-extra/policykit-gnome/policykit-gnome-0.7.ebuild36
2 files changed, 68 insertions, 0 deletions
diff --git a/gnome-extra/policykit-gnome/files/policykit-gnome-0.7-no-gtk-doc-check.patch b/gnome-extra/policykit-gnome/files/policykit-gnome-0.7-no-gtk-doc-check.patch
new file mode 100644
index 0000000..a09d10d
--- /dev/null
+++ b/gnome-extra/policykit-gnome/files/policykit-gnome-0.7-no-gtk-doc-check.patch
@@ -0,0 +1,32 @@
+--- configure.ac.orig 2007-11-06 21:43:51.000000000 -0800
++++ configure.ac 2007-11-06 21:45:07.000000000 -0800
+@@ -116,8 +116,14 @@
+ AC_ARG_ENABLE(gtk-doc, AC_HELP_STRING([--enable-gtk-doc],
+ [use gtk-doc to build documentation [default=yes]]),,
+ enable_gtk_doc=yes)
++dnl Crazy hack for dropping the dep on gtk-doc
++AC_DEFUN(GTK_DOC_CHECK, [])
+ GTK_DOC_CHECK([1.3])
+
++dnl Crazy hack for dropping the dep on gtk-doc
++AM_CONDITIONAL(ENABLE_GTK_DOC, 0, [])
++AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, 0, [])
++
+ # ***************************
+ # Check for required packages
+ # ***************************
+--- Makefile.am.orig 2007-11-06 21:45:19.000000000 -0800
++++ Makefile.am 2007-11-06 21:46:50.000000000 -0800
+@@ -5,7 +5,11 @@
+ endif
+
+ # Need to build docs after examples because the docs include generated files
+-SUBDIRS += doc po
++if ENABLE_GTK_DOC
++SUBDIRS += doc
++endif
++
++SUBDIRS += po
+
+ # Creating ChangeLog from git log (taken from cairo/Makefile.am):
+ ChangeLog: $(srcdir)/ChangeLog
diff --git a/gnome-extra/policykit-gnome/policykit-gnome-0.7.ebuild b/gnome-extra/policykit-gnome/policykit-gnome-0.7.ebuild
new file mode 100644
index 0000000..8ff6078
--- /dev/null
+++ b/gnome-extra/policykit-gnome/policykit-gnome-0.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit gnome2 autotools
+
+MY_PN="PolicyKit-gnome"
+
+DESCRIPTION="PolicyKit policies and configurations for the GNOME desktop"
+HOMEPAGE="http://hal.freedesktop.org/docs/PolicyKit"
+SRC_URI="http://hal.freedesktop.org/releases/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="|| ( LGPL-2 GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/dbus-glib-0.71
+ >=x11-libs/gtk+-2.12
+ >=x11-libs/libsexy-0.1.11
+ >=gnome-base/gnome-vfs-2.4
+ >=gnome-base/libgnome-2.14
+ >=gnome-base/libgnomeui-2.14
+ >=sys-auth/policykit-0.7"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.35.0
+ >=app-text/scrollkeeper-0.3.14
+ doc? ( >=dev-util/gtk-doc-1.3 )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ G2CONF="$(use_enable doc gtk-doc) --disable-examples"
+}