summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/evince')
-rw-r--r--app-text/evince/Manifest3
-rw-r--r--app-text/evince/evince-3.5.2.ebuild111
-rw-r--r--app-text/evince/files/evince-0.7.1-display-menu.patch11
3 files changed, 125 insertions, 0 deletions
diff --git a/app-text/evince/Manifest b/app-text/evince/Manifest
new file mode 100644
index 0000000..8faf06f
--- /dev/null
+++ b/app-text/evince/Manifest
@@ -0,0 +1,3 @@
+AUX evince-0.7.1-display-menu.patch 476 RMD160 a16a5e1f32490a7db219442b23cbcf77773e6bdd SHA1 73a97e83b12ad80f6645339978717bcf8c7da575 SHA256 1f450dfe57ef3325cb4642141d76fc8e7bf837c221d81a2593214913af058f4d
+DIST evince-3.5.2.tar.xz 6133592 RMD160 29acc2e7f581c6343b7cb9304a7d79083b53013a SHA1 a6069f3861016c6ab4553b83d5b885eb9adb23f7 SHA256 8f359d7f66e64aa43f69616445a7b77995d5b95c44e9bb264556351ec1a293e0
+EBUILD evince-3.5.2.ebuild 3270 RMD160 6ad2ca44b729f410b6e70b3b5a4a05006b5ceac8 SHA1 8efeecdf40681e76dabcfbf8205d0f5f71cdea71 SHA256 026111e084f20925534b738b9462aa7576e5f26ad018fa51138ee2b80d067b4d
diff --git a/app-text/evince/evince-3.5.2.ebuild b/app-text/evince/evince-3.5.2.ebuild
new file mode 100644
index 0000000..371f942
--- /dev/null
+++ b/app-text/evince/evince-3.5.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-3.4.0.ebuild,v 1.2 2012/05/10 01:32:11 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dbus debug djvu doc dvi gnome-keyring +introspection nautilus +ps t1lib tiff xps"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+
+# Since 2.26.2, can handle poppler without cairo support. Make it optional ?
+# not mature enough
+# atk used in libview
+# gdk-pixbuf used all over the place
+# libX11 used for totem-screensaver
+RDEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.25.11:2
+ >=dev-libs/libxml2-2.5:2
+ sys-libs/zlib
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.0.2:3[introspection?]
+ x11-libs/libX11
+ >=x11-libs/libSM-1
+ x11-libs/libICE
+ gnome-base/gsettings-desktop-schemas
+ || (
+ >=x11-themes/gnome-icon-theme-2.17.1
+ >=x11-themes/hicolor-icon-theme-0.10 )
+ >=x11-libs/cairo-1.10.0
+ >=app-text/poppler-0.20[cairo]
+ djvu? ( >=app-text/djvu-3.5.17 )
+ dvi? (
+ virtual/tex-base
+ dev-libs/kpathsea
+ t1lib? ( >=media-libs/t1lib-5.0.0 ) )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.22.0 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6 )
+ nautilus? ( >=gnome-base/nautilus-2.91.4[introspection?] )
+ ps? ( >=app-text/libspectre-0.2.0 )
+ tiff? ( >=media-libs/tiff-3.6:0 )
+ xps? ( >=app-text/libgxps-0.2.1 )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ app-text/docbook-xml-dtd:4.3
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.13
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+
+ELTCONF="--portage"
+
+# Needs dogtail and pyspi from http://fedorahosted.org/dogtail/
+# Releases: http://people.redhat.com/zcerza/dogtail/releases/
+RESTRICT="test"
+
+pkg_setup() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of Gnome apps that doesn't require network for that.
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-static
+ --disable-tests
+ --enable-pdf
+ --enable-comics
+ --enable-thumbnailer
+ --with-smclient=xsmp
+ --with-platform=gnome
+ --enable-help
+ $(use_enable dbus)
+ $(use_enable djvu)
+ $(use_enable dvi)
+ $(use_with gnome-keyring keyring)
+ $(use_enable introspection)
+ $(use_enable nautilus)
+ $(use_enable ps)
+ $(use_enable t1lib)
+ $(use_enable tiff)
+ $(use_enable xps)"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+src_prepare() {
+ # Regenerate marshalers to allow building with <glib-2.32
+ rm -v cut-n-paste/gimpcellrenderertoggle/gimpwidgetsmarshal.{c,h} \
+ cut-n-paste/toolbar-editor/eggmarshalers.{c,h} \
+ libview/ev-view-marshal.{c,h} || die "rm failed"
+
+ # Fix .desktop file so menu item shows up
+ epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
+
+ gnome2_src_prepare
+
+ AT_NOELIBTOOLIZE=yes eautoreconf
+
+ # Do not depend on gnome-icon-theme, bug #326855, #391859
+ sed -e 's/gnome-icon-theme >= $GNOME_ICON_THEME_REQUIRED//g' \
+ -i configure || die "sed failed"
+}
diff --git a/app-text/evince/files/evince-0.7.1-display-menu.patch b/app-text/evince/files/evince-0.7.1-display-menu.patch
new file mode 100644
index 0000000..9edc43e
--- /dev/null
+++ b/app-text/evince/files/evince-0.7.1-display-menu.patch
@@ -0,0 +1,11 @@
+diff --exclude-from=/home/dang/.diffrc -up -ruN evince-0.7.1.orig/data/evince.desktop.in.in evince-0.7.1/data/evince.desktop.in.in
+--- evince-0.7.1.orig/data/evince.desktop.in.in 2007-01-10 11:04:20.000000000 -0500
++++ evince-0.7.1/data/evince.desktop.in.in 2007-01-18 17:30:52.000000000 -0500
+@@ -9,7 +9,6 @@ StartupNotify=true
+ Terminal=false
+ Type=Application
+ Icon=evince
+-NoDisplay=true
+ X-GNOME-DocPath=
+ X-GNOME-Bugzilla-Bugzilla=GNOME
+ X-GNOME-Bugzilla-Product=evince