summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gobject-introspection/gobject-introspection-9999.ebuild')
-rw-r--r--dev-libs/gobject-introspection/gobject-introspection-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild b/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
new file mode 100644
index 0000000..a351f5e
--- /dev/null
+++ b/dev-libs/gobject-introspection/gobject-introspection-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools gnome2 git
+
+EGIT_REPO_URI="git://git.gnome.org/gobject-introspection"
+
+DESCRIPTION="GObject Introspection tools and library"
+HOMEPAGE="http://live.gnome.org/GObjectIntrospection/"
+SRC_URI=""
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.19.0
+ || (
+ sys-devel/gcc[libffi]
+ virtual/libffi )
+ >=dev-lang/python-2.5"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ >=dev-util/pkgconfig-0.18
+ sys-devel/flex"
+
+G2CONF="${G2CONF}
+--disable-gtk-doc
+--disable-static"
+
+src_unpack() {
+ git_src_unpack
+ cd ${S}
+ gtkdocize
+ eautoreconf
+}