summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/mutter/mutter-9999.ebuild')
-rw-r--r--x11-wm/mutter/mutter-9999.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/x11-wm/mutter/mutter-9999.ebuild b/x11-wm/mutter/mutter-9999.ebuild
new file mode 100644
index 0000000..15df43b
--- /dev/null
+++ b/x11-wm/mutter/mutter-9999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit autotools eutils gnome2 git
+
+EGIT_REPO_URI="git://git.gnome.org/mutter"
+
+DESCRIPTION="New GNOME window manager"
+HOMEPAGE="http://blogs.gnome.org/metacity/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="test xinerama"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=x11-libs/pango-1.2[X]
+ >=gnome-base/gconf-2
+ >=dev-libs/glib-2.6
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ x11-libs/libXcursor
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXext
+ x11-libs/libXrandr
+ x11-libs/libSM
+ x11-libs/libICE
+ gnome-extra/zenity
+ >=media-libs/clutter-1.0[introspection]
+ !x11-misc/expocity"
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README *.txt doc/*.txt"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-gconf
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ $(use_enable xinerama)"
+}
+
+src_unpack() {
+ git_src_unpack
+
+ cd ${S}
+ intltoolize --force --copy --automake || die
+ eautoreconf
+}
+