summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2007-02-16 21:42:13 +0000
committerChristian Parpart <trapni@gentoo.org>2007-02-16 21:42:13 +0000
commit5783ae40b29b37124d3629c54c2408956b7ba2bd (patch)
treec08eacb5b0de22ae83d8e463cae4c5b5b8d4804f /media-video/captury/captury-0.1.0.ebuild
parentmake the compilation progress still happy when having *old* (aka. stable) lib... (diff)
downloadoverlay-5783ae40b29b37124d3629c54c2408956b7ba2bd.tar.gz
overlay-5783ae40b29b37124d3629c54c2408956b7ba2bd.tar.bz2
overlay-5783ae40b29b37124d3629c54c2408956b7ba2bd.zip
added pkg_setup() to ensure user has installed emul-linux-x86-xlibs with opengl useflag enabled
svn path=/overlay/; revision=28
Diffstat (limited to 'media-video/captury/captury-0.1.0.ebuild')
-rw-r--r--media-video/captury/captury-0.1.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/media-video/captury/captury-0.1.0.ebuild b/media-video/captury/captury-0.1.0.ebuild
index 5ae1075..5a54be3 100644
--- a/media-video/captury/captury-0.1.0.ebuild
+++ b/media-video/captury/captury-0.1.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit multilib flag-o-matic
+inherit multilib flag-o-matic eutils
DESCRIPTION="Captury Tool - captures the screen from your OpenGL games."
HOMEPAGE="http://battousai.mylair.de/projects/captury/"
@@ -23,6 +23,10 @@ RESTRICT="multilib-pkg-force"
S="${WORKDIR}/${P}/${PN}"
+pkg_setup() {
+ built_with_use --missing die app-emulation/emul-linux-x86-xlibs opengl
+}
+
setup_env() {
myconf=""
makeopts=""