summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2007-02-04 09:04:41 +0000
committerChristian Parpart <trapni@gentoo.org>2007-02-04 09:04:41 +0000
commita4f0dcd2ce06fd80222a744b65669e97346f8e2e (patch)
tree3fdceef93026384c880ff9ef1498a0e0ff2e2c6d /www-apache/mod_transform/mod_transform-0.7.0_pre20070204.ebuild
parent * don't ./autogen.sh (diff)
downloadoverlay-a4f0dcd2ce06fd80222a744b65669e97346f8e2e.tar.gz
overlay-a4f0dcd2ce06fd80222a744b65669e97346f8e2e.tar.bz2
overlay-a4f0dcd2ce06fd80222a744b65669e97346f8e2e.zip
add mod_transform (with snapshot build) to repos
svn path=/overlay/; revision=10
Diffstat (limited to 'www-apache/mod_transform/mod_transform-0.7.0_pre20070204.ebuild')
-rw-r--r--www-apache/mod_transform/mod_transform-0.7.0_pre20070204.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/www-apache/mod_transform/mod_transform-0.7.0_pre20070204.ebuild b/www-apache/mod_transform/mod_transform-0.7.0_pre20070204.ebuild
new file mode 100644
index 0000000..924288d
--- /dev/null
+++ b/www-apache/mod_transform/mod_transform-0.7.0_pre20070204.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_transform/mod_transform-0.6.0.ebuild,v 1.8 2007/01/14 21:09:18 chtekk Exp $
+
+inherit apache-module
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DESCRIPTION="Filter module that allows Apache2 to do dynamic XSL transformations."
+HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_transform/"
+SRC_URI="http://battousai.mylair.de/dist/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-libs/libxslt-1.1.5
+ >=dev-libs/libxml2-2.6.11
+ >=www-misc/libapreq2-2.07
+ >=www-apache/mod_depends-0.7.0_p200508161"
+
+RDEPEND="${DEPEND}"
+
+APACHE2_MOD_CONF="0.7/10_${PN}"
+APACHE2_MOD_DEFINE="TRANSFORM"
+
+need_apache2
+
+src_compile() {
+ econf --with-apxs=${APXS2} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ local PLUGIN_DIR=/usr/$(get_libdir)/apache2/modules/mod_transform
+ dodir ${PLUGIN_DIR}
+ insinto ${PLUGIN_DIR}
+ doins src/.libs/http.so
+
+ apache2_src_install
+}