summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2016-03-23 16:51:20 +0100
committerUlrich Müller <ulm@gentoo.org>2016-03-23 16:51:20 +0100
commitd9e27e8fc65d55bb56574aacbdcf841e96802574 (patch)
treee4be79c8b3a43fd76cf972f4f34a2f679b85b7f9
parentotpcalc: Add 08_all_extract.patch. (diff)
downloadulm-motif-2.3.5-patches-1.tar.gz
ulm-motif-2.3.5-patches-1.tar.bz2
ulm-motif-2.3.5-patches-1.zip
Initial patchset for motif-2.3.5.motif-2.3.5-patches-1
-rw-r--r--patchsets/motif/2.3.5/01_all_solaris.patch17
-rw-r--r--patchsets/motif/2.3.5/02_all_sanitise-paths.patch27
-rw-r--r--patchsets/motif/2.3.5/03_all_solaris-11.patch13
-rw-r--r--patchsets/motif/2.3.5/04_all_parallel-make.patch15
-rw-r--r--patchsets/motif/2.3.5/05_all_install-dirs.patch18
5 files changed, 90 insertions, 0 deletions
diff --git a/patchsets/motif/2.3.5/01_all_solaris.patch b/patchsets/motif/2.3.5/01_all_solaris.patch
new file mode 100644
index 0000000..e1e6e62
--- /dev/null
+++ b/patchsets/motif/2.3.5/01_all_solaris.patch
@@ -0,0 +1,17 @@
+http://bugs.motifzone.net/showattachment.cgi?attach_id=259
+http://bugs.motifzone.net/long_list.cgi?buglist=1479
+
+Extend the patch to include guard for sun to solve the exact same
+compilation issue on Solaris.
+
+--- motif-2.3.4-orig/clients/uil/UilDefI.h
++++ motif-2.3.4/clients/uil/UilDefI.h
+@@ -270,7 +270,7 @@
+ #include "UilIODef.h"
+ #include "UilDiagDef.h"
+ #include "UilSarDef.h"
+-#if defined(linux) || defined(__APPLE__)
++#if defined(linux) || defined(__APPLE__) || defined(sun)
+ #define YYSTYPE yystype
+ #endif
+ #include "UilLexPars.h"
diff --git a/patchsets/motif/2.3.5/02_all_sanitise-paths.patch b/patchsets/motif/2.3.5/02_all_sanitise-paths.patch
new file mode 100644
index 0000000..750e368
--- /dev/null
+++ b/patchsets/motif/2.3.5/02_all_sanitise-paths.patch
@@ -0,0 +1,27 @@
+* don't do automagic guessing of paths
+
+--- motif-2.3.4-orig/configure.ac
++++ motif-2.3.4/configure.ac
+@@ -183,21 +183,8 @@
+
+ case "$host_os" in
+ freebsd*) CFLAGS="$CFLAGS -DCSRG_BASED -DXNO_MTSAFE_API -DXNO_MTSAFE_PWDAPI";
+- LDFLAGS="$LDFLAGS -L/usr/local/lib";;
++ ;;
+ cygwin*) CFLAGS="$CFLAGS -DXNO_MTSAFE_DIRENTDAPI";;
+- solaris* | sunos*) X_LIBS="$X_LIBS -L/usr/X/lib" &&
+- if test x$enable_motif22_compatibility = x
+- then
+- enable_motif22_compatibility="no"
+- fi;
+- if test x$enable_utf8 = x
+- then
+- enable_utf8="no"
+- fi;
+- if test x$enable_xft = x
+- then
+- enable_xft="no"
+- fi;;
+ esac
+
+ if test x$enable_motif22_compatibility = x
diff --git a/patchsets/motif/2.3.5/03_all_solaris-11.patch b/patchsets/motif/2.3.5/03_all_solaris-11.patch
new file mode 100644
index 0000000..4a6b236
--- /dev/null
+++ b/patchsets/motif/2.3.5/03_all_solaris-11.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/465426
+
+--- motif-2.3.4-orig/lib/Xm/Xmos_r.h
++++ motif-2.3.4/lib/Xm/Xmos_r.h
+@@ -602,7 +602,7 @@
+ # endif
+ } _Xreaddirparams;
+
+-# if defined(AIXV3) || defined(AIXV4) || defined(_POSIX_THREAD_SAFE_FUNCTIONS)
++# if defined(AIXV3) || defined(AIXV4) || defined(HAVE_READDIR_R_3) || defined(_POSIX_THREAD_SAFE_FUNCTIONS)
+ /* AIX defines the draft POSIX symbol, but uses the final API. */
+ /* POSIX final API, returns (int)0 on success. */
+ # if defined(__osf__)
diff --git a/patchsets/motif/2.3.5/04_all_parallel-make.patch b/patchsets/motif/2.3.5/04_all_parallel-make.patch
new file mode 100644
index 0000000..c8733e9
--- /dev/null
+++ b/patchsets/motif/2.3.5/04_all_parallel-make.patch
@@ -0,0 +1,15 @@
+http://bugs.motifzone.net/show_bug.cgi?id=1592
+
+--- motif-2.3.4-orig/lib/Xm/Makefile.am
++++ motif-2.3.4/lib/Xm/Makefile.am
+@@ -283,7 +283,9 @@
+ $(top_builddir)/config/util/makestrs:
+ ( cd $(top_builddir)/config/util && $(MAKE) $(AM_MAKEFLAGS) makestrs )
+
+-$(STRING_FILES): Makefile $(XMSTRING_LIST) XmStrDefs.ht XmStrDefsI.ht XmStrDefs.ct $(top_builddir)/config/util/makestrs
++XmStrDefs.h XmStrDefs22.h XmStrDefs23.h XmStrDefsI.h: XmStrDefs.c
++
++XmStrDefs.c: Makefile $(XMSTRING_LIST) XmStrDefs.ht XmStrDefsI.ht XmStrDefs.ct $(top_builddir)/config/util/makestrs
+ test -f $(XMSTRING_LIST) || $(LN_S) $(srcdir)/$(XMSTRING_LIST) $(XMSTRING_LIST)
+ test -f XmStrDefs.ht || $(LN_S) $(srcdir)/XmStrDefs.ht XmStrDefs.ht
+ test -f XmStrDefs22.ht || $(LN_S) $(srcdir)/XmStrDefs22.ht XmStrDefs22.ht
diff --git a/patchsets/motif/2.3.5/05_all_install-dirs.patch b/patchsets/motif/2.3.5/05_all_install-dirs.patch
new file mode 100644
index 0000000..8b525aa
--- /dev/null
+++ b/patchsets/motif/2.3.5/05_all_install-dirs.patch
@@ -0,0 +1,18 @@
+--- motif-2.3.4-orig/configure.ac
++++ motif-2.3.4/configure.ac
+@@ -179,13 +179,13 @@
+ LIBDIR="${libdir}/X11"
+ AC_SUBST(LIBDIR)
+
+-MWMRCDIR="${libdir}/X11"
++MWMRCDIR="${sysconfdir}/X11/mwm"
+ AC_SUBST(MWMRCDIR)
+
+ INCDIR="${includedir}/X11"
+ AC_SUBST(INCDIR)
+
+-XMBINDDIR_FALLBACK="${libdir}/X11/bindings"
++XMBINDDIR_FALLBACK="${datadir}/X11/bindings"
+ AC_SUBST(XMBINDDIR_FALLBACK)
+
+ RM="rm -f"