summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/scylla-jmx/scylla-jmx-9999.ebuild')
-rw-r--r--app-admin/scylla-jmx/scylla-jmx-9999.ebuild27
1 files changed, 11 insertions, 16 deletions
diff --git a/app-admin/scylla-jmx/scylla-jmx-9999.ebuild b/app-admin/scylla-jmx/scylla-jmx-9999.ebuild
index e29b1c1..a122a45 100644
--- a/app-admin/scylla-jmx/scylla-jmx-9999.ebuild
+++ b/app-admin/scylla-jmx/scylla-jmx-9999.ebuild
@@ -1,18 +1,13 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/scylladb/scylla-jmx.git"
- inherit git-r3
-else
- MY_PV="${PV/_rc/.rc}"
- MY_P="${PN}-${MY_PV}"
- SRC_URI="https://github.com/scylladb/${PN}/archive/scylla-${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/scylla-jmx-scylla-${MY_PV}"
-fi
+EGIT_CLONE_TYPE="mirror"
+EGIT_COMMIT="master"
+EGIT_REPO_URI="https://github.com/scylladb/scylla-jmx.git"
+inherit git-r3
+
PYTHON_COMPAT=( python2_7 )
inherit java-pkg-2 python-r1 systemd user
@@ -30,6 +25,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${CDEPEND}
${PYTHON_DEPS}
+ dev-python/pystache[${PYTHON_USEDEP}]
>=virtual/jre-1.8"
DEPEND="
@@ -46,10 +42,6 @@ pkg_setup() {
src_prepare() {
default
- # fix systemd service config path
- cp dist/common/systemd/scylla-jmx.service.in dist/common/systemd/scylla-jmx.service || die
- sed -e "s#@@SYSCONFDIR@@#/etc/sysconfig#g" -i dist/common/systemd/scylla-jmx.service || die
-
# fix symlink runtime error on scylla-jmx script
# * scylla-jmx is not available for oracle-jdk-bin-1.8 on x86_64
# * IMPORTANT: some Java tools are not available on some VMs on some architectures
@@ -78,7 +70,10 @@ src_install() {
newinitd "${FILESDIR}/scylla-jmx.initd" ${PN}
newconfd "${FILESDIR}/scylla-jmx.confd" ${PN}
- systemd_dounit dist/common/systemd/*.service
+
+ local MUSTACHE_DIST="\"debian\": true"
+ pystache dist/common/systemd/scylla-jmx.service.mustache "{ $MUSTACHE_DIST }" > scylla-jmx.service
+ systemd_dounit scylla-jmx.service
}
pkg_postinst() {