summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2006-01-04 20:41:36 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2006-01-04 20:41:36 +0000
commiteb49b68619f525df0007d4bfa3ad3e0389d9da9c (patch)
treea5353207d378a1d179bb03d5385aa1be1dfe821f /app-admin
parentFixed digests (diff)
downloadoverlay-eb49b68619f525df0007d4bfa3ad3e0389d9da9c.tar.gz
overlay-eb49b68619f525df0007d4bfa3ad3e0389d9da9c.tar.bz2
overlay-eb49b68619f525df0007d4bfa3ad3e0389d9da9c.zip
New webapp-config
svn path=/; revision=610
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.5.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-admin/webapp-config/webapp-config-1.50.5.ebuild b/app-admin/webapp-config/webapp-config-1.50.5.ebuild
new file mode 100644
index 0000000..77043bf
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils distutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~wrobel/webapp-config/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+S=${WORKDIR}/${PF}
+
+DEPEND=""
+
+src_install() {
+
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ dodir /etc/vhosts
+ cp config/webapp-config ${D}/etc/vhosts/
+ keepdir /usr/share/webapps
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+}
+
+src_test() {
+ cd ${S}
+ einfo "Running webapp-config doctests..."
+ if ! PYTHONPATH="." ${python} WebappConfig/tests/dtest.py; then
+ eerror "DocTests failed - please submit a bug report"
+ die "DocTesting failed!"
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "Now that you have upgraded webapp-config, you **must** update your"
+ einfo "config files in /etc/vhosts/webapp-config before you emerge any"
+ einfo "packages that use webapp-config."
+ echo
+ epause 5
+}