summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2005-01-19 09:12:37 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2005-01-19 09:12:37 +0000
commited04783f06d65268fe0e42427d2bd034a110744e (patch)
treeda148d69bd092f04e8e634f82067a1e51b8c8381 /sci-biology
parentfixed permissions on repbase ebuild (diff)
downloadoverlay-ed04783f06d65268fe0e42427d2bd034a110744e.tar.gz
overlay-ed04783f06d65268fe0e42427d2bd034a110744e.tar.bz2
overlay-ed04783f06d65268fe0e42427d2bd034a110744e.zip
Fixed cleaning script
svn path=/; revision=80
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/repbase/Manifest2
-rwxr-xr-xsci-biology/repbase/files/clean45
2 files changed, 25 insertions, 22 deletions
diff --git a/sci-biology/repbase/Manifest b/sci-biology/repbase/Manifest
index b15779e..68741b4 100644
--- a/sci-biology/repbase/Manifest
+++ b/sci-biology/repbase/Manifest
@@ -1,3 +1,3 @@
MD5 91b78f561ed7a033faf48d1e4d5c68e3 repbase-9.12.ebuild 1456
-MD5 5de6ba25014bec88b60fa472c4b69a91 files/clean 1120
+MD5 943163c2456b74490a384738b63d6d94 files/clean 1161
MD5 6d171b2224c472ad2ab93a3033b09c96 files/digest-repbase-9.12 70
diff --git a/sci-biology/repbase/files/clean b/sci-biology/repbase/files/clean
index b681d52..37ee59c 100755
--- a/sci-biology/repbase/files/clean
+++ b/sci-biology/repbase/files/clean
@@ -15,36 +15,39 @@ while (<LIB>)
{
if (m/^>/)
{
- if ($sequence eq "" and not $name eq "")
+ if (not $name eq "")
{
- print "---------------------------------------------------------------------------------------\n";
- print "Empty sequence: " . $name . "\n";
- }
- else
- {
- if ($sequence =~ m/^[ACGTNWSYRMHKXDVB]*$/)
+ if ($sequence eq "")
+ {
+ print "---------------------------------------------------------------------------------------\n";
+ print "Empty sequence: " . $name . "\n";
+ }
+ else
{
- $sequence =~ s/[WSYRMHKXDVB]/N/g;
- if (not $sequence =~ m/NNNN/)
+ if ($sequence =~ m/^[ACGTNWSYRMHKXDVB]*$/)
{
- print CLIB $name;
- print CLIB $sequence . "\n";
+ $sequence =~ s/[WSYRMHKXDVB]/N/g;
+ if (not $sequence =~ m/NNNN/)
+ {
+ print CLIB $name;
+ print CLIB $sequence . "\n";
+ }
+ else
+ {
+ print "---------------------------------------------------------------------------------------\n";
+ print "Too many N's: " . $name;
+ }
}
else
{
print "---------------------------------------------------------------------------------------\n";
- print "Too many N's: " . $name;
+ print "Invalid entry: " . $name;
+ $sequence =~ s/[ACGTN]//g;
+ print "Reduced sequence:\n";
+ print $sequence . "\n";
}
+ $sequence = "";
}
- else
- {
- print "---------------------------------------------------------------------------------------\n";
- print "Invalid entry: " . $name;
- $sequence =~ s/[ACGTN]//g;
- print "Reduced sequence:\n";
- print $sequence . "\n";
- }
- $sequence = "";
}
$name = $_;
}