summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2013-08-25 15:36:30 +0200
committerWolfram Schlich <wschlich@gentoo.org>2013-08-25 15:36:30 +0200
commit79752a83f2e9055c8d117257063c565ae9113f2f (patch)
tree5023e48b91a1f5795c648263ac800af132185e2b
parentremoved old versions (diff)
downloadwschlich-79752a83f2e9055c8d117257063c565ae9113f2f.tar.gz
wschlich-79752a83f2e9055c8d117257063c565ae9113f2f.tar.bz2
wschlich-79752a83f2e9055c8d117257063c565ae9113f2f.zip
added clamav version dependency
Package-Manager: portage-2.2.1
-rw-r--r--app-antivirus/skyldav/ChangeLog6
-rw-r--r--app-antivirus/skyldav/Manifest1
-rw-r--r--app-antivirus/skyldav/skyldav-0.2_rc3_p20130825.ebuild73
3 files changed, 80 insertions, 0 deletions
diff --git a/app-antivirus/skyldav/ChangeLog b/app-antivirus/skyldav/ChangeLog
index 4ccb67e..4def468 100644
--- a/app-antivirus/skyldav/ChangeLog
+++ b/app-antivirus/skyldav/ChangeLog
@@ -1,3 +1,9 @@
+*skyldav-0.2_rc3_p20130825 (25 Aug 2013)
+
+ 25 Aug 2013; Wolfram Schlich <wschlich@gentoo.org>
+ +skyldav-0.2_rc3_p20130825.ebuild:
+ added clamav version dependency
+
24 Aug 2013; Wolfram Schlich <wschlich@gentoo.org>
-files/skyldav-0.2_rc3-conf.patch, -files/skyldav-0.2_rc3-examples.patch,
-files/skyldav-0.2_rc3-openlog.patch,
diff --git a/app-antivirus/skyldav/Manifest b/app-antivirus/skyldav/Manifest
index f8d39dc..bcbfd85 100644
--- a/app-antivirus/skyldav/Manifest
+++ b/app-antivirus/skyldav/Manifest
@@ -1 +1,2 @@
+DIST skyldav-0.2_rc3_p20130825.tar.gz 101683 SHA256 290dcc7abba2f6da000f0910ef44f3672ca09a304f4702631ba487f359386894 SHA512 cf1537c81ebce00b19d057fa87bc4074413469a132e69b5d568a34f381dd1ff646efb620f117eab7201b0bf57c850f90f380bde6f93e9c4b32127dafa6387717 WHIRLPOOL 9d811f9e8668cbf796ae7ecf7d33fbb2b79ab1c9eb96d4c91bb0523076b8376bcfabba9ada44814235b048cd4f948562acdcc5c52b4c439a589d7aefd1754bd1
DIST skyldav-0.2rc3_p20130824.tar.gz 100909 SHA256 580729fd196fbdc8bea151e1aac31f5870d803601fd3da96c4092ce7613ad0c1 SHA512 eacbeead5b097cffb2587375ee63e14163cbd6e0fe7a21bf1ef8947e630bab28dbfe0f51ec2ba3d646533514e0f4b9d4d1b10137315d72c9aebdb4c4e72b1ebe WHIRLPOOL 35c608f1c30710e7f32f72d30664d91f9c2d007e69c03a183fe3ec5747f7acd623daa3ee8e9630dd03f8325bae74ad56bad233e4251da10408ec9a4b385de44b
diff --git a/app-antivirus/skyldav/skyldav-0.2_rc3_p20130825.ebuild b/app-antivirus/skyldav/skyldav-0.2_rc3_p20130825.ebuild
new file mode 100644
index 0000000..9932b97
--- /dev/null
+++ b/app-antivirus/skyldav/skyldav-0.2_rc3_p20130825.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit flag-o-matic linux-info linux-mod autotools-utils
+
+DESCRIPTION="Skyld AV: on-access scanning daemon for ClamAV using fanotify"
+HOMEPAGE="http://xypron.github.io/skyldav/"
+
+## github release tarball
+#MY_PV=${PV/_rc/rc}
+#MY_P="${PN}-${MY_PV}"
+#SRC_URI="https://github.com/xypron/skyldav/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+
+## selfmade tarball
+#MY_PVR=${PVR/_rc/rc}
+#MY_P="${PN}-${MY_PVR}"
+#SRC_URI="http://dev.gentoo.org/~wschlich/src/${CATEGORY}/${PN}/${MY_P}.tar.gz"
+
+## github commit tarball
+MY_GIT_COMMIT="3d875c4e361cba43a16d6e564f7b7461ffb5beab"
+MY_P="xypron-${PN}-${MY_GIT_COMMIT:0:7}"
+SRC_URI="https://github.com/xypron/${PN}/tarball/${MY_GIT_COMMIT} -> ${PF}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="Apache-2.0"
+IUSE="libnotify"
+
+RDEPEND=">=app-antivirus/clamav-0.97.8
+ sys-apps/util-linux
+ sys-libs/libcap
+ libnotify? (
+ media-libs/libcanberra[gtk]
+ x11-libs/libnotify
+ x11-libs/gtk+:2
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf-archive"
+
+## autotools-utils.eclass settings
+AUTOTOOLS_AUTORECONF="1"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+DOCS=( AUTHORS NEWS README )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.2_rc3_p20130824-conf.patch"
+ "${FILESDIR}/${PN}-0.2_rc3_p20130821-examples.patch"
+ "${FILESDIR}/${PN}-0.2_rc3-sbin.patch"
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+ kernel_is ge 3 8 0 || die "Linux 3.8.0 or newer recommended"
+ CONFIG_CHECK="FANOTIFY FANOTIFY_ACCESS_PERMISSIONS"
+ check_extra_config
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with libnotify notification)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}