summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2010-10-14 15:25:21 +0200
committerKacper Kowalik (Xarthisius) <xarthisius.kk@gmail.com>2010-10-14 15:25:21 +0200
commit1a00be4ccc2cc7caff022c7b0a210a43593e51e2 (patch)
treea89faec4c31073d975a487fde3a84c82a19f08da
parentsys-cluster/glusterfs: version bump (diff)
downloadxarthisius-1a00be4ccc2cc7caff022c7b0a210a43593e51e2.tar.gz
xarthisius-1a00be4ccc2cc7caff022c7b0a210a43593e51e2.tar.bz2
xarthisius-1a00be4ccc2cc7caff022c7b0a210a43593e51e2.zip
sci-libs/dcmtk: version bump, not fully working yet
-rw-r--r--sci-libs/dcmtk/ChangeLog20
-rw-r--r--sci-libs/dcmtk/Manifest5
-rw-r--r--sci-libs/dcmtk/dcmtk-3.5.5_pre20101008.ebuild59
-rw-r--r--sci-libs/dcmtk/files/dcmtk-asneeded.patch54
-rw-r--r--sci-libs/dcmtk/metadata.xml19
5 files changed, 157 insertions, 0 deletions
diff --git a/sci-libs/dcmtk/ChangeLog b/sci-libs/dcmtk/ChangeLog
new file mode 100644
index 0000000..6323297
--- /dev/null
+++ b/sci-libs/dcmtk/ChangeLog
@@ -0,0 +1,20 @@
+# ChangeLog for sci-libs/dcmtk
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*dcmtk-3.5.5_pre20101008 (14 Oct 2010)
+
+ 14 Oct 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ +dcmtk-3.5.5_pre20101008.ebuild, +files/dcmtk-asneeded.patch,
+ +metadata.xml:
+ Version bump. Use CMake, fix as-needed. Doxygen not working yet...
+
+ 26 Apr 2008; Ivan Havlicek <ivan@modulix.org> dcmtk-3.5.4-r3 :
+ Changes in xmedcon-0.10.4.ebuild for conformance with repoman
+
+ 26 Apr 2008; Ivan Havlicek <ivan@modulix.org> ChangeLog :
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/sci-libs/dcmtk/Manifest b/sci-libs/dcmtk/Manifest
new file mode 100644
index 0000000..b2cd6eb
--- /dev/null
+++ b/sci-libs/dcmtk/Manifest
@@ -0,0 +1,5 @@
+AUX dcmtk-asneeded.patch 4034 RMD160 0bcf67c09e46618977a76bada001b5f4c90bbcb9 SHA1 557da59201a499b517a10f07dc529dddce13563b SHA256 09048838c719a911516a91e06e8d0d2379ea2b91ee8b3f0110fe58d418d1d28b
+DIST dcmtk-3.5.5_20101008.tar.gz 4662578 RMD160 ccda8393aa1d27745832ed74635ef545f1fedab2 SHA1 29539987c042fd9c75f7628f49a03c49aecf5876 SHA256 f8eb25c76e078a387f86cd09ee27687f9860a1e9072b321ac8e070ccb85b1d90
+EBUILD dcmtk-3.5.5_pre20101008.ebuild 1488 RMD160 1a43518e592b9e3a96083ea7d3b94583d5458193 SHA1 e6a70bd1d10c3b521ea18827ef391be4b5c9e3c7 SHA256 b8dee0f1e6b734c35bef81cd060107717b1cba1cd49723c605b9b548005761cc
+MISC ChangeLog 925 RMD160 433548be9df6dee768752b9c648ddb2525514b4d SHA1 66944ad8e3c3b2037714057197f358b7e4ea1fd9 SHA256 ca9a566394839969162f01ecf4b8f50119146c7ca15af653ecf30c5b7c382fcb
+MISC metadata.xml 938 RMD160 e6451a136c100b3cafe90e2e1064dffb77aca7d9 SHA1 1a3b698c05897246eb73666f205ec7d873d20270 SHA256 3541a8cb00af24c3b785d021e1d15a94d9c0883d43a60228dd81ab7898534925
diff --git a/sci-libs/dcmtk/dcmtk-3.5.5_pre20101008.ebuild b/sci-libs/dcmtk/dcmtk-3.5.5_pre20101008.ebuild
new file mode 100644
index 0000000..b90ee62
--- /dev/null
+++ b/sci-libs/dcmtk/dcmtk-3.5.5_pre20101008.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+
+inherit cmake-utils eutils
+
+MY_P=${P/pre/}
+
+DESCRIPTION="The DICOM Toolkit"
+HOMEPAGE="http://dicom.offis.de/dcmtk.php.en"
+SRC_URI="http://dicom.offis.de/download/dcmtk/snapshot/${MY_P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc png ssl tcpd tiff +threads xml2 zlib"
+
+RDEPEND="media-libs/jpeg
+ png? ( media-libs/libpng )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ tiff? ( media-libs/tiff )
+ xml2? ( dev-libs/libxml2 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-asneeded.patch
+ sed -e "s:share/doc/dcmtk:&-${PV}:" \
+ -e "s:DIR \"/:DIR \"/usr/:" \
+ -e "s:usr/etc:etc:" \
+ -e "s:/lib\":/$(get_libdir)\":" \
+ -e "s:COPYRIGHT::" \
+ -i CMakeLists.txt || die
+ sed -e 's:${CMAKE_INSTALL_PREFIX}/::' \
+ -i dcmwlm/data/CMakeLists.txt doxygen/CMakeLists.txt || die
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DBUILD_SHARED_LIBS=ON
+ -DCMAKE_INSTALL_PREFIX=/
+ $(cmake-utils_use tiff DCMTK_WITH_TIFF)
+ $(cmake-utils_use png DCMTK_WITH_PNG)
+ $(cmake-utils_use xml2 DCMTK_WITH_XML)
+ $(cmake-utils_use zlib DCMTK_WITH_ZLIB)
+ $(cmake-utils_use ssl DCMTK_WITH_OPENSSL)
+ $(cmake-utils_use doc DCMTK_WITH_DOXYGEN)
+ $(cmake-utils_use threads DCMTK_WITH_THREADS)"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+}
diff --git a/sci-libs/dcmtk/files/dcmtk-asneeded.patch b/sci-libs/dcmtk/files/dcmtk-asneeded.patch
new file mode 100644
index 0000000..4d18197
--- /dev/null
+++ b/sci-libs/dcmtk/files/dcmtk-asneeded.patch
@@ -0,0 +1,54 @@
+--- dcmimgle/libsrc/CMakeLists.txt.orig 2010-10-14 12:19:24.416833916 +0200
++++ dcmimgle/libsrc/CMakeLists.txt 2010-10-14 12:18:51.682258692 +0200
+@@ -1,5 +1,5 @@
+ # create library from source files
+ ADD_LIBRARY(dcmimgle dcmimage dibaslut diciefn dicielut didislut didispfn didocu digsdfn digsdlut diimage diinpx diluptab dimo1img dimo2img dimoimg dimoimg3 dimoimg4 dimoimg5 dimomod dimoopx dimopx diovdat diovlay diovlimg diovpln diutils)
+-
++TARGET_LINK_LIBRARIES(dcmimgle dcmdata)
+ # declare installation files
+ INSTALL_TARGETS(${INSTALL_LIBDIR} dcmimgle)
+--- dcmpstat/libsrc/CMakeLists.txt.orig 2010-10-14 12:26:05.324680803 +0200
++++ dcmpstat/libsrc/CMakeLists.txt 2010-10-14 12:26:35.309298272 +0200
+@@ -1,5 +1,5 @@
+ # create library from source files
+ ADD_LIBRARY(dcmpstat dcmpstat dviface dvpsab dvpsabl dvpsal dvpsall dvpscf dvpscu dvpscul dvpsda dvpsdal dvpsfs dvpsga dvpsgal dvpsgl dvpsgll dvpsgr dvpsgrl dvpshlp dvpsib dvpsibl dvpsmsg dvpsov dvpsovl dvpspl dvpspl2 dvpspll dvpspr dvpsprt dvpsri dvpsril dvpsrs dvpsrsl dvpssp dvpsspl dvpssv dvpssvl dvpstat dvpstx dvpstxl dvpsvl dvpsvll dvpsvw dvpsvwl dvsighdl)
+-
++TARGET_LINK_LIBRARIES(dcmpstat dcmdsig dcmtls)
+ # declare installation files
+ INSTALL_TARGETS(${INSTALL_LIBDIR} dcmpstat)
+--- dcmsign/libsrc/CMakeLists.txt.orig 2010-10-14 12:37:02.149984538 +0200
++++ dcmsign/libsrc/CMakeLists.txt 2010-10-14 12:38:53.602332737 +0200
+@@ -1,5 +1,5 @@
+ # create library from source files
+ ADD_LIBRARY(dcmdsig dcsignat siautopr sibrsapr sicert sicertvf sicreapr sidsa simaccon simd5 sinullpr siprivat siripemd sirsa sisha1 sisprof sitypes)
+-
++TARGET_LINK_LIBRARIES(dcmdsig ${OPENSSL_LIBS})
+ # declare installation files
+ INSTALL_TARGETS(${INSTALL_LIBDIR} dcmdsig)
+--- dcmimage/libsrc/CMakeLists.txt.orig 2010-10-14 12:45:06.926394516 +0200
++++ dcmimage/libsrc/CMakeLists.txt 2010-10-14 12:46:05.197437359 +0200
+@@ -1,5 +1,5 @@
+ # create library from source files
+ ADD_LIBRARY(dcmimage diargimg dicmyimg dicoimg dicoopx dicopx dihsvimg dilogger dipalimg dipipng dipitiff diqtctab diqtfs diqthash diqthitl diqtpbox diquant diregist dirgbimg diybrimg diyf2img diyp2img)
+-
++TARGET_LINK_LIBRARIES(dcmimage ${LIBTIFF_LIBS} ${LIBPNG_LIBS})
+ # declare installation files
+ INSTALL_TARGETS(${INSTALL_LIBDIR} dcmimage)
+--- dcmdata/libsrc/CMakeLists.txt.orig 2010-10-14 12:44:00.991741511 +0200
++++ dcmdata/libsrc/CMakeLists.txt 2010-10-14 12:44:55.918954304 +0200
+@@ -1,5 +1,5 @@
+ # create library from source files
+ ADD_LIBRARY(dcmdata cmdlnarg dcbytstr dcchrstr dccodec dcdatset dcddirif dcdicdir dcdicent dcdict dcdictzz dcdirrec dcelem dcerror dcfilefo dchashdi dcistrma dcistrmb dcistrmf dcistrmz dcitem dclist dcmetinf dcobject dcostrma dcostrmb dcostrmf dcostrmz dcpcache dcpixel dcpixseq dcpxitem dcrleccd dcrlecce dcrlecp dcrledrg dcrleerg dcrlerp dcsequen dcstack dcswap dctag dctagkey dctypes dcuid dcwcache dcvm dcvr dcvrae dcvras dcvrat dcvrcs dcvrda dcvrds dcvrdt dcvrfd dcvrfl dcvris dcvrlo dcvrlt dcvrobow dcvrof dcvrpn dcvrpobw dcvrsh dcvrsl dcvrss dcvrst dcvrtm dcvrui dcvrul dcvrulup dcvrus dcvrut dcxfer dcpath vrscan vrscanl)
+-
++TARGET_LINK_LIBRARIES(dcmdata ${ZLIB_LIBS})
+ # declare installation files
+ INSTALL_TARGETS(${INSTALL_LIBDIR} dcmdata)
+--- dcmsr/libsrc/CMakeLists.txt.orig 2010-10-14 14:45:48.736866802 +0200
++++ dcmsr/libsrc/CMakeLists.txt 2010-10-14 14:46:40.910215801 +0200
+@@ -1,5 +1,5 @@
+ # create library from source files
+ ADD_LIBRARY(dcmsr dsrcitem dsrcodtn dsrcodvl dsrcomtn dsrcomvl dsrcontn dsrcsidl dsrdattn dsrdoc dsrdoctn dsrdoctr dsrdtitn dsrimgfr dsrimgtn dsrimgvl dsrnumtn dsrnumvl dsrpnmtn dsrreftn dsrscogr dsrsc3gr dsrscotn dsrsc3tn dsrscovl dsrsc3vl dsrsoprf dsrstrvl dsrtcodt dsrtcosp dsrtcotn dsrtcoto dsrtcovl dsrtextn dsrtimtn dsrtncsr dsrtree dsrtypes dsruidtn dsrwavch dsrwavtn dsrwavvl dsrxmlc dsrxmld dsriodcc dsrbascc dsrenhcc dsrcomcc dsrkeycc dsrmamcc dsrchecc dsrcolcc dsrprocc dsrxrdcc dsrspecc dsrmaccc)
+-
++TARGET_LINK_LIBRARIES(dcmsr ${LIBXML_LIBS})
+ # declare installation files
+ INSTALL_TARGETS(${INSTALL_LIBDIR} dcmsr)
diff --git a/sci-libs/dcmtk/metadata.xml b/sci-libs/dcmtk/metadata.xml
new file mode 100644
index 0000000..fc6991d
--- /dev/null
+++ b/sci-libs/dcmtk/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ DCMTK is a collection of libraries and applications implementing large
+ parts the DICOM standard. It includes software for examining,
+ constructing and converting DICOM image files, handling offline media,
+ sending and receiving images over a network connection, as well as
+ demonstrative image storage and worklist servers.
+ </longdescription>
+ <longdescription lang="fr">
+ DCMTK est un ensemble de bibliothèques et d'application implémentant
+ une grande partie du standard DICOM. Cela comprend des logiciels de
+ visualisation et de conversion des fichier image, de manipulation de
+ médias locaux, de réception et d'envoi d'images à travers un réseau
+ ainsi qu'un serveur d'images et de worklist de demonstration.
+ </longdescription>
+</pkgmetadata>