summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/intel-ocl-sdk/intel-ocl-sdk-1.5.ebuild')
-rw-r--r--dev-util/intel-ocl-sdk/intel-ocl-sdk-1.5.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/intel-ocl-sdk/intel-ocl-sdk-1.5.ebuild b/dev-util/intel-ocl-sdk/intel-ocl-sdk-1.5.ebuild
new file mode 100644
index 0000000..b3780d3
--- /dev/null
+++ b/dev-util/intel-ocl-sdk/intel-ocl-sdk-1.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+EAPI=4
+
+MY_PN=${PN//-/_}
+MY_P=${MY_PN}_${PV}_x64
+INTEL_SDK=/opt/intel/opencl-sdk/
+
+inherit rpm
+
+DESCRIPTION="Intel's implementation of the OpenCL standard optimized for Intel processors."
+HOMEPAGE="http://software.intel.com/en-us/articles/opencl-sdk/"
+SRC_URI="http://software.intel.com/file/35820/${MY_P}.tgz" #BOGUS
+
+LICENSE="Intel-SDP"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 -x86"
+
+#sys-devel/clang
+#dev-libs/boost:1.46
+RDEPEND="dev-cpp/tbb
+ sys-process/numactl"
+DEPEND=""
+
+RESTRICT="mirror"
+QA_EXECSTACK="${INTEL_SDK/\//}lib/libcpu_device.so
+ ${INTEL_SDK/\//}lib/libOclCpuBackEnd.so
+ ${INTEL_SDK/\//}lib/libtask_executor.so"
+QA_PREBUILT="${INTEL_SDK}lib/*"
+
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ rpm_unpack ./${MY_P}.rpm
+}
+
+src_prepare() {
+ cat <<- EOF > "${S}"/intelocl64.icd
+ ${INTEL_SDK}/lib/libintelocl.so
+ EOF
+}
+
+src_install() {
+ insinto ${INTEL_SDK}
+ doins -r usr/include
+
+ insinto ${INTEL_SDK}/lib
+ doins usr/lib64/libOpenCL.so
+ pushd usr/lib64/OpenCL/vendors/intel
+ rm -f libboost* libtbb*
+ doins *.so *rtl *pch
+ popd
+ # things that are left out: llc, ioc
+}