summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libproxy/Manifest3
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.7-gcc47.patch57
-rw-r--r--net-libs/libproxy/libproxy-0.4.7.ebuild77
3 files changed, 0 insertions, 137 deletions
diff --git a/net-libs/libproxy/Manifest b/net-libs/libproxy/Manifest
deleted file mode 100644
index c94d965..0000000
--- a/net-libs/libproxy/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX libproxy-0.4.7-gcc47.patch 1674 RMD160 db229a421000667e169cc85f2210e099c94aefab SHA1 537a5d1f4b69c352fbdf5d4fc5c38171392fe951 SHA256 fce5b8fbc96cbf9aa16b2b783052fbb90130452b5f72005ff604d087d81d049a
-DIST libproxy-0.4.7.tar.gz 91092 RMD160 a09c8320cbabed23c84ceddf3c9b572cf89c9c0e SHA1 b01ebbdf837babf63f38ee34e261d76f23dad319 SHA256 8fe0a58810139ba3c2e186deccf3e68adcd127aa0e972b0862b30b3dde493797
-EBUILD libproxy-0.4.7.ebuild 2314 RMD160 2f94088b4ff21ccf4c7a714b8a3b8981d905c475 SHA1 d5cd46e411ba8a0f08b2cb0529cef1b6ccc977a7 SHA256 7c01df9dc8cc5297561d9f3b45df8c969e169466b88642e8c00f13601f757ee0
diff --git a/net-libs/libproxy/files/libproxy-0.4.7-gcc47.patch b/net-libs/libproxy/files/libproxy-0.4.7-gcc47.patch
deleted file mode 100644
index ac01466..0000000
--- a/net-libs/libproxy/files/libproxy-0.4.7-gcc47.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-http://code.google.com/p/libproxy/source/detail?r=833
-http://code.google.com/p/libproxy/issues/detail?id=173
-https://bugs.gentoo.org/show_bug.cgi?id=412363
-
---- a/libproxy/url.cpp
-+++ b/libproxy/url.cpp
-@@ -33,6 +33,7 @@
- #include <cstdlib> // For atoi()
- #include <sys/stat.h> // For stat()
- #include <algorithm> // For transform()
-+#include <unistd.h> // For read() close()
-
- #ifdef WIN32
- #include <io.h>
---- a/libproxy/modules/pacrunner_webkit.cpp
-+++ b/libproxy/modules/pacrunner_webkit.cpp
-@@ -18,6 +18,7 @@
- ******************************************************************************/
-
- #include "../extension_pacrunner.hpp"
-+#include <unistd.h> // gethostname
- using namespace libproxy;
-
- #ifdef __APPLE__
---- a/libproxy/modules/pacrunner_natus.cpp
-+++ b/libproxy/modules/pacrunner_natus.cpp
-@@ -18,6 +18,7 @@
- ******************************************************************************/
-
- #include "../extension_pacrunner.hpp"
-+#include <unistd.h> // gethostname
- using namespace libproxy;
-
- #define I_ACKNOWLEDGE_THAT_NATUS_IS_NOT_STABLE
---- a/libproxy/modules/pacrunner_mozjs.cpp
-+++ b/libproxy/modules/pacrunner_mozjs.cpp
-@@ -18,6 +18,7 @@
- ******************************************************************************/
-
- #include <cstring> // ?
-+#include <unistd.h> // gethostname
-
- #include "../extension_pacrunner.hpp"
- using namespace libproxy;
---- a/libproxy/modules/config_sysconfig.cpp
-+++ b/libproxy/modules/config_sysconfig.cpp
-@@ -21,7 +21,10 @@
- #include <cstdlib>
- #include <map>
- #include <fstream>
-+#include <unistd.h>
-+#include <sys/types.h>
-
-+
- #include "../extension_config.hpp"
- using namespace libproxy;
- using std::map;
diff --git a/net-libs/libproxy/libproxy-0.4.7.ebuild b/net-libs/libproxy/libproxy-0.4.7.ebuild
deleted file mode 100644
index 9e144d3..0000000
--- a/net-libs/libproxy/libproxy-0.4.7.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.7.ebuild,v 1.9 2012/02/01 02:00:47 ssuominen Exp $
-
-EAPI=4
-PYTHON_DEPEND="python? 2:2.6"
-
-inherit cmake-utils mono python
-
-DESCRIPTION="Library for automatic proxy configuration management"
-HOMEPAGE="http://code.google.com/p/libproxy/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-linux"
-IUSE="gnome kde mono networkmanager perl python test"
-
-# FIXME: Disable webkit support due problems like bug #366791
-# FIXME: Also disable xulrunner support due bug #360893, will be readded
-# in the future when only spidermonkey mozjs is provided.
-# NOTE: USE=xulrunner also causes problems like bug 373397, re-add carefully.
-
-RDEPEND="gnome? ( >=dev-libs/glib-2.26:2 )
- kde? ( >=kde-base/kdelibs-4.4.5 )
- mono? ( dev-lang/mono )
- networkmanager? ( net-misc/networkmanager )
- perl? ( dev-lang/perl )"
-# xulrunner? ( >=net-libs/xulrunner-1.9.1:1.9 )
-# webkit? ( net-libs/webkit-gtk:2 )
-# Since 0.4.7, webkit gtk3 support is also available
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${P}-gcc47.patch )
-
-pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README"
-
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_configure() {
- # WITH_VALA just copies the .vapi file over and needs no deps,
- # hence always enable it unconditionally
- local mycmakeargs=(
- -DPERL_VENDORINSTALL=ON
- -DCMAKE_C_FLAGS="${CFLAGS}"
- -DCMAKE_CXX_FLAGS="${CXXFLAGS}"
- $(cmake-utils_use_with gnome GNOME)
- $(cmake-utils_use_with gnome GNOME3)
- $(cmake-utils_use_with kde KDE4)
- $(cmake-utils_use_with mono DOTNET)
- $(cmake-utils_use_with networkmanager NM)
- $(cmake-utils_use_with perl PERL)
- $(cmake-utils_use_with python PYTHON)
- -DWITH_VALA=ON
- -DWITH_WEBKIT=OFF
- -DWITH_WEBKIT3=OFF
- -DWITH_MOZJS=OFF
- $(cmake-utils_use test BUILD_TESTING)
- )
- #$(cmake-utils_use_with webkit WEBKIT)
- #$(cmake-utils_use_with xulrunner MOZJS)
- cmake-utils_src_configure
-}
-
-pkg_postinst() {
- use python && python_mod_optimize ${PN}.py
-}
-
-pkg_postrm() {
- use python && python_mod_cleanup ${PN}.py
-}