summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2013-02-14 15:45:41 +0800
committerBen de Groot <yngwin@gentoo.org>2013-02-14 15:45:41 +0800
commit3be7058666712c2f3a065af6821528a9b7dd1328 (patch)
tree74e811143030e8224fa710d278d78b8bf82c50bf /www-apps
parentnikola: add new dep (diff)
downloadyngwin-3be7058666712c2f3a065af6821528a9b7dd1328.tar.gz
yngwin-3be7058666712c2f3a065af6821528a9b7dd1328.tar.bz2
yngwin-3be7058666712c2f3a065af6821528a9b7dd1328.zip
sync with gx86
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nikola/nikola-9999.ebuild54
1 files changed, 37 insertions, 17 deletions
diff --git a/www-apps/nikola/nikola-9999.ebuild b/www-apps/nikola/nikola-9999.ebuild
index ddf93ae..b289cef 100644
--- a/www-apps/nikola/nikola-9999.ebuild
+++ b/www-apps/nikola/nikola-9999.ebuild
@@ -1,35 +1,55 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=4
-PYTHON_COMPAT="python2_6 python2_7"
-
-inherit git-2 python-distutils-ng
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} ) # 3_2 should be possible now, but untested
+inherit distutils-r1
DESCRIPTION="A static website and blog generator"
HOMEPAGE="http://nikola.ralsina.com.ar/"
-#SRC_URI="http://nikola-generator.googlecode.com/files/${P}.zip"
-EGIT_REPO_URI="git://github.com/ralsina/nikola.git"
-LICENSE="GPL-3"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ralsina/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://nikola-generator.googlecode.com/files/${P}.zip"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT-with-advertising"
SLOT="0"
-KEYWORDS=""
-IUSE=""
+IUSE="jinja markdown"
-DEPEND=""
-RDEPEND="dev-python/docutils
- dev-python/doit
+DEPEND="dev-python/docutils" # needs rst2man to build manpage
+RDEPEND="${DEPEND}
+ =dev-python/configparser-3.2.0*
+ >=dev-python/doit-0.20.0
dev-python/imaging
+ dev-python/lxml
>=dev-python/mako-0.6
+ >=dev-python/mock-1.0.0
dev-python/pygments
- dev-python/unidecode"
+ dev-python/PyRSS2Gen
+ dev-python/requests
+ dev-python/unidecode
+ dev-python/yapsy
+ jinja? ( dev-python/jinja )
+ markdown? ( dev-python/markdown )"
src_install() {
- python-distutils-ng_src_install
+ distutils-r1_src_install
# hackish way to remove docs that ended up in the wrong place
- rm "${D}"/usr/*.txt
+ rm -rf "${D}"/usr/share/doc/${PN}
+
+ dodoc AUTHORS.txt CHANGES.txt README.md docs/*.txt
+}
- dodoc README.md docs/*
+pkg_postinst() {
+ if has_version '<www-apps/nikola-5.0'; then
+ elog 'Nikola has changed quite a lot since the previous major version.'
+ elog 'Please make sure to read the updated documentation.'
+ fi
}