summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/915resolution')
-rw-r--r--sys-apps/915resolution/915resolution-0.5.2.ebuild40
-rw-r--r--sys-apps/915resolution/Manifest8
-rw-r--r--sys-apps/915resolution/files/digest-915resolution-0.5.23
3 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/915resolution/915resolution-0.5.2.ebuild b/sys-apps/915resolution/915resolution-0.5.2.ebuild
new file mode 100644
index 0000000..0d2e3d1
--- /dev/null
+++ b/sys-apps/915resolution/915resolution-0.5.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Program for changing the resolution of an unavailable VBIOS mode on Intel 915 cards"
+HOMEPAGE="http://www.geocities.com/stomljen/"
+SRC_URI="http://www.geocities.com/stomljen/${PN}-${PV}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+RESTRICT="nomirror"
+S=${WORKDIR}/${PN}-${PV}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ install -m755 -D 915resolution ${D}/usr/sbin/915resolution \
+ || die "install failed"
+ dodoc README.txt
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf.d" 915resolution
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init.d" 915resolution
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "Edit your the config file in /etc/conf.d as you need"
+ einfo "and add 915resolution to the default runlevel."
+ einfo ""
+}
+
diff --git a/sys-apps/915resolution/Manifest b/sys-apps/915resolution/Manifest
new file mode 100644
index 0000000..9657a45
--- /dev/null
+++ b/sys-apps/915resolution/Manifest
@@ -0,0 +1,8 @@
+DIST 915resolution-0.5.2.tar.gz 21183 RMD160 722b352a83f41f0e9822ed4e096e8064f239dcc1 SHA1 9f26eb1b728ca0b2d28c948207b034a49b477089 SHA256 98827dd5adb5ffb5e415b2b28364033ffc173796555051ef52983ec5df77b6d4
+EBUILD 915resolution-0.5.2.ebuild 938 RMD160 c739612c1b786865b7af42890327ad45a6990a3e SHA1 5d3b35eda58539a8874d673091265bee503bb96f SHA256 1aa618ce35a53d352f169459acb8cb178ccfe34a4bd9afe4bcd59b86631c6f19
+MD5 311466032357d1aa16d7212d7e8f6c7b 915resolution-0.5.2.ebuild 938
+RMD160 c739612c1b786865b7af42890327ad45a6990a3e 915resolution-0.5.2.ebuild 938
+SHA256 1aa618ce35a53d352f169459acb8cb178ccfe34a4bd9afe4bcd59b86631c6f19 915resolution-0.5.2.ebuild 938
+MD5 4796a2ce0e9d7cc0f16a63fb5038e352 files/digest-915resolution-0.5.2 256
+RMD160 0dc3039740106b490b01db11cc33adea5bdc37fb files/digest-915resolution-0.5.2 256
+SHA256 a9b1e1c8d39680132cb47bfb19be139315dccd0a537fb97cc3a03eae79bc1499 files/digest-915resolution-0.5.2 256
diff --git a/sys-apps/915resolution/files/digest-915resolution-0.5.2 b/sys-apps/915resolution/files/digest-915resolution-0.5.2
new file mode 100644
index 0000000..a8810e3
--- /dev/null
+++ b/sys-apps/915resolution/files/digest-915resolution-0.5.2
@@ -0,0 +1,3 @@
+MD5 a3441e5662c5ff1e00dc97de4487e8f8 915resolution-0.5.2.tar.gz 21183
+RMD160 722b352a83f41f0e9822ed4e096e8064f239dcc1 915resolution-0.5.2.tar.gz 21183
+SHA256 98827dd5adb5ffb5e415b2b28364033ffc173796555051ef52983ec5df77b6d4 915resolution-0.5.2.tar.gz 21183