summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Snelham <zeypher@gentoo.org>2006-11-08 20:21:06 +0000
committerMatthew Snelham <zeypher@gentoo.org>2006-11-08 20:21:06 +0000
commita7c1359e984d5039161a8c4d2b1df8fb4c11adc8 (patch)
tree96dcc0c426ae35d11155ff6ef8ca5ad08f7c82a1 /sys-kernel/apparmor-sources/apparmor-sources-2.6.18.ebuild
downloadzeypher-a7c1359e984d5039161a8c4d2b1df8fb4c11adc8.tar.gz
zeypher-a7c1359e984d5039161a8c4d2b1df8fb4c11adc8.tar.bz2
zeypher-a7c1359e984d5039161a8c4d2b1df8fb4c11adc8.zip
Initial import of AppArmor ebuilds, October release.
svn path=/; revision=1
Diffstat (limited to 'sys-kernel/apparmor-sources/apparmor-sources-2.6.18.ebuild')
-rw-r--r--sys-kernel/apparmor-sources/apparmor-sources-2.6.18.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/apparmor-sources/apparmor-sources-2.6.18.ebuild b/sys-kernel/apparmor-sources/apparmor-sources-2.6.18.ebuild
new file mode 100644
index 0000000..e173057
--- /dev/null
+++ b/sys-kernel/apparmor-sources/apparmor-sources-2.6.18.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="1"
+inherit eutils kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~x86 ~amd64"
+HOMEPAGE="http://forge.novell.com/modules/xfmod/project/?apparmor"
+DESCRIPTION="Full sources to provide the required AppArmor modules and kernel hooks. Based on the gentoo-sources tree."
+
+MONTH="October"
+UP_KPVER="2.6.18"
+
+AA_SRC="http://forgeftp.novell.com/apparmor/Development%20-%20${MONTH}%20Snapshot/apparmor-kernel-patches-${UP_KPVER}.tar.gz"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${AA_SRC}"
+
+src_unpack() {
+ unpack "apparmor-kernel-patches-${UP_KPVER}.tar.gz"
+
+ kernel-2_src_unpack
+
+ EPATCH_FORCE="yes"
+ EPATCH_OPTS=""
+ epatch ${WORKDIR}/${UP_KPVER}/current/apparmor-2.6.18-v154-fullseries.patch
+}
+
+pkg_postinst() {
+ postinst_sources
+
+ einfo
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+ einfo
+ einfo "Make sure that your kernel configuration file is set with:"
+ einfo " CONFIG_SECURITY=y"
+ einfo " CONFIG_SECURITY_APPARMOR=m"
+ einfo "Without these, apparmor will not function."
+ einfo
+}