aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2019-11-13 11:21:39 +0000
committerNick Clifton <nickc@redhat.com>2019-11-13 11:21:39 +0000
commit415ed2a17588f855397cc2d03aa68a79e84f77f7 (patch)
tree98c0bbe9707745e033e8ce248d087dcf42049f6c
parentgnulib: Fix path to import/Makefile{,.in} (diff)
downloadbinutils-gdb-415ed2a17588f855397cc2d03aa68a79e84f77f7.tar.gz
binutils-gdb-415ed2a17588f855397cc2d03aa68a79e84f77f7.tar.bz2
binutils-gdb-415ed2a17588f855397cc2d03aa68a79e84f77f7.zip
Fix the rule for building C files in the gprof makefile.
PR 2587 * Makefile.am: Fix rule to build .c files from .m files.
-rw-r--r--gprof/ChangeLog5
-rw-r--r--gprof/Makefile.am2
2 files changed, 6 insertions, 1 deletions
diff --git a/gprof/ChangeLog b/gprof/ChangeLog
index 84285aa30de..53921bd4018 100644
--- a/gprof/ChangeLog
+++ b/gprof/ChangeLog
@@ -1,3 +1,8 @@
+2019-11-13 Nick Clifton <nickc@redhat.com>
+
+ PR 2587
+ * Makefile.am: Fix rule to build .c files from .m files.
+
2019-09-18 Alan Modra <amodra@gmail.com>
* corefile.c, * symtab.c: Update throughout for bfd section
diff --git a/gprof/Makefile.am b/gprof/Makefile.am
index c1d5b1c8b8b..0d87ca837fe 100644
--- a/gprof/Makefile.am
+++ b/gprof/Makefile.am
@@ -64,7 +64,7 @@ CONFIG_STATUS_DEPENDENCIES = $(BFDDIR)/development.sh
# This empty rule is a hack against gmake patched by Apple.
%.o:%.m
-.m.c:
+.c.m:
awk -f $(srcdir)/gen-c-prog.awk > $@ \
FUNCTION=`(echo $*|sed -e 's,.*/,,g' -e 's/_bl//')`_blurb \
FILE=$*.m $<