summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwiktor w brodlo <wiktor@brodlo.net>2011-06-09 21:10:07 +0000
committerwiktor w brodlo <wiktor@brodlo.net>2011-06-09 21:10:07 +0000
commitefeb38a7c1235e045e0421a207e9ef19d61bd0c2 (patch)
tree623edb1f189c27f24d2396d25699450b1a3c55fb /dev-python
parentDeps and anaconda, imported from Sabayon (diff)
downloadanaconda-overlay-efeb38a7c1235e045e0421a207e9ef19d61bd0c2.tar.gz
anaconda-overlay-efeb38a7c1235e045e0421a207e9ef19d61bd0c2.tar.bz2
anaconda-overlay-efeb38a7c1235e045e0421a207e9ef19d61bd0c2.zip
Fixed categories
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyblock/Manifest1
-rw-r--r--dev-python/pyblock/pyblock-0.46.ebuild30
-rw-r--r--dev-python/python-cryptsetup/Manifest1
-rw-r--r--dev-python/python-cryptsetup/python-cryptsetup-0.0.10.ebuild21
-rw-r--r--dev-python/python-ethtool/Manifest2
-rw-r--r--dev-python/python-ethtool/python-ethtool-0.3.ebuild16
-rw-r--r--dev-python/python-meh/Manifest2
-rw-r--r--dev-python/python-meh/files/python-meh-keep_exc_win_above.patch11
-rw-r--r--dev-python/python-meh/python-meh-0.8.ebuild35
-rw-r--r--dev-python/python-nss/Manifest3
-rw-r--r--dev-python/python-nss/files/python-nss-fix-path.patch44
-rw-r--r--dev-python/python-nss/python-nss-0.8.ebuild49
-rw-r--r--dev-python/python-report/Manifest5
-rw-r--r--dev-python/python-report/files/bugs.sabayon.org.ini9
-rw-r--r--dev-python/python-report/files/python-report-0.10-disable-rpm.patch20
-rw-r--r--dev-python/python-report/files/python-report-0.10-fix-version-detection.patch22
-rw-r--r--dev-python/python-report/files/python-report-0.10-sabayon-defaults.patch54
-rw-r--r--dev-python/python-report/python-report-0.10-r1.ebuild63
-rw-r--r--dev-python/python-slip/Manifest2
-rw-r--r--dev-python/python-slip/python-slip-0.2.9.ebuild28
20 files changed, 418 insertions, 0 deletions
diff --git a/dev-python/pyblock/Manifest b/dev-python/pyblock/Manifest
new file mode 100644
index 0000000..a4fda35
--- /dev/null
+++ b/dev-python/pyblock/Manifest
@@ -0,0 +1 @@
+EBUILD pyblock-0.46.ebuild 652 RMD160 c1cf0cd06becbab096291a8423ad9559959d9a4a SHA1 7d6313dd0f92e04de12b922c3f2bc0117e60ffc4 SHA256 405a7f655cd7ce7b449234823b700a4659e955908d0d853032bf07d8dafd7129
diff --git a/dev-python/pyblock/pyblock-0.46.ebuild b/dev-python/pyblock/pyblock-0.46.ebuild
new file mode 100644
index 0000000..8906420
--- /dev/null
+++ b/dev-python/pyblock/pyblock-0.46.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2004-2010 Sabayon
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="2"
+EGIT_COMMIT="${PN}-${PV}-1"
+EGIT_REPO_URI="git://git.fedorahosted.org/pyblock.git"
+inherit base git
+
+DESCRIPTION="Python interface for working with block devices"
+HOMEPAGE="http://git.fedoraproject.org/git/pyblock.git?p=pyblock.git;a=summary"
+SRC_URI=""
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="selinux"
+
+DEPEND="${DEPEND}
+ sys-devel/gettext"
+DEPEND="${DEPEND}
+ sys-fs/lvm2
+ sys-fs/dmraid
+ dev-python/pyparted"
+
+src_compile() {
+ local use_selinux=0
+ use selinux && use_selinux=1
+ base_src_compile USESELINUX="${use_selinux}"
+}
diff --git a/dev-python/python-cryptsetup/Manifest b/dev-python/python-cryptsetup/Manifest
new file mode 100644
index 0000000..9952e49
--- /dev/null
+++ b/dev-python/python-cryptsetup/Manifest
@@ -0,0 +1 @@
+EBUILD python-cryptsetup-0.0.10.ebuild 490 RMD160 7c024aa4811c12e64c0784c3f1dac764982c0c72 SHA1 aac7de0021398e9c5b0fd53f73b76a4f657b721e SHA256 a68d6b27b96d535fd5b9ebab985e23644b107d5044003192324bc019e9b09ce6
diff --git a/dev-python/python-cryptsetup/python-cryptsetup-0.0.10.ebuild b/dev-python/python-cryptsetup/python-cryptsetup-0.0.10.ebuild
new file mode 100644
index 0000000..625e454
--- /dev/null
+++ b/dev-python/python-cryptsetup/python-cryptsetup-0.0.10.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+EGIT_REPO_URI="git://git.fedorahosted.org/python-cryptsetup.git"
+EGIT_COMMIT="${P}"
+
+inherit distutils git eutils
+
+DESCRIPTION="Python bindings for Network Security Services (NSS)"
+HOMEPAGE="http://git.fedorahosted.org/git/?p=python-cryptsetup.git"
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-fs/cryptsetup"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/python-ethtool/Manifest b/dev-python/python-ethtool/Manifest
new file mode 100644
index 0000000..ab2e39f
--- /dev/null
+++ b/dev-python/python-ethtool/Manifest
@@ -0,0 +1,2 @@
+DIST python-ethtool-0.3.tar.bz2 18644 RMD160 7145fa6d4231706d1615e851619b88765450ad1c SHA1 76ab1316d59332bc51227034ee575c0a5820fb9e SHA256 eb69cbf8c4c368e829b61521cb0df46c2689453dcecaed7421e2859aa570c43a
+EBUILD python-ethtool-0.3.ebuild 424 RMD160 f2f51e402f70b675194b8557c5100e04d76e0e32 SHA1 bea87ca918e6deae4671a9a67b439393dda080ed SHA256 96654b0871a1e021f889f9cfaa781a186ece4457e1df3a711604bf9e4123a45a
diff --git a/dev-python/python-ethtool/python-ethtool-0.3.ebuild b/dev-python/python-ethtool/python-ethtool-0.3.ebuild
new file mode 100644
index 0000000..6ef467b
--- /dev/null
+++ b/dev-python/python-ethtool/python-ethtool-0.3.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+inherit distutils eutils
+
+DESCRIPTION="Python bindings for the ethtool kernel interface"
+HOMEPAGE="http://git.kernel.org/?p=linux/kernel/git/acme/python-ethtool.git"
+SRC_URI="http://userweb.kernel.org/~acme/python-ethtool/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
diff --git a/dev-python/python-meh/Manifest b/dev-python/python-meh/Manifest
new file mode 100644
index 0000000..b7b705b
--- /dev/null
+++ b/dev-python/python-meh/Manifest
@@ -0,0 +1,2 @@
+AUX python-meh-keep_exc_win_above.patch 490 RMD160 7a248b66fec0f4d19f82d69b8b13dab2ec196086 SHA1 5d9e62919a76235bb0433198ba8831d7aa97220d SHA256 b115dd9391efa2b7a8761a0edd79cbf466458eddba75e03ff3ea76eed5a7d317
+EBUILD python-meh-0.8.ebuild 808 RMD160 6693192ed06ff856de049313308723d4e2501c59 SHA1 5683a45ba52e61994ea6855686a2552195e7c41f SHA256 714db46a9f038773ed6de7948ae0d4ff6229b7c2ac4676fc701ce080671fe0ed
diff --git a/dev-python/python-meh/files/python-meh-keep_exc_win_above.patch b/dev-python/python-meh/files/python-meh-keep_exc_win_above.patch
new file mode 100644
index 0000000..3e1df2b
--- /dev/null
+++ b/dev-python/python-meh/files/python-meh-keep_exc_win_above.patch
@@ -0,0 +1,11 @@
+diff -Nurp python-meh-0.8.orig/meh/ui/gui.py python-meh-0.8/meh/ui/gui.py
+--- python-meh-0.8.orig/meh/ui/gui.py 2010-06-21 15:59:28.983568381 +0200
++++ python-meh-0.8/meh/ui/gui.py 2010-06-21 16:04:34.006524479 +0200
+@@ -139,6 +139,7 @@ class MainExceptionWindow(AbstractMainEx
+ self.dialog.destroy()
+
+ def run(self, *args, **kwargs):
++ self.dialog.set_keep_above(True)
+ self.dialog.show_all()
+ self.rc = self.dialog.run()
+ self.dialog.destroy()
diff --git a/dev-python/python-meh/python-meh-0.8.ebuild b/dev-python/python-meh/python-meh-0.8.ebuild
new file mode 100644
index 0000000..74fd4a6
--- /dev/null
+++ b/dev-python/python-meh/python-meh-0.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+EGIT_REPO_URI="git://git.fedorahosted.org/python-meh.git"
+EGIT_COMMIT="r${PV}-1"
+inherit distutils git eutils
+
+DESCRIPTION="Python exception handling library"
+HOMEPAGE="http://git.fedoraproject.org/git/python-meh.git?p=python-meh.git;a=summary"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+COMMON_DEPEND="dev-util/intltool
+ sys-devel/gettext"
+DEPEND="${COMMON_DEPEND}"
+# FIXME: missing RDEPENDs: rpm, yum
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/newt
+ gtk? ( dev-python/pygtk:2 )
+ dev-python/dbus-python
+ dev-python/python-report
+ net-misc/openssh"
+
+src_prepare() {
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-keep_exc_win_above.patch"
+ distutils_src_prepare
+}
diff --git a/dev-python/python-nss/Manifest b/dev-python/python-nss/Manifest
new file mode 100644
index 0000000..bf32295
--- /dev/null
+++ b/dev-python/python-nss/Manifest
@@ -0,0 +1,3 @@
+AUX python-nss-fix-path.patch 2124 RMD160 1637e30111b9b0115bbc49ce34379869c1cc6e4a SHA1 15fd01f0aee8801f1c408182d67bd636e3b32b3a SHA256 5887e7afb2da1a08857a1faff38fcbe978ac961fc8faaa53b4ceeaa32ac6911a
+DIST python-nss-0.8.tar.lzma 108903 RMD160 e636140ab155e64d99e9eb1b5d574ae1e966cf07 SHA1 ad67c7c5e65be0054c98aea0eced12414208352a SHA256 6af55f01782867b2bc9ce09838c385ba9340c2a0646c3cf1ec1931892f64086a
+EBUILD python-nss-0.8.ebuild 1138 RMD160 24ee0f6f21e483e7209d6cff8efab10385574795 SHA1 64c218f7acec2760f652d4a45c6d64a4436ff4df SHA256 932edb75406d01c26d404e5d3a221e5c26a2907c8342a3efed5f54949459b39c
diff --git a/dev-python/python-nss/files/python-nss-fix-path.patch b/dev-python/python-nss/files/python-nss-fix-path.patch
new file mode 100644
index 0000000..7e679fc
--- /dev/null
+++ b/dev-python/python-nss/files/python-nss-fix-path.patch
@@ -0,0 +1,44 @@
+diff -Nurp python-nss-0.8.orig/setup.py python-nss-0.8/setup.py
+--- python-nss-0.8.orig/setup.py 2009-09-21 21:18:37.000000000 +0200
++++ python-nss-0.8/setup.py 2010-04-01 19:46:44.172982047 +0200
+@@ -310,32 +310,36 @@ extra_compile_args = []
+ nss_error_extension = \
+ Extension('nss.error',
+ sources = ['src/py_nspr_error.c'],
+- include_dirs = ['/usr/include/nss3', '/usr/include/nspr4'],
++ include_dirs = ['/usr/include/nss', '/usr/include/nspr'],
+ libraries = ['nspr4'],
++ library_dirs = ['/usr/lib/nspr', '/usr/lib/nss'],
+ extra_compile_args = extra_compile_args,
+ )
+
+ nss_io_extension = \
+ Extension('nss.io',
+ sources = ['src/py_nspr_io.c'],
+- include_dirs = ['/usr/include/nss3', '/usr/include/nspr4'],
++ include_dirs = ['/usr/include/nss', '/usr/include/nspr'],
+ libraries = ['nspr4'],
++ library_dirs = ['/usr/lib/nspr', '/usr/lib/nss'],
+ extra_compile_args = extra_compile_args,
+ )
+
+ nss_nss_extension = \
+ Extension('nss.nss',
+ sources = ['src/py_nss.c'],
+- include_dirs = ['src', '/usr/include/nss3', '/usr/include/nspr4'],
++ include_dirs = ['src', '/usr/include/nss', '/usr/include/nspr'],
+ libraries = ['nspr4', 'ssl3'],
++ library_dirs = ['/usr/lib/nspr', '/usr/lib/nss'],
+ extra_compile_args = extra_compile_args,
+ )
+
+ nss_ssl_extension = \
+ Extension('nss.ssl',
+ sources = ['src/py_ssl.c'],
+- include_dirs = ['src', '/usr/include/nss3', '/usr/include/nspr4'],
++ include_dirs = ['src', '/usr/include/nss', '/usr/include/nspr'],
+ libraries = ['nspr4', 'ssl3'],
++ library_dirs = ['/usr/lib/nspr', '/usr/lib/nss'],
+ extra_compile_args = extra_compile_args,
+ )
+
diff --git a/dev-python/python-nss/python-nss-0.8.ebuild b/dev-python/python-nss/python-nss-0.8.ebuild
new file mode 100644
index 0000000..4e928df
--- /dev/null
+++ b/dev-python/python-nss/python-nss-0.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="Python bindings for Network Security Services (NSS)"
+HOMEPAGE="http://people.redhat.com/jdennis/python-nss/doc/api/html"
+SRC_URI="mirror://sabayon/${CATEGORY}/${P}.tar.lzma"
+
+LICENSE="|| ( MPL-1.1 GPL-2 LGPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-libs/nss
+ dev-libs/nspr
+ doc? ( dev-python/docutils
+ dev-python/epydoc )"
+
+RDEPEND="${DEPEND}"
+
+RESTRICT_PYTHON_ABIS="3.*"
+DOCS="README doc/ChangeLog"
+
+src_prepare() {
+ epatch "${FILESDIR}"/python-nss-fix-path.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ #TODO fix doc generations
+ if use doc; then
+ einfo "Generating API documentation..."
+
+ PYTHONPATH="${ED}$(python_get_sitedir -f)" epydoc --html --docformat restructuredtext \
+ -o "${S}"/build-2.6/doc/html "${S}"/build-2.6/lib.linux-x86_64-2.6/nss
+
+ dohtml -r "${S}/build/doc/"html/*
+ insinto /usr/share/doc/"${PF}"
+ doins -r ./test
+ insinto /usr/share/doc/"${PF}"/examples
+ doins doc/examples/*.py
+ fi
+}
diff --git a/dev-python/python-report/Manifest b/dev-python/python-report/Manifest
new file mode 100644
index 0000000..3661a5a
--- /dev/null
+++ b/dev-python/python-report/Manifest
@@ -0,0 +1,5 @@
+AUX bugs.sabayon.org.ini 171 RMD160 87fd58ee98c30e9924c569e65bbf7c4b03707095 SHA1 d3769ff4c5d2418bab0128291d337d535ba66b16 SHA256 84060de5c596e836a58d166c12fc373852cfe104da78853b4499acebbc3e92b5
+AUX python-report-0.10-disable-rpm.patch 1292 RMD160 816b671a5418a25f5c3d2874de98eed5bb962127 SHA1 649c42b4c17e03b015badb0c8a70215350111b39 SHA256 38633e72b7265580a33b118deddb3f6cae932f6935a9c40f73fa4ec3e1dab990
+AUX python-report-0.10-fix-version-detection.patch 1038 RMD160 39db9d2b7835a5e5902946e5e623dad3608d3acd SHA1 41ce2a64447e23e7612a1f5b28da953fd96e2233 SHA256 a6e61621ac0a0d3eb0f906e78b6726eee357f0213b41b68e2a1efe4f8788c545
+AUX python-report-0.10-sabayon-defaults.patch 2816 RMD160 16cd841db8789c664c5a3cc2d595e735ecf0fa6b SHA1 3b0ef79a491c5e4bd91d16fee35392762c244e68 SHA256 7e662cea4143c5d3f27646c6250cf57f3e91b29d58bb0aff883e60e1d1478830
+EBUILD python-report-0.10-r1.ebuild 1625 RMD160 c75181e9f255443ac05250e6e09837f68d8149b7 SHA1 14c8a07e1941780074ab9eb7eb7f2162946fd383 SHA256 ddabf039882ae47a4c2c0615f3f8420010f6663df16b816c59a1d7efce701627
diff --git a/dev-python/python-report/files/bugs.sabayon.org.ini b/dev-python/python-report/files/bugs.sabayon.org.ini
new file mode 100644
index 0000000..9fa2982
--- /dev/null
+++ b/dev-python/python-report/files/bugs.sabayon.org.ini
@@ -0,0 +1,9 @@
+[bugs.sabayon.org]
+# template
+template=bugzilla-template
+
+# rhbz url
+bugzilla_host=bugs.sabayon.org
+
+# rhbz login, a password is always asked.
+# username=user@example.com
diff --git a/dev-python/python-report/files/python-report-0.10-disable-rpm.patch b/dev-python/python-report/files/python-report-0.10-disable-rpm.patch
new file mode 100644
index 0000000..501bb70
--- /dev/null
+++ b/dev-python/python-report/files/python-report-0.10-disable-rpm.patch
@@ -0,0 +1,20 @@
+diff -Nurp python-report-0.10.orig/python/report/templates/bugzilla-template/__init__.py python-report-0.10/python/report/templates/bugzilla-template/__init__.py
+--- python-report-0.10.orig/python/report/templates/bugzilla-template/__init__.py 2010-04-02 19:32:19.729109477 +0200
++++ python-report-0.10/python/report/templates/bugzilla-template/__init__.py 2010-04-02 19:32:54.640917830 +0200
+@@ -106,7 +106,6 @@ import filer
+ def sendToBugzilla(component, signature, io, bzfiler,
+ optionsDict, fileName, fileDescription):
+
+- import rpmUtils.arch
+
+ class BugzillaCommunicationException (Exception):
+ pass
+@@ -204,7 +203,7 @@ def sendToBugzilla(component, signature,
+ bug = withBugzillaDo(bzfiler, lambda b: b.createbug(product=bzfiler.getproduct(),
+ component=component,
+ version=bzfiler.getversion(),
+- platform=rpmUtils.arch.getBaseArch(),
++ # platform=rpmUtils.arch.getBaseArch(),
+ bug_severity="medium",
+ priority="medium",
+ op_sys="Linux",
diff --git a/dev-python/python-report/files/python-report-0.10-fix-version-detection.patch b/dev-python/python-report/files/python-report-0.10-fix-version-detection.patch
new file mode 100644
index 0000000..d8f9b95
--- /dev/null
+++ b/dev-python/python-report/files/python-report-0.10-fix-version-detection.patch
@@ -0,0 +1,22 @@
+diff -Nurp python-report-0.10.orig//python/report/templates/bugzilla-template/filer.py python-report-0.10/python/report/templates/bugzilla-template/filer.py
+--- python-report-0.10.orig//python/report/templates/bugzilla-template/filer.py 2010-04-13 23:08:08.849090647 +0200
++++ python-report-0.10/python/report/templates/bugzilla-template/filer.py 2010-04-13 23:09:20.799052132 +0200
+@@ -61,15 +61,11 @@ def getVersion():
+ if os.path.exists(SYSTEM_VERSION_PATH):
+ file = open(SYSTEM_VERSION_PATH, "r")
+ content = file.read()
+- if content.find("Rawhide") > -1:
+- return "rawhide"
+-
+- clist = content.split(" ")
+- i = clist.index("release")
+- return clist[i+1]
++ file.close()
++ return content.strip().split()[-1]
+ else:
+ # default to rawhide
+- return "rawhide"
++ return "unknown"
+
+ class LoginError(Exception):
+ """An error occurred while logging into the bug reporting system."""
diff --git a/dev-python/python-report/files/python-report-0.10-sabayon-defaults.patch b/dev-python/python-report/files/python-report-0.10-sabayon-defaults.patch
new file mode 100644
index 0000000..4af6ec6
--- /dev/null
+++ b/dev-python/python-report/files/python-report-0.10-sabayon-defaults.patch
@@ -0,0 +1,54 @@
+diff -Nurp python-report-0.10.orig/python/report/templates/bugzilla-template/__init__.py python-report-0.10/python/report/templates/bugzilla-template/__init__.py
+--- python-report-0.10.orig/python/report/templates/bugzilla-template/__init__.py 2010-04-02 18:46:19.862030189 +0200
++++ python-report-0.10/python/report/templates/bugzilla-template/__init__.py 2010-04-02 18:56:47.102924468 +0200
+@@ -55,10 +55,10 @@ def displayURL(optionsDict):
+ def bugURL(optionsDict):
+ if 'bugURL' in optionsDict:
+ return optionsDict["bugURL"]
+- host = "bugzilla.redhat.com"
++ host = "bugs.sabayon.org"
+ if 'bugzilla_host' in optionsDict:
+ host = optionsDict["bugzilla_host"]
+- return "https://" + host + "/xmlrpc.cgi"
++ return "http://" + host + "/xmlrpc.cgi"
+
+ def report(signature, io, optionsDict):
+ if not io:
+@@ -130,8 +130,8 @@ def sendToBugzilla(component, signature,
+
+ try:
+ if not bzfiler:
+- bzfiler = filer.BugzillaFiler("https://bugzilla.redhat.com/xmlrpc.cgi",
+- "http://bugzilla.redhat.com",
++ bzfiler = filer.BugzillaFiler("http://bugs.sabayon.org/xmlrpc.cgi",
++ "http://bugs.sabayon.org",
+ filer.getVersion(), filer.getProduct())
+
+ if not bzfiler or not bzfiler.supportsFiling() or not bzfiler.bugUrl:
+diff -Nurp python-report-0.10.orig/python/report/templates/RHEL-template/__init__.py python-report-0.10/python/report/templates/RHEL-template/__init__.py
+--- python-report-0.10.orig/python/report/templates/RHEL-template/__init__.py 2010-04-02 18:46:19.862030189 +0200
++++ python-report-0.10/python/report/templates/RHEL-template/__init__.py 2010-04-02 18:56:33.214921519 +0200
+@@ -55,10 +55,10 @@ def displayURL(optionsDict):
+ def bugURL(optionsDict):
+ if optionsDict.has_key("bugURL"):
+ return optionsDict["bugURL"]
+- host = "bugzilla.redhat.com"
++ host = "bugs.sabayon.org"
+ if optionsDict.has_key("bugzilla_host"):
+ host = optionsDict["bugzilla_host"]
+- return "https://" + host + "/xmlrpc.cgi"
++ return "http://" + host + "/xmlrpc.cgi"
+
+ def report(signature, io, optionsDict):
+ if not io:
+@@ -131,8 +131,8 @@ def sendToBugzilla( component, hashmarke
+
+ try:
+ if not bzfiler:
+- bzfiler = filer.BugzillaFiler("https://bugzilla.redhat.com/xmlrpc.cgi",
+- "http://bugzilla.redhat.com",
++ bzfiler = filer.BugzillaFiler("http://bugs.sabayon.org/xmlrpc.cgi",
++ "http://bugs.sabayon.org",
+ filer.getVersion(), filer.getProduct())
+
+ if not bzfiler or not bzfiler.supportsFiling() or not bzfiler.bugUrl:
diff --git a/dev-python/python-report/python-report-0.10-r1.ebuild b/dev-python/python-report/python-report-0.10-r1.ebuild
new file mode 100644
index 0000000..7bbd08b
--- /dev/null
+++ b/dev-python/python-report/python-report-0.10-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+EGIT_REPO_URI="git://git.fedorahosted.org/report.git"
+EGIT_COMMIT="${PV}"
+inherit base git autotools eutils
+
+DESCRIPTION="Provides a single configurable problem/bug/issue reporting API."
+HOMEPAGE="http://git.fedoraproject.org/git/?p=report.git;a=summary"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/rpm
+ net-misc/curl"
+RDEPEND="dev-libs/openssl
+ net-misc/curl
+ dev-libs/libxml2"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${P}-sabayon-defaults.patch
+ epatch "${FILESDIR}"/${P}-disable-rpm.patch
+ epatch "${FILESDIR}"/${P}-fix-version-detection.patch
+
+ eautoreconf || die "cannot run eautoreconf"
+ autoreconf -i || die "wtf"
+ eautomake || die "cannot run eautomake"
+}
+
+src_configure() {
+ econf --prefix=/usr || die "configure failed"
+}
+
+src_compile() {
+ # workaround crappy build system
+ mkdir -p "${S}/python/report/templates/RHEL-template/bugzillaCopy"
+ touch "${S}/python/report/templates/RHEL-template/bugzillaCopy/VERSION"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ base_src_install
+
+ # remove Red Hat stuff
+ rm "${D}"/etc/report.d/RHEL.ini
+ rm "${D}"/etc/report.d/dropbox.redhat.com.ini
+ rm "${D}"/etc/report.d/bugzilla.redhat.com.ini
+
+ # XXX: {not yet implemented} install Sabayon configuration
+ # cp "${FILESDIR}"/bugs.sabayon.org.ini "${D}/etc/report.d/"
+ find "${D}"/ -name "bugzilla-template" -type d | xargs rm -rf
+ find "${D}"/ -name "RHEL-template" -type d | xargs rm -rf
+ find "${D}"/ -name "strata-template" -type d | xargs rm -rf
+
+}
diff --git a/dev-python/python-slip/Manifest b/dev-python/python-slip/Manifest
new file mode 100644
index 0000000..ad7e135
--- /dev/null
+++ b/dev-python/python-slip/Manifest
@@ -0,0 +1,2 @@
+DIST python-slip-0.2.9.tar.bz2 22017 RMD160 9e1672978857a73b6ad60569aaf8c03aaeeffe29 SHA1 2aeb7a63debb176848f0638dea9d5bdc63f10a15 SHA256 8e2d78af1c94599559d8396c67eae27f6899bee6f4f7ad33e2470cac677ac898
+EBUILD python-slip-0.2.9.ebuild 664 RMD160 9f9c2106ba77ed4528f8231771de4b3af646124b SHA1 b6c4e73478195956b209a2b4d5e4b8eb00db3db8 SHA256 ffee1829993442bdd77d8d9a786f3fd1fa1549a25ffbd6cf317d30d5e8622d91
diff --git a/dev-python/python-slip/python-slip-0.2.9.ebuild b/dev-python/python-slip/python-slip-0.2.9.ebuild
new file mode 100644
index 0000000..5b1d592
--- /dev/null
+++ b/dev-python/python-slip/python-slip-0.2.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+inherit python distutils
+
+DESCRIPTION="The Simple Library for Python packages"
+HOMEPAGE="https://fedorahosted.org/python-slip/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk selinux"
+# TODO: split package?
+RDEPEND="selinux? ( sys-libs/libselinux )
+ dev-python/dbus-python
+ || ( sys-auth/polkit sys-auth/policykit )
+ dev-python/decorator
+ gtk? ( dev-python/pygtk )"
+
+src_compile() {
+ emake || die "cannot run make"
+ distutils_src_compile
+}