aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--autodep_overlay/app-portage/autodep/Manifest3
-rw-r--r--autodep_overlay/app-portage/autodep/autodep-0.4.ebuild46
-rw-r--r--autodep_overlay/app-portage/autodep/autodep-9999.ebuild47
3 files changed, 96 insertions, 0 deletions
diff --git a/autodep_overlay/app-portage/autodep/Manifest b/autodep_overlay/app-portage/autodep/Manifest
index d5663d6..7a518a1 100644
--- a/autodep_overlay/app-portage/autodep/Manifest
+++ b/autodep_overlay/app-portage/autodep/Manifest
@@ -3,7 +3,10 @@ AUX autodep-0.3-build.patch 628 RMD160 e21dc8071b9c3832c2d5da1f34af2364529a8442
DIST autodep-0.1.tar.bz2 960704 RMD160 3934ee314270e35dba78d09567ee889256d70999 SHA1 982221bae181f3bfedb974f13dafa35684276fa0 SHA256 281de88d57649e00d202cb45e36cd47b54908c76ef371a7b6585d2a33717a31a
DIST autodep-0.2.tar.bz2 966275 RMD160 a95fab6b3f769f51d297e0f480a93cc06bd6bbbf SHA1 0cdf7bc76bc2166b8588a92150cf0f592c7e48c6 SHA256 8768ba2918ca9b51a919622d43525dbeb8a3d0873acd7bde234eb06dd222fe78
DIST autodep-0.3.tar.bz2 966193 RMD160 2c8935a77cd7453e19a6f4d6bf45f4dca9c648b3 SHA1 898252ceca7f342a0219419bedca4cdebefa61b9 SHA256 2a2d371757aebdff394b3e7ff5dd0ba6843aad04e2d0ed33cca38d4e929640bd
+DIST autodep-0.4.tar.bz2 967835 RMD160 b1b858b7771ed20993d580b8c331a51238eb13de SHA1 0dc1d839f38d01bb932b72669bb5d9f03b61d5dd SHA256 92fbcfcfd745a613920339302b88624862718216b2b6615ef59ee3a24eafef8c
EBUILD autodep-0.1.ebuild 603 RMD160 96f606f31a227020244e7f2296a39cc1a3141c73 SHA1 3d6e334a3d780faa903d3fc28158e31a6c558bd5 SHA256 dd0d6d415a2cb26648752a95a4a2c651d0d88f6257c01eeaabf8ecb30341b893
EBUILD autodep-0.2.ebuild 1021 RMD160 911343780edf90f988f7190097913cc16edbe80f SHA1 c8a6bafcdb62c991158092d21853fa5c5808bfea SHA256 75234d3696131dd0b702e4854c286df3a3494d66fc741f10e8938bd34b2373a1
EBUILD autodep-0.3.ebuild 1021 RMD160 911343780edf90f988f7190097913cc16edbe80f SHA1 c8a6bafcdb62c991158092d21853fa5c5808bfea SHA256 75234d3696131dd0b702e4854c286df3a3494d66fc741f10e8938bd34b2373a1
+EBUILD autodep-0.4.ebuild 934 RMD160 82a071f2c1e9f161600d854fd7cc96411abec848 SHA1 22c887a2f3cf618093489c5ca74569f58659f335 SHA256 79ab13a0ed94728dae8dcb9e50151c315450b5d96e863ab7d45781495dbc5036
+EBUILD autodep-9999.ebuild 958 RMD160 c2af82a8d3aad0ce329669c427260f6c09448399 SHA1 6f2238588b0ff883f5209f94a61ec95dd2cde938 SHA256 36b98e346e65e76b5fe270778194b17a758c9eff7928b04052486d7f54657905
MISC metadata.xml 236 RMD160 c6016193e6e7f695842ec19ec763036f58bdda4e SHA1 fa16ff69bc55dbe8a1d1b0b35ba003f1721bb827 SHA256 611f4a8c32b3d1653e7e925d9fc3731bca94046e373abacf3e44180cbb707f6c
diff --git a/autodep_overlay/app-portage/autodep/autodep-0.4.ebuild b/autodep_overlay/app-portage/autodep/autodep-0.4.ebuild
new file mode 100644
index 0000000..92ce5ba
--- /dev/null
+++ b/autodep_overlay/app-portage/autodep/autodep-0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
+
+inherit autotools eutils python flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Auto dependency analyser for Gentoo"
+HOMEPAGE="http://soc.dev.gentoo.org/~bay/autodep/"
+SRC_URI="http://soc.dev.gentoo.org/~bay/autodep/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="
+ app-portage/portage-utils
+ sys-fs/fuse"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" RAW_LDFLAGS="$(raw-ldflags)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" libdir="$(get_libdir)" install || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/portage_with_autodep
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/portage_with_autodep
+}
+
diff --git a/autodep_overlay/app-portage/autodep/autodep-9999.ebuild b/autodep_overlay/app-portage/autodep/autodep-9999.ebuild
new file mode 100644
index 0000000..f612cf9
--- /dev/null
+++ b/autodep_overlay/app-portage/autodep/autodep-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+PYTHON_DEPEND="2:2.6"
+RESTRICT_PYTHON_ABIS='2.4 2.5 3.*'
+
+inherit autotools eutils python git-2 flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Auto dependency analyser for Gentoo"
+HOMEPAGE="http://soc.dev.gentoo.org/~bay/autodep/"
+SRC_URI=""
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/autodep.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="
+ app-portage/portage-utils
+ sys-fs/fuse"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" RAW_LDFLAGS="$(raw-ldflags)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" libdir="$(get_libdir)" install || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/portage_with_autodep
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/portage_with_autodep
+}
+