aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek.chauhan@gmail.com>2008-09-17 13:44:12 +0530
committerNirbheek Chauhan <nirbheek.chauhan@gmail.com>2008-09-17 20:28:02 +0530
commit2e1bc5e90b8981af3a298f84987ea75a93efdbef (patch)
tree5e1fdf596299603ae9868562541cce07e3077f2d
parentFix setup.py to include all required files (diff)
downloadautotua-2e1bc5e90b8981af3a298f84987ea75a93efdbef.tar.gz
autotua-2e1bc5e90b8981af3a298f84987ea75a93efdbef.tar.bz2
autotua-2e1bc5e90b8981af3a298f84987ea75a93efdbef.zip
Add an ebuild for the 0.0.1 release of autotua
-rw-r--r--overlay/dev-util/autotua-slave/Manifest2
-rw-r--r--overlay/dev-util/autotua-slave/autotua-slave-0.0.1.ebuild22
-rw-r--r--overlay/profiles/repo_name1
3 files changed, 25 insertions, 0 deletions
diff --git a/overlay/dev-util/autotua-slave/Manifest b/overlay/dev-util/autotua-slave/Manifest
new file mode 100644
index 0000000..392c5a6
--- /dev/null
+++ b/overlay/dev-util/autotua-slave/Manifest
@@ -0,0 +1,2 @@
+DIST autotua-slave-0.0.1.tar.gz 11826 RMD160 d1d5ac2ead86b43c7f8bd3c46787014909604572 SHA1 ee24d87600fcc4d59b124b20d78a47dfa5ea5f4b SHA256 5bd7590be385bc4bb07b37093bafb3f0b73e2b4feacd50ff41b14625b4834126
+EBUILD autotua-slave-0.0.1.ebuild 566 RMD160 f1c59a075b78d6bb7231cd70628b9ba11b175b25 SHA1 d305e03f77057780b420b99803065cc84265836f SHA256 caad8e27a5ebe7265eea202a1586cf4959e7ebdb25a04e2311dbd99ce0bf31b3
diff --git a/overlay/dev-util/autotua-slave/autotua-slave-0.0.1.ebuild b/overlay/dev-util/autotua-slave/autotua-slave-0.0.1.ebuild
new file mode 100644
index 0000000..4df4e42
--- /dev/null
+++ b/overlay/dev-util/autotua-slave/autotua-slave-0.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="The slave client used by the AutotuA devhelp system"
+HOMEPAGE="http://soc.gentooexperimental.org/projects/show/autotua"
+SRC_URI="http://dev.gentooexperimental.org/~bheekling/files/autotua/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="net-misc/connect"
+DEPEND="${RDEPEND}
+ >=dev-lang/python-2.5"
+
+pkg_preinst() {
+ fperms +x /usr/lib/python*/site-packages/autotua/bin/jobuild.sh
+}
diff --git a/overlay/profiles/repo_name b/overlay/profiles/repo_name
new file mode 100644
index 0000000..50d1e65
--- /dev/null
+++ b/overlay/profiles/repo_name
@@ -0,0 +1 @@
+autotua