summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-03-23 00:35:59 +0000
committerMike Frysinger <vapier@gentoo.org>2008-03-23 00:35:59 +0000
commit8b4b0aee3ae956e3284b9ac18547a77f9fbd2a7b (patch)
treec34bac860e691a8bf2657ce3bd1305dc915707f6
parentpunt things moved to openrc (diff)
downloadbaselayout-8b4b0aee3ae956e3284b9ac18547a77f9fbd2a7b.tar.gz
baselayout-8b4b0aee3ae956e3284b9ac18547a77f9fbd2a7b.tar.bz2
baselayout-8b4b0aee3ae956e3284b9ac18547a77f9fbd2a7b.zip
finish merging openrc changes
svn path=/trunk/; revision=3110
-rw-r--r--Makefile25
-rw-r--r--default.mk3
-rw-r--r--etc.BSD/Makefile2
-rw-r--r--etc.Linux/Makefile2
-rw-r--r--etc/Makefile2
-rw-r--r--share.Linux/passwd2
6 files changed, 6 insertions, 30 deletions
diff --git a/Makefile b/Makefile
index 77b4f2d8..616e6f8a 100644
--- a/Makefile
+++ b/Makefile
@@ -7,10 +7,10 @@
# It also has the added bonus of being easier to install on systems
# without an ebuild style package manager.
-SUBDIRS = conf.d etc init.d man net sh share src
+SUBDIRS = etc share
NAME = baselayout
-VERSION = 2.0.0_rc6
+VERSION = 2.0.0
PKG = $(NAME)-$(VERSION)
@@ -21,17 +21,12 @@ OS=BSD
endif
endif
-BASE_DIRS = $(RC_LIB)/init.d $(RC_LIB)/tmp
KEEP_DIRS = /boot /home /mnt /root \
/usr/local/bin /usr/local/sbin /usr/local/share/doc /usr/local/share/man \
/var/lock /var/run
ifeq ($(OS),Linux)
KEEP_DIRS += /dev /sys
- NET_LO = net.lo
-endif
-ifneq ($(OS),Linux)
- NET_LO = net.lo0
endif
TOPDIR = .
@@ -43,22 +38,6 @@ install::
$(INSTALL_DIR) $(DESTDIR)$$x || exit $$? ; \
touch $(DESTDIR)$$x/.keep || exit $$? ; \
done
- # Don't install runlevels if they already exist
- if ! test -d $(DESTDIR)/etc/runlevels ; then \
- (cd runlevels; $(MAKE) install) ; \
- test -d runlevels.$(OS) && (cd runlevels.$(OS); $(MAKE) install) ; \
- $(INSTALL_DIR) $(DESTDIR)/etc/runlevels/single || exit $$? ; \
- $(INSTALL_DIR) $(DESTDIR)/etc/runlevels/nonetwork || exit $$? ; \
- fi
- ln -snf ../../$(RC_LIB)/sh/net.sh $(DESTDIR)/etc/init.d/$(NET_LO) || exit $$?
- ln -snf ../../$(RC_LIB)/sh/functions.sh $(DESTDIR)/etc/init.d || exit $$?
- # Handle lib correctly
- if test $(LIB) != "lib" ; then \
- sed -i'.bak' -e 's,/lib/,/$(LIB)/,g' $(DESTDIR)/$(RC_LIB)/sh/functions.sh || exit $$? ; \
- rm -f $(DESTDIR)/$(RC_LIB)/sh/functions.sh.bak ; \
- sed -i'.bak' -e 's,/lib/,/$(LIB)/,g' $(DESTDIR)/$(RC_LIB)/sh/rc-functions.sh || exit $$? ; \
- rm -f $(DESTDIR)/$(RC_LIB)/sh/rc-functions.sh.bak ; \
- fi
layout:
# Create base filesytem layout
diff --git a/default.mk b/default.mk
index 6cbe1b7a..a2454060 100644
--- a/default.mk
+++ b/default.mk
@@ -4,12 +4,10 @@
DESTDIR = /
ROOT = /
LIB = lib
-RC_LIB = /$(LIB)/rc
#
# Recursive rules
#
-
SUBDIRS_ALL = $(patsubst %,%_all,$(SUBDIRS))
SUBDIRS_CLEAN = $(patsubst %,%_clean,$(SUBDIRS))
SUBDIRS_INSTALL = $(patsubst %,%_install,$(SUBDIRS))
@@ -33,7 +31,6 @@ install:: $(SUBDIRS_INSTALL)
#
# Install rules
#
-
INSTALL_DIR = install -m 0755 -d
INSTALL_EXE = install -m 0755
INSTALL_FILE = install -m 0644
diff --git a/etc.BSD/Makefile b/etc.BSD/Makefile
index b78ea8b4..02f3022b 100644
--- a/etc.BSD/Makefile
+++ b/etc.BSD/Makefile
@@ -1,5 +1,5 @@
DIR = /etc
-FILES = COPYRIGHT issue issue.logo login.conf rc rc.shutdown
+FILES = COPYRIGHT issue issue.logo login.conf
TOPDIR = ..
include $(TOPDIR)/default.mk
diff --git a/etc.Linux/Makefile b/etc.Linux/Makefile
index 8a14505b..1d95b5d3 100644
--- a/etc.Linux/Makefile
+++ b/etc.Linux/Makefile
@@ -1,4 +1,4 @@
-SUBDIRS = modules.d modules.autoload.d
+SUBDIRS = modules.d
DIR = /etc
FILES = filesystems inputrc issue issue.logo
FILES_NOEXIST = sysctl.conf
diff --git a/etc/Makefile b/etc/Makefile
index d93220f3..11e19a9b 100644
--- a/etc/Makefile
+++ b/etc/Makefile
@@ -1,7 +1,7 @@
SUBDIRS = env.d profile.d
DIR = /etc
-FILES = hosts networks profile protocols rc.conf services shells
+FILES = hosts networks profile protocols services shells
TOPDIR = ..
include $(TOPDIR)/default.mk
diff --git a/share.Linux/passwd b/share.Linux/passwd
index b964d8e3..9f2f6984 100644
--- a/share.Linux/passwd
+++ b/share.Linux/passwd
@@ -10,4 +10,4 @@ news:x:9:13:news:/var/spool/news:/bin/false
uucp:x:10:14:uucp:/var/spool/uucp:/bin/false
operator:x:11:0:operator:/root:/bin/bash
portage:x:250:250:portage:/var/tmp/portage:/bin/false
-nobody:x:65534:65534:nobody:/:/bin/false
+nobody:x:65534:65534:nobody:/var/empty:/bin/false