summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-25 21:48:42 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-25 21:48:42 -0600
commitff9fc523397858c2eaa927847570e6e679989ae6 (patch)
tree11a0353b14ef668606130e3b7302007581eec019
parentetc/issue: remove DNS domain name (diff)
downloadbaselayout-ff9fc523397858c2eaa927847570e6e679989ae6.tar.gz
baselayout-ff9fc523397858c2eaa927847570e6e679989ae6.tar.bz2
baselayout-ff9fc523397858c2eaa927847570e6e679989ae6.zip
install the fhs compatible symlinks in the Makefile
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index ecc7b107..29b21c1b 100644
--- a/Makefile
+++ b/Makefile
@@ -60,6 +60,12 @@ install:
./make_os_release ${PV} > $(DESTDIR)/usr/lib/os-release
$(INSTALL_DIR) $(DESTDIR)/usr/share/baselayout
cp -pPR share/* $(DESTDIR)/usr/share/baselayout/
+ # FHS compatibility symlinks
+ ln -snf ../proc/self/mounts $(DESTDIR)/etc/mtab
+ ln -snf ../var/tmp $(DESTDIR)/usr/tmp
+ $(INSTALL_DIR) $(DESTDIR)/var
+ ln -snf ../run $(DESTDIR)/var/run
+ ln -snf ../run/lock $(DESTDIR)/var/lock
layout:
# Create base filesytem layout