summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-15 07:47:23 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-15 07:47:23 +0000
commit28e190ff218be5771f4e58fe414296f818128b26 (patch)
tree38a10d2b522326c3e27c56895a5889d3b26772c3
parentwww-client/chromium-bin-debian: 55.0.2883.75_p3 (diff)
downloadbetagarden-28e190ff218be5771f4e58fe414296f818128b26.tar.gz
betagarden-28e190ff218be5771f4e58fe414296f818128b26.tar.bz2
betagarden-28e190ff218be5771f4e58fe414296f818128b26.zip
net-analyzer/nethogs: Fix after latest tree updates
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--net-analyzer/nethogs/nethogs-9999.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/net-analyzer/nethogs/nethogs-9999.ebuild b/net-analyzer/nethogs/nethogs-9999.ebuild
index 405b6dd..419fc75 100644
--- a/net-analyzer/nethogs/nethogs-9999.ebuild
+++ b/net-analyzer/nethogs/nethogs-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit eutils git-r3 toolchain-funcs
DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
-HOMEPAGE="http://nethogs.sf.net/"
-#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="https://github.com/raboof/nethogs"
+SRC_URI=""
EGIT_REPO_URI="https://github.com/raboof/nethogs.git"
LICENSE="GPL-2"
@@ -17,21 +17,18 @@ KEYWORDS=""
RDEPEND="
net-libs/libpcap
- sys-libs/ncurses
+ sys-libs/ncurses:0=
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
"
-DOCS=( Changelog DESIGN README )
-
-src_prepare() {
- tc-export CC CXX PKG_CONFIG
-}
+DOCS=( DESIGN README.decpcap.txt README.md )
src_compile() {
- emake NCURSES_LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)"
+ tc-export CC CXX PKG_CONFIG
+ emake NCURSES_LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)" ${PN}
}
src_install() {