summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2015-06-30 23:25:11 +0200
committerSebastian Pipping <sebastian@pipping.org>2015-06-30 23:36:15 +0200
commit2ad838e68bc250cfb1740d7cf27d9fd7fc94776f (patch)
tree24765f125b5e39b120381e64c557d18d9e9cfda6
parentmedia-sound/dermixd: 2.0.0 (diff)
downloadbetagarden-2ad838e68bc250cfb1740d7cf27d9fd7fc94776f.tar.gz
betagarden-2ad838e68bc250cfb1740d7cf27d9fd7fc94776f.tar.bz2
betagarden-2ad838e68bc250cfb1740d7cf27d9fd7fc94776f.zip
media-sound/dermixd: 1.6.2
-rw-r--r--media-sound/dermixd/Manifest1
-rw-r--r--media-sound/dermixd/dermixd-1.6.2.ebuild47
-rw-r--r--media-sound/dermixd/files/dermixd-1.6.2-compile.patch121
3 files changed, 169 insertions, 0 deletions
diff --git a/media-sound/dermixd/Manifest b/media-sound/dermixd/Manifest
index 7c02219..54253ce 100644
--- a/media-sound/dermixd/Manifest
+++ b/media-sound/dermixd/Manifest
@@ -1,2 +1,3 @@
DIST Config-Param-3.000010.tar.gz 44568 SHA256 87e8cab1427fe85f53b1aa1e72781f261091488bbf1aab14e5d96e5894074584 SHA512 794ef0bf8353923b40cbf00d49c5d65df67d64aec8001547e4da03f3165bf93590af90f31bdc8292704e6f409fd6691093e84dbcbe0cb5b83f69dacd873ce262 WHIRLPOOL 6705653257cd862accb88d597fc0c205c7a4646abd530551ba601afda79d1efcb916d4c77f404181f70bee4e5bdd71660e6ea70799c5bc6bd1300faafd0bc5a2
+DIST dermixd-1.6.2.tar.bz2 210734 SHA256 93275c344ff0407d140e9faf866f02ecfccaff44b073e02966ff70aacbe47e0a SHA512 6021bde8982cd7d2bc6ce2d79b8d2e69d06baf6a9ca7adce571d7aaf6e7fd56817d17192360fc622fd6622f4e17689965424e5dbc9ab0cfee49ae012f7eaddbc WHIRLPOOL 48f0868a3e89bbd07d9c80f9cc265ac3b835e3f42fbaa762c0b1526b9554bd8f3c90b14d41b90016ba99fcdcf92f3d7e4f481c945dedff0959ccab529659515f
DIST dermixd-2.0.0.tar.bz2 267493 SHA256 7f9f39901a3bc959ab8c9c0e4f7cb2bc12622493c2ce2be0a78f3a971080f2c2 SHA512 fc00156a840dcb8d3034d796b4be76210998a41caf332fe54a2d7ceda78f8e301b1c69f4b7bb09f20aa9f5dff434f53ad560deaf029a652ccdfef3dacd8a4df4 WHIRLPOOL cfae015e1d3e83a9eeb92dc71ca030a84a36ac70f4296cf1490b439376f9825430891f353fc857ad30a58647ceb0b3fe8f44aa625c5e784f4a2a5c892c2e4bfa
diff --git a/media-sound/dermixd/dermixd-1.6.2.ebuild b/media-sound/dermixd/dermixd-1.6.2.ebuild
new file mode 100644
index 0000000..09142d7
--- /dev/null
+++ b/media-sound/dermixd/dermixd-1.6.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Multi-stream music player daemon"
+HOMEPAGE="http://thomas.orgis.org/dermixd/i.shtml"
+SRC_URI="http://thomas.orgis.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-lang/perl
+ media-libs/alsa-lib
+ media-libs/libsndfile
+ media-libs/libvorbis
+ media-sound/mpg123
+ sys-devel/gcc[cxx]
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-compile.patch
+}
+
+src_compile() {
+ emake SNDFILE=yes VORBISFILE=yes gnu-alsa || die
+}
+
+src_install() {
+ # Library
+ insinto /usr/lib/${PN}
+ doins frontend/Param.pm
+ doins -r frontend/DerMixD
+
+ # Commands
+ newbin frontend/simple_player ${PN}-simple-player
+ newbin frontend/shuffle ${PN}-shuffle
+ dobin frontend/${PN}-control
+ dobin ${PN}
+}
diff --git a/media-sound/dermixd/files/dermixd-1.6.2-compile.patch b/media-sound/dermixd/files/dermixd-1.6.2-compile.patch
new file mode 100644
index 0000000..76344aa
--- /dev/null
+++ b/media-sound/dermixd/files/dermixd-1.6.2-compile.patch
@@ -0,0 +1,121 @@
+From f26141183f24c9cea162352cf7aaa982e27b4978 Mon Sep 17 00:00:00 2001
+From: Sebastian Pipping <sebastian@pipping.org>
+Date: Tue, 30 Jun 2015 22:58:10 +0200
+Subject: [PATCH] Add missing libc includes
+
+---
+ audio_fifo.cxx | 1 +
+ in_vorbisfile.cxx | 3 +++
+ input.cxx | 3 +++
+ mixer.cxx | 1 +
+ mixer_data.cxx | 2 ++
+ mixer_tools.cxx | 2 ++
+ param.cxx | 1 +
+ tstring.cxx | 1 +
+ 8 files changed, 14 insertions(+)
+
+diff --git a/audio_fifo.cxx b/audio_fifo.cxx
+index 8a59757..984b287 100644
+--- a/audio_fifo.cxx
++++ b/audio_fifo.cxx
+@@ -40,6 +40,7 @@
+ #include "audio_fifo.hxx"
+ #include "param.hxx"
+ #include "secsleep.hxx"
++#include <cstring> // memcpy
+ #include <sys/time.h>
+
+ void* fifo_reader(void* p)
+diff --git a/in_vorbisfile.cxx b/in_vorbisfile.cxx
+index 376d116..362cda0 100644
+--- a/in_vorbisfile.cxx
++++ b/in_vorbisfile.cxx
+@@ -13,6 +13,9 @@
+ #define ME "vorbisfile_input"
+ #define MEF "vorbis_file"
+
++#include <cstdio> // vsnprintf
++#include <cstring> // memset
++
+ // Hm, actually we talk about vorbus, ogg is generic... but it is the common file name ending.
+ // Dammit, I should code real file type detection... using libmagic... test access.
+ const string vorbisfile_input::t = "ogg";
+diff --git a/input.cxx b/input.cxx
+index 37355a1..97f7356 100644
+--- a/input.cxx
++++ b/input.cxx
+@@ -25,6 +25,9 @@
+ #ifdef IN_SNDFILE
+ #include "in_sndfile.hxx"
+ #endif
++
++#include <strings.h> // strcasecmp
++
+ input_device* new_input_device(string type, input_data& data)
+ {
+ if(strcasecmp(type.c_str(), mpg123_input::t.c_str()) == 0) return new mpg123_input(&data);
+diff --git a/mixer.cxx b/mixer.cxx
+index 7164fa5..2f739bb 100644
+--- a/mixer.cxx
++++ b/mixer.cxx
+@@ -10,6 +10,7 @@
+
+ #include <fcntl.h>
+ #include <signal.h>
++#include <cstring> // memmove
+
+ #include "audio_buffer.hxx"
+ #include "audio_functions.hxx"
+diff --git a/mixer_data.cxx b/mixer_data.cxx
+index 3da6e00..29588e6 100644
+--- a/mixer_data.cxx
++++ b/mixer_data.cxx
+@@ -22,6 +22,8 @@
+ #include "mixer_tools.hxx"
+ #include "communicator_actions.hxx"
+
++#include <strings.h> // strcasecmp
++
+ //#define DEBUG_SCRIPT
+ //#define DEBUG_MIXER2
+ //#define DEBUG_RESET
+diff --git a/mixer_tools.cxx b/mixer_tools.cxx
+index c9f5365..73bc3bc 100644
+--- a/mixer_tools.cxx
++++ b/mixer_tools.cxx
+@@ -19,6 +19,8 @@
+ #include "mixer_data.hxx"
+ #include "mixer_tools.hxx"
+
++#include <strings.h> // strcasecmp
++
+ //#define DEBUG_TOOLS
+
+ string stringstatus(signed char status)
+diff --git a/param.cxx b/param.cxx
+index c3eff1f..d19882c 100644
+--- a/param.cxx
++++ b/param.cxx
+@@ -8,6 +8,7 @@
+ //not depending on dermixd's common header, this stuff can easily tranfserred to other projects or into an independent library
+ #include <cstdlib>
+ #include <cstdio>
++#include <strings.h> // strcasecmp
+ #include <string>
+ #include <vector>
+ using namespace std;
+diff --git a/tstring.cxx b/tstring.cxx
+index 04e91f2..3a6d3cb 100644
+--- a/tstring.cxx
++++ b/tstring.cxx
+@@ -5,6 +5,7 @@
+ (c)2008 Thomas Orgis, licensed under GPLv2
+ */
+ #include "tstring.hxx"
++#include <cstdio> // vsnprintf
+ using namespace std;
+
+ // Chunks for increasing the sprintf buffer.
+--
+2.4.0
+