summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sebastian@pipping.org>2014-09-07 19:44:11 +0200
committerSebastian Pipping <sebastian@pipping.org>2014-09-07 19:44:11 +0200
commit1b57fc50e985e46b953401e863e75306ca15c8ef (patch)
tree14be2652f1e768adfa4678ed84649d6f8a069a52 /dev-libs
parentdev-libs/libecco-bin: 0_p2080406 (diff)
downloadbetagarden-1b57fc50e985e46b953401e863e75306ca15c8ef.tar.gz
betagarden-1b57fc50e985e46b953401e863e75306ca15c8ef.tar.bz2
betagarden-1b57fc50e985e46b953401e863e75306ca15c8ef.zip
dev-libs/libttdht: Ensure that SHA1_* are linked in
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libttdht/files/libttdht-0_p20140917-makefile.patch13
-rw-r--r--dev-libs/libttdht/libttdht-0_p20140917.ebuild3
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-libs/libttdht/files/libttdht-0_p20140917-makefile.patch b/dev-libs/libttdht/files/libttdht-0_p20140917-makefile.patch
new file mode 100644
index 0000000..8477422
--- /dev/null
+++ b/dev-libs/libttdht/files/libttdht-0_p20140917-makefile.patch
@@ -0,0 +1,13 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -26,8 +26,9 @@ libttdht_la_SOURCES = \
+ dhtlog.c
+
+ lib_LTLIBRARIES = libttdht.la
++libttdht_la_LIBADD = -lssl -lcrypto
+
+ check_PROGRAMS = dhttest
+
+ dhttest_SOURCES = dhttest.c
+-dhttest_LDADD = -lssl .libs/libttdht.a
++dhttest_LDADD = .libs/libttdht.la
diff --git a/dev-libs/libttdht/libttdht-0_p20140917.ebuild b/dev-libs/libttdht/libttdht-0_p20140917.ebuild
index 08ad74e..be24419 100644
--- a/dev-libs/libttdht/libttdht-0_p20140917.ebuild
+++ b/dev-libs/libttdht/libttdht-0_p20140917.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit autotools
+inherit eutils autotools
DESCRIPTION="BitTorrent library"
HOMEPAGE="https://github.com/naihe2010/libttdht"
@@ -20,6 +20,7 @@ DEPEND="${RDEPEND}
app-arch/xz-utils"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
eautoreconf || die
rm -R win32 || die
}