summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-07 09:04:41 +0200
committerJustin Lecher <jlec@gentoo.org>2014-11-18 08:05:32 +0100
commitbe7599ebca00e6a4c3ad611ef63166ca18978248 (patch)
treecfc666f844cea8827418f4e6b8bc5faff9b79de6 /dev-vcs
parentgames-board/gambit: Remove, version 1.0.1 added to main repository (diff)
downloadbetagarden-be7599ebca00e6a4c3ad611ef63166ca18978248.tar.gz
betagarden-be7599ebca00e6a4c3ad611ef63166ca18978248.tar.bz2
betagarden-be7599ebca00e6a4c3ad611ef63166ca18978248.zip
dev-vcs/hub: Install additional files
Package-Manager: portage-2.2.14_rc1
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/hub/ChangeLog5
-rw-r--r--dev-vcs/hub/hub-9999.ebuild33
2 files changed, 32 insertions, 6 deletions
diff --git a/dev-vcs/hub/ChangeLog b/dev-vcs/hub/ChangeLog
index 2914a87..3b5f320 100644
--- a/dev-vcs/hub/ChangeLog
+++ b/dev-vcs/hub/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for dev-vcs/hub
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/ChangeLog,v 1.3 2013/05/31 23:14:44 ottxor Exp $
+ 07 Oct 2014; Justin Lecher <jlec@gentoo.org> hub-9999.ebuild:
+ Install additional files
+
25 Dec 2013; Justin Lecher <jlec@gentoo.org> hub-9999.ebuild:
Update to current HEAD
diff --git a/dev-vcs/hub/hub-9999.ebuild b/dev-vcs/hub/hub-9999.ebuild
index f9d8a75..c0c8614 100644
--- a/dev-vcs/hub/hub-9999.ebuild
+++ b/dev-vcs/hub/hub-9999.ebuild
@@ -1,16 +1,21 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-vcs/hub/hub-1.10.6.ebuild,v 1.1 2013/05/31 23:14:44 ottxor Exp $
EAPI="5"
-USE_RUBY="ruby18 ruby19"
+USE_RUBY="ruby19"
RUBY_FAKEGEM_TASK_DOC=
RUBY_FAKEGEM_EXTRADOC="README.md"
-inherit git-r3 readme.gentoo ruby-fakegem
+inherit bash-completion-r1 git-r3 readme.gentoo ruby-fakegem
-ruby_add_bdepend "test? ( dev-ruby/webmock dev-util/cucumber )"
+ruby_add_bdepend "
+ test? (
+ dev-ruby/webmock
+ dev-util/cucumber
+ virtual/ruby-minitest
+ )"
DESCRIPTION="command-line wrapper for git that makes you better at GitHub"
HOMEPAGE="http://defunkt.io/hub/"
@@ -20,7 +25,7 @@ EGIT_REPO_URI="https://github.com/github/hub.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-RDEPEND=">=dev-vcs/git-1.7.3"
+RDEPEND="dev-vcs/git"
DOC_CONTENTS="You may want to add 'alias git=hub' to your .{csh,bash}rc"
@@ -31,7 +36,25 @@ src_unpack() {
git-r3_src_unpack
}
+all_ruby_prepare() {
+ sed -i -e 's/Minitest/MiniTest/g' test/*.rb || die
+}
+
src_install() {
ruby-ng_src_install
readme.gentoo_create_doc
+
+ cd "${S}"/all/${P} || die
+
+ doman man/${PN}.1
+
+ insinto /usr/share/${PN}/
+ doins -r git-hooks
+
+ # Broken with autoloader
+ # https://github.com/github/hub/issues/592
+ #newbashcomp etc/hub.bash_completion.sh ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins etc/hub.zsh_completion ${PN}
}