summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-02-06 22:57:08 +0800
committerBen de Groot <yngwin@gentoo.org>2015-02-06 22:57:08 +0800
commitb80d16e448d2c7e9b66a6206e7c71a4222ba4c89 (patch)
treeb9a8e110642a6a58e2dc7a990ed9f6b4a1aa2092 /games-board
parentnet-dns/inadyn-mt: 02.24.44 (diff)
downloadbetagarden-b80d16e448d2c7e9b66a6206e7c71a4222ba4c89.tar.gz
betagarden-b80d16e448d2c7e9b66a6206e7c71a4222ba4c89.tar.bz2
betagarden-b80d16e448d2c7e9b66a6206e7c71a4222ba4c89.zip
games-board/stockfish: live ebuild
Diffstat (limited to 'games-board')
-rw-r--r--games-board/stockfish/metadata.xml8
-rw-r--r--games-board/stockfish/stockfish-9999.ebuild40
2 files changed, 48 insertions, 0 deletions
diff --git a/games-board/stockfish/metadata.xml b/games-board/stockfish/metadata.xml
new file mode 100644
index 0000000..f2b4a5d
--- /dev/null
+++ b/games-board/stockfish/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-board/stockfish/stockfish-9999.ebuild b/games-board/stockfish/stockfish-9999.ebuild
new file mode 100644
index 0000000..cba1014
--- /dev/null
+++ b/games-board/stockfish/stockfish-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/stockfish/stockfish-6.ebuild,v 1.1 2015/02/05 20:09:33 yngwin Exp $
+
+EAPI=5
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="The strongest chess engine in the world"
+HOMEPAGE="http://stockfishchess.org/"
+EGIT_REPO_URI="git://github.com/official-stockfish/Stockfish.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_popcnt cpu_flags_x86_sse"
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/${P}/src
+
+src_prepare() {
+ sed -e 's:-strip $(BINDIR)/$(EXE)::' -i Makefile
+}
+
+src_compile() {
+ local my_arch
+ use x86 && my_arch=x86-32-old
+ use cpu_flags_x86_sse && my_arch=x86-32
+ use amd64 && my_arch=x86-64
+ use cpu_flags_x86_popcnt && my_arch=x86-64-modern
+ use cpu_flags_x86_avx2 && my_arch=x86-64-bmi2
+
+ emake build ARCH=${my_arch} CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc ../AUTHORS ../Readme.md
+}