summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/rapidsvn/ChangeLog38
-rw-r--r--dev-vcs/rapidsvn/files/rapidsvn-svncpp_link.patch12
-rw-r--r--dev-vcs/rapidsvn/metadata.xml7
-rw-r--r--dev-vcs/rapidsvn/rapidsvn-9999.ebuild94
4 files changed, 0 insertions, 151 deletions
diff --git a/dev-vcs/rapidsvn/ChangeLog b/dev-vcs/rapidsvn/ChangeLog
deleted file mode 100644
index b29740e..0000000
--- a/dev-vcs/rapidsvn/ChangeLog
+++ /dev/null
@@ -1,38 +0,0 @@
-# ChangeLog for dev-vcs/rapidsvn
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-
- 19 Jan 2014; Justin Lecher <jlec@gentoo.org> rapidsvn-9999.ebuild:
- Fix S after moce to git
-
- 07 Jan 2014; Justin Lecher <jlec@gentoo.org> rapidsvn-9999.ebuild:
- Switch from git-2 to git-r3
-
- 04 Jul 2013; Justin Lecher <jlec@gentoo.org> rapidsvn-9999.ebuild:
- Fix for new python eclasses
-
- 19 Feb 2013; Justin Lecher <jlec@gentoo.org> rapidsvn-9999.ebuild,
- metadata.xml:
- Move to new upstream VCS location; move to new python eclasses
-
- 10 Aug 2012; Justin Lecher <jlec@gentoo.org> rapidsvn-9999.ebuild:
- Install missing icons, #430648
-
- 07 Jun 2012; Justin Lecher <jlec@gentoo.org> rapidsvn-9999.ebuild:
- Use append-ccpflags for CPPFLAGS, correct location of icon file
-
- 19 Feb 2012; Justin Lecher <jlec@gentoo.org> Manifest:
- Fix Manifest
-
- 18 Feb 2012; Justin Lecher <jlec@gentoo.org>
- files/rapidsvn-svncpp_link.patch:
- Fix for current HEAD
-
- 01 Feb 2012; Justin Lecher <jlec@gentoo.org> rapidsvn-9999.ebuild:
- Add support for static-libs
-
-*rapidsvn-9999 (31 Jan 2012)
-
- 31 Jan 2012; Justin Lecher <jlec@gentoo.org> +rapidsvn-9999.ebuild,
- +files/rapidsvn-svncpp_link.patch, +metadata.xml:
- Add live ebuild
-
diff --git a/dev-vcs/rapidsvn/files/rapidsvn-svncpp_link.patch b/dev-vcs/rapidsvn/files/rapidsvn-svncpp_link.patch
deleted file mode 100644
index da85858..0000000
--- a/dev-vcs/rapidsvn/files/rapidsvn-svncpp_link.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: src/svncpp/Makefile.am
-===================================================================
---- libsvncpp/Makefile.am
-+++ libsvncpp/Makefile.am
-@@ -27,3 +27,7 @@
- url.cpp \
- wc.cpp
-
-+libsvncpp_la_LIBADD= $(SVN_LIBS) \
-+ $(NEON_LIBS) \
-+ $(APR_LIBS) \
-+ -lstdc++
diff --git a/dev-vcs/rapidsvn/metadata.xml b/dev-vcs/rapidsvn/metadata.xml
deleted file mode 100644
index 2c53357..0000000
--- a/dev-vcs/rapidsvn/metadata.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>maintainer-wanted@gentoo.org</email>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-vcs/rapidsvn/rapidsvn-9999.ebuild b/dev-vcs/rapidsvn/rapidsvn-9999.ebuild
deleted file mode 100644
index 9c8e456..0000000
--- a/dev-vcs/rapidsvn/rapidsvn-9999.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-WX_GTK_VER=2.8
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils fdo-mime flag-o-matic git-r3 python-single-r1 versionator wxwidgets
-
-MY_PV=$(get_version_component_range 1-2)
-MY_REL="1"
-
-DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system"
-HOMEPAGE="http://rapidsvn.tigris.org/"
-SRC_URI=""
-EGIT_REPO_URI="git://github.com/RapidSVN/RapidSVN.git"
-
-LICENSE="GPL-2 LGPL-2.1 FDL-1.2"
-SLOT="0"
-KEYWORDS=""
-IUSE="doc static-libs"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEP="
- ${PYTHON_DEPS}
- dev-libs/apr
- dev-libs/apr-util
- dev-vcs/subversion
- x11-libs/wxGTK:${WX_GTK_VER}[X]"
-DEPEND="${COMMON_DEP}
- doc? (
- dev-libs/libxslt
- app-text/docbook-sgml-utils
- app-doc/doxygen
- app-text/docbook-xsl-stylesheets )"
-RDEPEND="${COMMON_DEP}"
-
-PATCHES=( "${FILESDIR}/${PN}-svncpp_link.patch" )
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-DOCS=( HACKING.txt TRANSLATIONS )
-
-src_prepare() {
- autotools-utils_src_prepare
-}
-
-src_configure() {
- local myeconfargs=( --with-wx-config=${WX_CONFIG} )
-
- if use doc; then
- myeconfargs+=( --with-manpage=yes )
- else
- myeconfargs+=(
- --without-xsltproc
- --with-manpage=no
- --without-doxygen
- --without-dot )
- fi
-
- append-cppflags $( apr-1-config --cppflags )
-
- myeconfargs+=(
- --with-svn-lib="${EPREFIX}"/usr/$(get_libdir)
- --with-svn-include="${EPREFIX}"/usr/include
- --with-apr-config="${EPREFIX}/usr/bin/apr-1-config"
- --with-apu-config="${EPREFIX}/usr/bin/apu-1-config"
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- doicon rapidsvn/res/rapidsvn.ico librapidsvn/src/res/bitmaps/${PN}*.png
- make_desktop_entry rapidsvn "RapidSVN ${PV}" \
- "${EPREFIX}/usr/share/pixmaps/rapidsvn_32x32.png" \
- "RevisionControl;Development"
-
- use doc && dohtml "${S}"/doc/svncpp/html/*
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}