summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/wile/files/wile-1.0.0-josepy.patch')
-rw-r--r--app-crypt/wile/files/wile-1.0.0-josepy.patch80
1 files changed, 0 insertions, 80 deletions
diff --git a/app-crypt/wile/files/wile-1.0.0-josepy.patch b/app-crypt/wile/files/wile-1.0.0-josepy.patch
deleted file mode 100644
index 04382c8..0000000
--- a/app-crypt/wile/files/wile-1.0.0-josepy.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 4a7df693b83dbf8d1d3c5245ad9725e98d24b027 Mon Sep 17 00:00:00 2001
-From: Luka Matijevic <lumatijev@gmail.com>
-Date: Tue, 13 Feb 2018 13:50:55 +0100
-Subject: [PATCH 1/2] Fix JOSE dependency
-
-Starting with ACME version 0.21.0 implementation for JOSE was split out
-of ACME library into a separate package named josepy.
-
-Added josepy as a dependency to setup.py and fixed code according to
-this changes.
-
-https://pypi.python.org/pypi/josepy
-https://github.com/certbot/josepy
----
- setup.py | 1 +
- wile/__init__.py | 2 +-
- wile/cert.py | 2 +-
- 3 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 7a8dc8d..5ed1f03 100755
---- a/setup.py
-+++ b/setup.py
-@@ -28,6 +28,7 @@ def read(filename):
- 'cryptography',
- 'setuptools_scm', # for run-time version-detect
- 'paramiko',
-+ 'josepy',
- ],
- tests_require=[
- 'backports.tempfile;python_version<"3.0"',
-diff --git a/wile/__init__.py b/wile/__init__.py
-index 944b320..1445d10 100644
---- a/wile/__init__.py
-+++ b/wile/__init__.py
-@@ -4,7 +4,7 @@
-
- import setuptools_scm
- import click
--from acme import jose
-+import josepy as jose
- from cryptography.hazmat.primitives import serialization
- from cryptography.hazmat.backends import default_backend
- from cryptography.hazmat.primitives.asymmetric import rsa
-diff --git a/wile/cert.py b/wile/cert.py
-index 4aba7c1..c9fc33b 100644
---- a/wile/cert.py
-+++ b/wile/cert.py
-@@ -13,7 +13,7 @@
- from acme import challenges
- from acme import messages
- from acme import errors
--from acme.jose.util import ComparableX509
-+from josepy.util import ComparableX509
-
- from . import reg
- from . import argtypes
-
-From 62e18a5ef30cd1d88dc90ac5df99f9d66bea5eb1 Mon Sep 17 00:00:00 2001
-From: Luka Matijevic <lumatijev@gmail.com>
-Date: Wed, 14 Feb 2018 14:25:56 +0100
-Subject: [PATCH 2/2] Increased minimal acme version.
-
----
- setup.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/setup.py b/setup.py
-index 5ed1f03..3ad2397 100755
---- a/setup.py
-+++ b/setup.py
-@@ -22,7 +22,7 @@ def read(filename):
- ],
- install_requires=[
- 'six',
-- 'acme >= 0.16.0',
-+ 'acme >= 0.21.0',
- 'click >= 6.0',
- 'pyOpenSSL',
- 'cryptography',