aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheofilos Intzoglou <int.teo@gmail.com>2011-10-05 00:57:42 +0300
committerTheofilos Intzoglou <int.teo@gmail.com>2011-10-05 00:57:42 +0300
commita0fdbc8c237219c1f15d60bae87e2da0ec261564 (patch)
treea32787ecb547489f18d984b022977a2f9bf4671e /src/CMakeLists.txt
parentImplement get_hard_masked and get_path, (diff)
downloadc-portage-a0fdbc8c237219c1f15d60bae87e2da0ec261564.tar.gz
c-portage-a0fdbc8c237219c1f15d60bae87e2da0ec261564.tar.bz2
c-portage-a0fdbc8c237219c1f15d60bae87e2da0ec261564.zip
Port to CMake and add a check for the portage api. If the api is
not available, it will refuse to build the library.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..7eb4403
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,5 @@
+find_package(PythonLibs REQUIRED)
+
+include_directories(${PYTHON_INCLUDE_DIRS})
+add_definitions(-std=c99)
+add_library(cportage dataconnect.c dict.c flag.c interpreter.c packageproperties.c portagesettings.c stringlist.c tester.c)