aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-12-02 21:59:46 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-12-02 21:59:46 +0000
commit2c10c2435b7a56dee5fe6e62daf01e9a62503441 (patch)
tree10642f1a709e101d6e558e8120a3391ce5811b89 /examples
parentOK, just kidding on that last commit. We were already doing rc-update add xd... (diff)
downloadcatalyst-2c10c2435b7a56dee5fe6e62daf01e9a62503441.tar.gz
catalyst-2c10c2435b7a56dee5fe6e62daf01e9a62503441.tar.bz2
catalyst-2c10c2435b7a56dee5fe6e62daf01e9a62503441.zip
Added chost/cflags/cxxflags/ldflags to example spec template.
git-svn-id: svn+ssh://svn.gentoo.org/var/svnroot/catalyst/trunk@934 d1e1f19c-881f-0410-ab34-b69fee027534
Diffstat (limited to 'examples')
-rw-r--r--examples/generic_stage_template.spec29
1 files changed, 29 insertions, 0 deletions
diff --git a/examples/generic_stage_template.spec b/examples/generic_stage_template.spec
index 4a15ddcc..10b7851d 100644
--- a/examples/generic_stage_template.spec
+++ b/examples/generic_stage_template.spec
@@ -58,3 +58,32 @@ distcc_hosts:
# example:
# portage_confdir: /etc/portage
portage_confdir:
+
+# These options are only available when building a stage1 target and are all
+# optional.
+
+# This option is used to change the CHOST from what is default in the profile
+# to whatever you specify. This is useful for building NPTL, for example.
+# example:
+# chost: i686-pc-linux-gnu
+chost:
+
+# This option allows you to change the default CFLAGS that will be used in
+# building this stage. This really should remain generic, as putting
+# optimizations flags here will build a stage1 tarball that is no longer
+# generic.
+# example:
+# cflags: -Os -pipe -fomit-frame-pointer -mcpu=i686
+cflags:
+
+# This is for setting the CXXFLAGS. Generally, this would be set to the same
+# as CFLAGS. In fact, it will mirror CFLAGS by default.
+# example:
+# cxxflags: -Os -pipe -fomit-frame-pointer -mcpu=i686
+cxxflags:
+
+# Setting this option sets LDFLAGS in make.conf in your stage. This would be
+# useful for setting up an embedded or hardened system.
+# example:
+# ldflags: -Wl,-O1 -Wl,-z,now
+ldflags: