summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-09-15 12:14:43 -0400
committerMike Gilbert <floppym@gentoo.org>2016-09-15 12:14:43 -0400
commit5a6c895eb7b1ab210533130a948235ac812e78ef (patch)
tree8b6bf77da4d47a2516eec239555837d62d5ed050
parentextract-cves: simplify output (diff)
downloadchromium-tools-5a6c895eb7b1ab210533130a948235ac812e78ef.tar.gz
chromium-tools-5a6c895eb7b1ab210533130a948235ac812e78ef.tar.bz2
chromium-tools-5a6c895eb7b1ab210533130a948235ac812e78ef.zip
chrome-bump: drop the version suffix from google-chrome
-rwxr-xr-xchrome-bump10
1 files changed, 5 insertions, 5 deletions
diff --git a/chrome-bump b/chrome-bump
index b3f82a5..d8df1fc 100755
--- a/chrome-bump
+++ b/chrome-bump
@@ -26,16 +26,16 @@ PORTDIR = portage.settings.repositories['gentoo'].location
PKGMAP = {
'www-client/google-chrome': {
- '*.ebuild': ('_p', 'google-chrome-stable'),
+ '*.ebuild': ('', 'google-chrome-stable'),
},
'www-client/google-chrome-beta': {
- '*.ebuild': ('_p', 'google-chrome-beta'),
+ '*.ebuild': ('', 'google-chrome-beta'),
},
'www-client/google-chrome-unstable': {
- '*.ebuild': ('_p', 'google-chrome-unstable'),
+ '*.ebuild': ('', 'google-chrome-unstable'),
},
'www-plugins/chrome-binary-plugins': {
- '*_p*.ebuild': ('_p', 'google-chrome-stable'),
+ '*[0123456789].ebuild': ('', 'google-chrome-stable'),
'*_beta*.ebuild': ('_beta', 'google-chrome-beta'),
'*_alpha*.ebuild': ('_alpha', 'google-chrome-unstable'),
},
@@ -98,7 +98,7 @@ def sync_ebuilds(pkg, debs):
found = True
break
if not found:
- copy_ebuild(ebuilds[0], new_ebuild(pn, version, sep, revision))
+ copy_ebuild(ebuilds[0], new_ebuild(pn, version, sep, ''))
changed = True
for ebuild in ebuilds: