aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-02-27 16:41:28 +0100
committerUlrich Müller <ulm@gentoo.org>2021-02-27 16:41:28 +0100
commitf8f963463000ea36cd0c36e7505e678b14395315 (patch)
tree2999c17b0ceaa056a7f25758299bba85f5d78704
parentebuild-writing/functions/src_prepare/epatch: fix whitespace (diff)
downloaddevmanual-f8f963463000ea36cd0c36e7505e678b14395315.tar.gz
devmanual-f8f963463000ea36cd0c36e7505e678b14395315.tar.bz2
devmanual-f8f963463000ea36cd0c36e7505e678b14395315.zip
Makefile: Suppress spurious tidy warnings
tidy-html5 complains about empty URI references in href which are perfectly valid HTML: https://tools.ietf.org/html/std66#section-4.4 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 618b190..5d74d88 100644
--- a/Makefile
+++ b/Makefile
@@ -92,7 +92,8 @@ validate:
tidy: $(HTMLS) $(ECLASS_HTMLS)
@status=0; \
for f in $^; do \
- output=$$(tidy -q -errors --drop-empty-elements no $${f} 2>&1) \
+ output=$$(sed 's/href=""/href="index.html"/' $${f} \
+ | tidy -q -errors --drop-empty-elements no 2>&1) \
|| { status=$$?; echo "Failed on $${f}:"; echo "$${output}"; }; \
done; \
test $${status} -eq 0 && echo "tidy validation successful"; \