aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--appendices/common-problems/text.xml4
-rw-r--r--ebuild-writing/file-format/text.xml4
-rw-r--r--ebuild-writing/variables/text.xml2
-rw-r--r--eclass-writing/text.xml2
-rw-r--r--general-concepts/portage-cache/text.xml6
-rw-r--r--xsl/lang.highlight.ebuild.xsl6
6 files changed, 15 insertions, 9 deletions
diff --git a/appendices/common-problems/text.xml b/appendices/common-problems/text.xml
index bced1db..992f863 100644
--- a/appendices/common-problems/text.xml
+++ b/appendices/common-problems/text.xml
@@ -57,9 +57,9 @@ in use, there are various alternatives:
<p>
Usually when any of the above are used in global scope, it is to manipulate
a version or program name string. These should be avoided in favour of
- pure <c>bash</c> constructs. The <c>versionator</c> eclass is often of use here.
+ pure <c>bash</c> constructs. The <c>eapi7-ver</c> eclass is often of use here.
See <uri link="::ebuild-writing/variables/#Version and Name Formatting Issues"/>,
- <c>man versionator.eclass</c> and <uri
+ <c>man eapi7-ver.eclass</c> and <uri
link="::tools-reference/bash/#Bash Variable Manipulation"/>.
</p>
</dd>
diff --git a/ebuild-writing/file-format/text.xml b/ebuild-writing/file-format/text.xml
index f9e6a4f..2c130af 100644
--- a/ebuild-writing/file-format/text.xml
+++ b/ebuild-writing/file-format/text.xml
@@ -130,8 +130,8 @@ is to use <c>9999</c> as the version (or as the last version component).
<p>
The
-<uri link="::eclass-reference/versionator.eclass">
-versionator.eclass</uri> may be used to manipulate and extract ebuild
+<uri link="::eclass-reference/eapi7-ver.eclass">
+eapi7-ver.eclass</uri> may be used to manipulate and extract ebuild
version components.
</p>
diff --git a/ebuild-writing/variables/text.xml b/ebuild-writing/variables/text.xml
index f2575ad..98babe4 100644
--- a/ebuild-writing/variables/text.xml
+++ b/ebuild-writing/variables/text.xml
@@ -540,7 +540,7 @@ to read.
<p>
Some ebuilds use calls to <c>sed</c>, <c>awk</c> and / or <c>cut</c> to do this. This
must <e>not</e> be done for any new code, and should be fixed to use either
-versionator or bash substitution where possible. Global scope non-bash code is
+eapi7-ver or bash substitution where possible. Global scope non-bash code is
highly discouraged.
</p>
diff --git a/eclass-writing/text.xml b/eclass-writing/text.xml
index db7d9f1..99824e5 100644
--- a/eclass-writing/text.xml
+++ b/eclass-writing/text.xml
@@ -26,7 +26,7 @@ Roughly speaking, there are three kinds of eclass:
<ul>
<li>
Those which provide common functions which are used by many ebuilds (for
- example, <c>eutils</c>, <c>versionator</c>, <c>cvs</c>, <c>bash-completion</c>)
+ example, <c>eutils</c>, <c>eapi7-ver</c>, <c>cvs</c>, <c>bash-completion</c>)
</li>
<li>
Those which provide a basic build system for many similar packages (for
diff --git a/general-concepts/portage-cache/text.xml b/general-concepts/portage-cache/text.xml
index f985d56..13dcfae 100644
--- a/general-concepts/portage-cache/text.xml
+++ b/general-concepts/portage-cache/text.xml
@@ -25,14 +25,14 @@ fi
</codesample>
<p>
-However, this is legal, since <c>versionator.eclass</c> works upon <c>PV</c>, and
+However, this is legal, since <c>eapi7-ver.eclass</c> works upon <c>PV</c>, and
<c>PV</c> and <c>PN</c> are both static:
</p>
<codesample lang="ebuild">
-inherit versionator
+inherit eapi7-ver
-if [[ $(get_major_version) -ge 7 ]] ; then
+if ver_test -ge 7.0 ; then
IUSE="${IUSE} tcltk mzscheme"
DEPEND="${DEPEND}
tcltk? ( dev-lang/tcl )
diff --git a/xsl/lang.highlight.ebuild.xsl b/xsl/lang.highlight.ebuild.xsl
index 4f84b8d..e2b1d72 100644
--- a/xsl/lang.highlight.ebuild.xsl
+++ b/xsl/lang.highlight.ebuild.xsl
@@ -331,6 +331,11 @@
<span class="Statement"><xsl:value-of select="$data"/></span>
</xsl:when>
+ <!-- eapi7-ver -->
+ <xsl:when test="$data = 'ver_rs' or $data = 'ver_cut' or $data = 'ver_test'">
+ <span class="Statement"><xsl:value-of select="$data"/></span>
+ </xsl:when>
+
<!-- No match return -->
<xsl:otherwise>
<xsl:value-of select="$data"/>
@@ -412,3 +417,4 @@
</xsl:template>
</xsl:stylesheet>
+