aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'general-concepts/virtuals/text.xml')
-rw-r--r--general-concepts/virtuals/text.xml16
1 files changed, 9 insertions, 7 deletions
diff --git a/general-concepts/virtuals/text.xml b/general-concepts/virtuals/text.xml
index 377933f..62c739d 100644
--- a/general-concepts/virtuals/text.xml
+++ b/general-concepts/virtuals/text.xml
@@ -1,4 +1,4 @@
-<?xml version="1.0"?>
+<?xml version="1.0" encoding="UTF-8"?>
<guide self="general-concepts/virtuals/">
<chapter>
<title>Virtuals</title>
@@ -24,17 +24,17 @@ An example of a virtual:
</p>
<codesample lang="ebuild">
-EAPI=7
+EAPI=8
DESCRIPTION="Virtual for C++ tr1 &lt;type_traits&gt;"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
RDEPEND="|| ( &gt;=sys-devel/gcc-4.1 dev-libs/boost )"
</codesample>
<p>
-Looks familar...right? It should since its going to look just like a regular
+Looks familar...right? It should since it's going to look just like a regular
ebuild.
</p>
@@ -95,7 +95,7 @@ For example, a virtual for different packages providing ABI-compatible
</p>
<codesample lang="ebuild">
-EAPI=6
+EAPI=8
DESCRIPTION="Virtual for libfoo.so.1"
SLOT="0/1"
@@ -124,10 +124,11 @@ would contain:
</p>
<codesample lang="ebuild">
-EAPI=6
+EAPI=8
DESCRIPTION="Virtual for libfoo.so.0"
SLOT="0/0"
+
RDEPEND="dev-libs/libfoo:0/0"
</codesample>
@@ -136,10 +137,11 @@ while <c>virtual/libfoo-1.ebuild</c> would contain:
</p>
<codesample lang="ebuild">
-EAPI=6
+EAPI=8
DESCRIPTION="Virtual for libfoo.so.1"
SLOT="0/1"
+
RDEPEND="dev-libs/newfoo:0/1"
</codesample>