aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-02-24 18:00:57 +0100
committerUlrich Müller <ulm@gentoo.org>2024-02-24 18:00:57 +0100
commite4ebd98af5240843848d297811e6c856bb8db1cb (patch)
treeb533d14d598df47d5fdd61e86843f2ab55440cb5
parentFix implicit function declarations in configure.ac (diff)
downloademacs-patches-e4ebd98af5240843848d297811e6c856bb8db1cb.tar.gz
emacs-patches-e4ebd98af5240843848d297811e6c856bb8db1cb.tar.bz2
emacs-patches-e4ebd98af5240843848d297811e6c856bb8db1cb.zip
Remove 29.1 patchset
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--emacs/29.1/01_all_xdisp-segfault.patch32
-rw-r--r--emacs/29.1/02_all_modeline.patch28
-rw-r--r--emacs/29.1/03_all_zlib-inflate.patch22
-rw-r--r--emacs/29.1/04_all_tree-sitter.patch21
-rw-r--r--emacs/29.1/05_all_small-ja-dic.patch92
-rw-r--r--emacs/29.1/06_all_sanity-check.patch13
-rw-r--r--emacs/29.1/07_all_epg-gpmsm.patch38
7 files changed, 0 insertions, 246 deletions
diff --git a/emacs/29.1/01_all_xdisp-segfault.patch b/emacs/29.1/01_all_xdisp-segfault.patch
deleted file mode 100644
index 835185b..0000000
--- a/emacs/29.1/01_all_xdisp-segfault.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-Fix segmentation fault due to invalid mode-line-format
-Patch backported from master branch
-https://debbugs.gnu.org/64893
-
-commit 7ea3f39deec3d54914077455e70605a14eb7d200
-Author: Eli Zaretskii <eliz@gnu.org>
-Date: Thu Jul 27 15:34:38 2023 +0300
-
- Avoid crashes due to invalid 'mode-line-format'
-
- * src/xdisp.c (display_mode_element, redisplay_window_error):
- Don't take XCAR of what can be Qnil. (Bug#64893)
-
---- emacs-29.1/src/xdisp.c
-+++ emacs-29.1/src/xdisp.c
-@@ -17601,6 +17601,7 @@ redisplay_window_error (Lisp_Object erro
- if (max_redisplay_ticks > 0
- && CONSP (error_data)
- && EQ (XCAR (error_data), Qerror)
-+ && CONSP (XCDR (error_data))
- && STRINGP (XCAR (XCDR (error_data))))
- Vdelayed_warnings_list = Fcons (list2 (XCAR (error_data),
- XCAR (XCDR (error_data))),
-@@ -27091,7 +27092,7 @@ display_mode_element (struct it *it, int
-
- oprops = Fcopy_sequence (oprops);
- tem = props;
-- while (CONSP (tem))
-+ while (CONSP (tem) && CONSP (XCDR (tem)))
- {
- oprops = plist_put (oprops, XCAR (tem),
- XCAR (XCDR (tem)));
diff --git a/emacs/29.1/02_all_modeline.patch b/emacs/29.1/02_all_modeline.patch
deleted file mode 100644
index d51a79e..0000000
--- a/emacs/29.1/02_all_modeline.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Avoid spurious whitespace in the modeline
-Patch backported from master branch
-https://debbugs.gnu.org/58183
-
-commit 8c3338f6ba354218aee12c223d778be4180f892b
-Author: Ulrich Müller <ulm@gentoo.org>
-Date: Fri Jul 28 12:21:42 2023 +0200
-
- Avoid spurious whitespace in the modeline of emacsclient frames
-
- * lisp/bindings.el (mode-line-client): Compute 'help-echo text
- property in advance. (Bug#58183)
-
---- emacs-29/lisp/bindings.el
-+++ emacs-29/lisp/bindings.el
-@@ -226,9 +226,9 @@ mode-line-mule-info
- (put 'mode-line-mule-info 'risky-local-variable t)
-
- (defvar mode-line-client
-- `(""
-- (:propertize ("" (:eval (if (frame-parameter nil 'client) "@" "")))
-- help-echo ,(purecopy "emacsclient frame")))
-+ `(:eval
-+ (if (frame-parameter nil 'client)
-+ ,(propertize "@" 'help-echo (purecopy "emacsclient frame"))))
- "Mode line construct for identifying emacsclient frames.")
- ;; Autoload if this file no longer dumped.
- ;;;###autoload
diff --git a/emacs/29.1/03_all_zlib-inflate.patch b/emacs/29.1/03_all_zlib-inflate.patch
deleted file mode 100644
index b31847a..0000000
--- a/emacs/29.1/03_all_zlib-inflate.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-Support decompressing pigz-compressed files
-Patch from master branch
-https://bugs.gentoo.org/911539
-https://debbugs.gnu.org/64893
-
-commit 46b6d175054e8f6bf7cb45e112048c0cf02bfee9
-Author: Amritpal Singh <sysgrammer@protonmail.com>
-Date: Fri Jun 2 10:51:21 2023 +0530
-
- Support files compressed by 'pigz'
-
---- a/src/decompress.c
-+++ b/src/decompress.c
-@@ -151,7 +151,7 @@
- return -1;
-
- accumulate_and_process_md5 (out, MD5_BLOCKSIZE - stream.avail_out, &ctx);
-- } while (!stream.avail_out);
-+ } while (stream.avail_in && !stream.avail_out);
-
- } while (res != Z_STREAM_END);
-
diff --git a/emacs/29.1/04_all_tree-sitter.patch b/emacs/29.1/04_all_tree-sitter.patch
deleted file mode 100644
index b49c542..0000000
--- a/emacs/29.1/04_all_tree-sitter.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Fix build failure with tree-sitter
-Patch from emacs-29 branch
-https://bugs.gentoo.org/911826
-https://debbugs.gnu.org/65123
-
-commit e1874c4e8bff165abc5c2e842b4381b65da67ebb
-Author: Eli Zaretskii <eliz@gnu.org>
-Date: Mon Aug 7 16:20:17 2023 +0300
-
- * configure.ac (HAVE_TREE_SITTER): Set NEED_DYNLIB=yes (bug#65123).
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -3254,6 +3254,7 @@ AC_DEFUN
- [HAVE_TREE_SITTER=yes], [HAVE_TREE_SITTER=no])
- if test "${HAVE_TREE_SITTER}" = yes; then
- AC_DEFINE(HAVE_TREE_SITTER, 1, [Define if using tree-sitter.])
-+ NEED_DYNLIB=yes
- else
- EMACS_CHECK_MODULES([TREE_SITTER], [tree-sitter >= 0.6.3],
- [HAVE_TREE_SITTER=yes], [HAVE_TREE_SITTER=no])
diff --git a/emacs/29.1/05_all_small-ja-dic.patch b/emacs/29.1/05_all_small-ja-dic.patch
deleted file mode 100644
index 117edbd..0000000
--- a/emacs/29.1/05_all_small-ja-dic.patch
+++ /dev/null
@@ -1,92 +0,0 @@
-Regenerate Japanese dictionary with --with-small-ja-dic option
-Patch from emacs-29 branch
-https://debbugs.gnu.org/66125
-
-Also update the following generated files:
-* leim/small-ja-dic-option
-* lisp/leim/ja-dic/ja-dic.{el,elc}
-
-commit 7d5fee0feaa5740f3fbbfc6d5f13855bf58b9c25
-Author: Eli Zaretskii <eliz@gnu.org>
-Date: Sun Sep 24 15:30:01 2023 +0300
-
- Support regeneration of ja-dic.el under '--with-small-ja-dic'
-
---- a/.gitignore
-+++ b/.gitignore
-@@ -95,6 +95,7 @@ lisp/cedet/semantic/grammar-wy.el
- lisp/eshell/esh-groups.el
- lisp/finder-inf.el
- lisp/leim/ja-dic/
-+leim/small-ja-dic-option
- lisp/leim/leim-list.el
- lisp/leim/quail/4Corner.el
- lisp/leim/quail/ARRAY30.el
---- a/leim/Makefile.in
-+++ b/leim/Makefile.in
-@@ -26,6 +26,7 @@ SHELL =
- # Here are the things that we expect ../configure to edit.
- srcdir=@srcdir@
- top_builddir = @top_builddir@
-+top_srcdir = @top_srcdir@
-
- # Where the generated files go.
- leimdir = ${srcdir}/../lisp/leim
-@@ -134,9 +135,15 @@ ${leimdir}/leim-list.el:
-
- ${leimdir}/ja-dic/ja-dic.el: | $(leimdir)/ja-dic
-
-+# This is used to support regeneration of ja-dic when the SMALL_JA_DIC
-+# option is flipped by the configure-time option.
-+small-ja-dic-option: ../config.status
-+ $(AM_V_GEN)echo "Small ja-dic option: $(SMALL_JA_DIC)" > $@.$$$$ && \
-+ ${top_srcdir}/build-aux/move-if-change $@.$$$$ $@
-+
- .PHONY: generate-ja-dic
- generate-ja-dic: ${leimdir}/ja-dic/ja-dic.el
--${leimdir}/ja-dic/ja-dic.el: $(srcdir)/SKK-DIC/SKK-JISYO.L
-+${leimdir}/ja-dic/ja-dic.el: $(srcdir)/SKK-DIC/SKK-JISYO.L small-ja-dic-option
- $(AM_V_GEN)$(RUN_EMACS) -batch -l ja-dic-cnv \
- -f batch-skkdic-convert -dir "$(leimdir)/ja-dic" $(JA_DIC_NO_REDUCTION_OPTION) "$<"
-
---- a/lisp/international/ja-dic-cnv.el
-+++ b/lisp/international/ja-dic-cnv.el
-@@ -346,6 +346,8 @@ skkdic-convert
- (erase-buffer)
- (buffer-disable-undo)
- (generate-lisp-file-heading ja-dic-filename 'skkdic-convert :code nil)
-+ (insert (format ";; Generated with small ja-dic option: %s\n\n"
-+ (if no-reduction "no" "yes")))
- (insert ";; Original SKK dictionary file: "
- (file-relative-name (expand-file-name filename) dirname)
- "\n\n"
---- a/make-dist
-+++ b/make-dist
-@@ -357,6 +357,7 @@ possibly_non_vc_files=
- MANIFEST aclocal.m4 configure
- admin/charsets/jisx2131-filter
- src/config.in
-+ leim/small-ja-dic-option
- "$(
- find admin doc etc lisp \
- \( -name '*.el' -o -name '*.elc' -o -name '*.map' -o -name '*.stamp' \
---- /dev/null
-+++ b/leim/small-ja-dic-option
-@@ -0,0 +1 @@
-+Small ja-dic option: no
---- a/lisp/leim/ja-dic/ja-dic.el
-+++ b/lisp/leim/ja-dic/ja-dic.el
-@@ -3,6 +3,8 @@
-
- ;; This file is part of GNU Emacs.
-
-+;; Generated with small ja-dic option: no
-+
- ;; Original SKK dictionary file: ../../../leim/SKK-DIC/SKK-JISYO.L
-
- ;;; Start of the header of the original SKK dictionary.
---- a/lisp/leim/ja-dic/ja-dic.elc
-+++ b/lisp/leim/ja-dic/ja-dic.elc
-@@ -5,1 +5,1 @@
--
-+
diff --git a/emacs/29.1/06_all_sanity-check.patch b/emacs/29.1/06_all_sanity-check.patch
deleted file mode 100644
index 6509cf7..0000000
--- a/emacs/29.1/06_all_sanity-check.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://bugs.gentoo.org/916180
-
---- emacs-29.1/Makefile.in
-+++ emacs-29.1/Makefile.in
-@@ -417,7 +417,7 @@
-
- sanity-check:
- @[ -f .no-advice-on-failure ] && exit 0; true
-- @v=$$(src/emacs${EXEEXT} --batch --eval \
-+ @v=$$(src/emacs${EXEEXT} --batch --quick --eval \
- '(progn (defun f (n) (if (= 0 n) 1 (* n (f (- n 1))))) (princ (f 10)))' \
- 2> /dev/null); \
- [ "X$$v" = "X3628800" ] && exit 0; \
diff --git a/emacs/29.1/07_all_epg-gpmsm.patch b/emacs/29.1/07_all_epg-gpmsm.patch
deleted file mode 100644
index 646798c..0000000
--- a/emacs/29.1/07_all_epg-gpmsm.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Don't enable pinentry loopback mode for gpgsm
-Patch from master branch
-https://debbugs.gnu.org/67012
-
-commit e736a1b5a2aa2dd8dbaba32a408db70822fe434f
-Author: Ulrich Müller <ulm@gentoo.org>
-Date: Fri Nov 17 12:16:54 2023 +0100
-
- Don't enable pinentry loopback mode for gpgsm
-
---- a/doc/misc/epa.texi
-+++ b/doc/misc/epa.texi
-@@ -640,6 +640,9 @@ GnuPG Pinentry
- Emacs.
- @end enumerate
-
-+Note that loopback Pinentry does not work with @command{gpgsm},
-+therefore EasyPG will ignore this setting for it.
-+
- There are other options available to use Emacs as Pinentry, you might
- come across a Pinentry called @command{pinentry-emacs} or
- @command{gpg-agent} option @code{allow-emacs-pinentry}. However,
---- a/lisp/epg.el
-+++ b/lisp/epg.el
-@@ -595,7 +595,12 @@ epg--start
- (if (epg-context-textmode context) '("--textmode"))
- (if (epg-context-output-file context)
- (list "--output" (epg-context-output-file context)))
-- (if (epg-context-pinentry-mode context)
-+ (if (and (epg-context-pinentry-mode context)
-+ (not
-+ ;; loopback doesn't work with gpgsm
-+ (and (eq (epg-context-protocol context) 'CMS)
-+ (eq (epg-context-pinentry-mode context)
-+ 'loopback))))
- (list "--pinentry-mode"
- (symbol-name (epg-context-pinentry-mode
- context))))