aboutsummaryrefslogtreecommitdiff
path: root/emacs
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-02-20 00:05:21 +0100
committerUlrich Müller <ulm@gentoo.org>2023-02-20 00:05:21 +0100
commitdcc08aa9261b6dd3c61781c81354ba9f88c35ff9 (patch)
treef1b72b3b37c965144a61ec897209cf9c2094dd84 /emacs
parentSupport webkit2gtk-4.1 (diff)
downloademacs-patches-dcc08aa9261b6dd3c61781c81354ba9f88c35ff9.tar.gz
emacs-patches-dcc08aa9261b6dd3c61781c81354ba9f88c35ff9.tar.bz2
emacs-patches-dcc08aa9261b6dd3c61781c81354ba9f88c35ff9.zip
28.3: Copy patchset from 28.2
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'emacs')
-rw-r--r--emacs/28.3/01_all_libseccomp.patch15
-rw-r--r--emacs/28.3/03_all_webkit-4.1.patch26
2 files changed, 41 insertions, 0 deletions
diff --git a/emacs/28.3/01_all_libseccomp.patch b/emacs/28.3/01_all_libseccomp.patch
new file mode 100644
index 0000000..ecbbba0
--- /dev/null
+++ b/emacs/28.3/01_all_libseccomp.patch
@@ -0,0 +1,15 @@
+libseccomp is detected by configure but doesn't appear to have any
+effect on the installed image. For now, disable it unconditionally.
+https://bugs.gentoo.org/857906
+
+--- emacs-28.2/configure.ac
++++ emacs-28.2/configure.ac
+@@ -4373,7 +4373,7 @@
+ ]])])
+ AC_SUBST([HAVE_SECCOMP])
+
+-EMACS_CHECK_MODULES([LIBSECCOMP], [libseccomp >= 2.5.2])
++HAVE_LIBSECCOMP=no
+ AC_SUBST([HAVE_LIBSECCOMP])
+ AC_SUBST([LIBSECCOMP_LIBS])
+ AC_SUBST([LIBSECCOMP_CFLAGS])
diff --git a/emacs/28.3/03_all_webkit-4.1.patch b/emacs/28.3/03_all_webkit-4.1.patch
new file mode 100644
index 0000000..950fd78
--- /dev/null
+++ b/emacs/28.3/03_all_webkit-4.1.patch
@@ -0,0 +1,26 @@
+Migrate from net-libs/webkit-gtk:4 to :4.1
+Backported from emacs-29 branch
+https://bugs.gentoo.org/893670
+
+commit 7287b7b53a17f9b2d1b474466106806a9d57af47
+Author: Ulrich Müller <ulm@gentoo.org>
+Date: Thu Feb 9 10:58:48 2023 +0100
+
+ Support webkit2gtk-4.1
+
+--- emacs-28.2/configure.ac
++++ emacs-28.2/configure.ac
+@@ -2784,8 +2784,12 @@
+ if test "$with_xwidgets" != "no"; then
+ if test "$USE_GTK_TOOLKIT" = "GTK3" && test "$window_system" != "none"; then
+ WEBKIT_REQUIRED=2.12
+- WEBKIT_MODULES="webkit2gtk-4.0 >= $WEBKIT_REQUIRED"
++ WEBKIT_MODULES="webkit2gtk-4.1 >= $WEBKIT_REQUIRED"
+ EMACS_CHECK_MODULES([WEBKIT], [$WEBKIT_MODULES])
++ if test "$HAVE_WEBKIT" = "no"; then
++ WEBKIT_MODULES="webkit2gtk-4.0 >= $WEBKIT_REQUIRED"
++ EMACS_CHECK_MODULES([WEBKIT], [$WEBKIT_MODULES])
++ fi
+ HAVE_XWIDGETS=$HAVE_WEBKIT
+ XWIDGETS_OBJ="xwidget.o"
+ elif test "${NS_IMPL_COCOA}" = "yes"; then