summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emacs/26.3/07_all_configure-decl.patch66
-rw-r--r--emacs/27.2/08_all_configure-decl.patch66
-rw-r--r--emacs/28.2/09_all_configure-decl.patch66
-rw-r--r--emacs/29.2/03_all_configure-decl.patch52
4 files changed, 250 insertions, 0 deletions
diff --git a/emacs/26.3/07_all_configure-decl.patch b/emacs/26.3/07_all_configure-decl.patch
new file mode 100644
index 0000000..ac55b9f
--- /dev/null
+++ b/emacs/26.3/07_all_configure-decl.patch
@@ -0,0 +1,66 @@
+Fix implicit function declarations in configure.ac (XOpenDisplay, malloc)
+Backported from master branch
+https://bugs.gentoo.org/898304
+
+commit 6c1413d5ef0d1fea639b0d8c83a0c0065d99359b
+Author: Florian Weimer <fweimer@redhat.com>
+Date: Fri Dec 23 18:49:25 2022 +0100
+
+ configure: Remove obsolete check for -b i486-linuxaout
+
+commit 121a9ff9f6fc69066ce30c2dbe6cbfbfdca6aeaa
+Author: Florian Weimer <fweimer@redhat.com>
+Date: Fri Dec 23 18:51:08 2022 +0100
+
+ Fix alternate stack test in configure
+
+--- emacs-26.3/configure.ac
++++ emacs-26.3/configure.ac
+@@ -2421,39 +2421,6 @@
+ export LD_RUN_PATH
+ fi
+
+- if test "${opsys}" = "gnu-linux"; then
+- AC_CACHE_CHECK([whether X on GNU/Linux needs -b to link], [emacs_cv_b_link],
+- [AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
+- [[XOpenDisplay ("foo");]])],
+- [xgnu_linux_first_failure=no],
+- [xgnu_linux_first_failure=yes])
+- if test "${xgnu_linux_first_failure}" = "yes"; then
+- OLD_CPPFLAGS="$CPPFLAGS"
+- OLD_LIBS="$LIBS"
+- CPPFLAGS="$CPPFLAGS -b i486-linuxaout"
+- LIBS="$LIBS -b i486-linuxaout"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
+- [[XOpenDisplay ("foo");]])],
+- [xgnu_linux_second_failure=no],
+- [xgnu_linux_second_failure=yes])
+- if test "${xgnu_linux_second_failure}" = "yes"; then
+- # If we get the same failure with -b, there is no use adding -b.
+- # So leave it out. This plays safe.
+- emacs_cv_b_link=no
+- else
+- emacs_cv_b_link=yes
+- fi
+- CPPFLAGS=$OLD_CPPFLAGS
+- LIBS=$OLD_LIBS
+- else
+- emacs_cv_b_link=no
+- fi])
+- if test "x$emacs_cv_b_link" = xyes ; then
+- LD_SWITCH_X_SITE="$LD_SWITCH_X_SITE -b i486-linuxaout"
+- C_SWITCH_X_SITE="$C_SWITCH_X_SITE -b i486-linuxaout"
+- fi
+- fi
+-
+ # Reportedly, some broken Solaris systems have XKBlib.h but are missing
+ # header files included from there.
+ AC_CACHE_CHECK([for Xkb], [emacs_cv_xkb],
+@@ -4170,6 +4137,7 @@
+ [emacs_cv_alternate_stack],
+ [AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM([[#include <signal.h>
++ #include <stdlib.h>
+ ]],
+ [[stack_t ss;
+ struct sigaction sa;
diff --git a/emacs/27.2/08_all_configure-decl.patch b/emacs/27.2/08_all_configure-decl.patch
new file mode 100644
index 0000000..0e95515
--- /dev/null
+++ b/emacs/27.2/08_all_configure-decl.patch
@@ -0,0 +1,66 @@
+Fix implicit function declarations in configure.ac (XOpenDisplay, malloc)
+Backported from master branch
+https://bugs.gentoo.org/898304
+
+commit 6c1413d5ef0d1fea639b0d8c83a0c0065d99359b
+Author: Florian Weimer <fweimer@redhat.com>
+Date: Fri Dec 23 18:49:25 2022 +0100
+
+ configure: Remove obsolete check for -b i486-linuxaout
+
+commit 121a9ff9f6fc69066ce30c2dbe6cbfbfdca6aeaa
+Author: Florian Weimer <fweimer@redhat.com>
+Date: Fri Dec 23 18:51:08 2022 +0100
+
+ Fix alternate stack test in configure
+
+--- emacs-27.2/configure.ac
++++ emacs-27.2/configure.ac
+@@ -2505,39 +2505,6 @@
+ export LD_RUN_PATH
+ fi
+
+- if test "${opsys}" = "gnu-linux"; then
+- AC_CACHE_CHECK([whether X on GNU/Linux needs -b to link], [emacs_cv_b_link],
+- [AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
+- [[XOpenDisplay ("foo");]])],
+- [xgnu_linux_first_failure=no],
+- [xgnu_linux_first_failure=yes])
+- if test "${xgnu_linux_first_failure}" = "yes"; then
+- OLD_CPPFLAGS="$CPPFLAGS"
+- OLD_LIBS="$LIBS"
+- CPPFLAGS="$CPPFLAGS -b i486-linuxaout"
+- LIBS="$LIBS -b i486-linuxaout"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
+- [[XOpenDisplay ("foo");]])],
+- [xgnu_linux_second_failure=no],
+- [xgnu_linux_second_failure=yes])
+- if test "${xgnu_linux_second_failure}" = "yes"; then
+- # If we get the same failure with -b, there is no use adding -b.
+- # So leave it out. This plays safe.
+- emacs_cv_b_link=no
+- else
+- emacs_cv_b_link=yes
+- fi
+- CPPFLAGS=$OLD_CPPFLAGS
+- LIBS=$OLD_LIBS
+- else
+- emacs_cv_b_link=no
+- fi])
+- if test "x$emacs_cv_b_link" = xyes ; then
+- LD_SWITCH_X_SITE="$LD_SWITCH_X_SITE -b i486-linuxaout"
+- C_SWITCH_X_SITE="$C_SWITCH_X_SITE -b i486-linuxaout"
+- fi
+- fi
+-
+ # Reportedly, some broken Solaris systems have XKBlib.h but are missing
+ # header files included from there.
+ AC_CACHE_CHECK([for Xkb], [emacs_cv_xkb],
+@@ -4397,6 +4364,7 @@
+ [emacs_cv_alternate_stack],
+ [AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM([[#include <signal.h>
++ #include <stdlib.h>
+ ]],
+ [[stack_t ss;
+ struct sigaction sa;
diff --git a/emacs/28.2/09_all_configure-decl.patch b/emacs/28.2/09_all_configure-decl.patch
new file mode 100644
index 0000000..1e86f54
--- /dev/null
+++ b/emacs/28.2/09_all_configure-decl.patch
@@ -0,0 +1,66 @@
+Fix implicit function declarations in configure.ac (XOpenDisplay, malloc)
+Backported from master branch
+https://bugs.gentoo.org/898304
+
+commit 6c1413d5ef0d1fea639b0d8c83a0c0065d99359b
+Author: Florian Weimer <fweimer@redhat.com>
+Date: Fri Dec 23 18:49:25 2022 +0100
+
+ configure: Remove obsolete check for -b i486-linuxaout
+
+commit 121a9ff9f6fc69066ce30c2dbe6cbfbfdca6aeaa
+Author: Florian Weimer <fweimer@redhat.com>
+Date: Fri Dec 23 18:51:08 2022 +0100
+
+ Fix alternate stack test in configure
+
+--- emacs-28.2/configure.ac
++++ emacs-28.2/configure.ac
+@@ -2491,39 +2491,6 @@
+ export LD_RUN_PATH
+ fi
+
+- if test "${opsys}" = "gnu-linux"; then
+- AC_CACHE_CHECK([whether X on GNU/Linux needs -b to link], [emacs_cv_b_link],
+- [AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
+- [[XOpenDisplay ("foo");]])],
+- [xgnu_linux_first_failure=no],
+- [xgnu_linux_first_failure=yes])
+- if test "${xgnu_linux_first_failure}" = "yes"; then
+- OLD_CPPFLAGS="$CPPFLAGS"
+- OLD_LIBS="$LIBS"
+- CPPFLAGS="$CPPFLAGS -b i486-linuxaout"
+- LIBS="$LIBS -b i486-linuxaout"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
+- [[XOpenDisplay ("foo");]])],
+- [xgnu_linux_second_failure=no],
+- [xgnu_linux_second_failure=yes])
+- if test "${xgnu_linux_second_failure}" = "yes"; then
+- # If we get the same failure with -b, there is no use adding -b.
+- # So leave it out. This plays safe.
+- emacs_cv_b_link=no
+- else
+- emacs_cv_b_link=yes
+- fi
+- CPPFLAGS=$OLD_CPPFLAGS
+- LIBS=$OLD_LIBS
+- else
+- emacs_cv_b_link=no
+- fi])
+- if test "x$emacs_cv_b_link" = xyes ; then
+- LD_SWITCH_X_SITE="$LD_SWITCH_X_SITE -b i486-linuxaout"
+- C_SWITCH_X_SITE="$C_SWITCH_X_SITE -b i486-linuxaout"
+- fi
+- fi
+-
+ # Reportedly, some broken Solaris systems have XKBlib.h but are missing
+ # header files included from there.
+ AC_CACHE_CHECK([for Xkb], [emacs_cv_xkb],
+@@ -4629,6 +4596,7 @@
+ [emacs_cv_alternate_stack],
+ [AC_COMPILE_IFELSE(
+ [AC_LANG_PROGRAM([[#include <signal.h>
++ #include <stdlib.h>
+ ]],
+ [[stack_t ss;
+ struct sigaction sa;
diff --git a/emacs/29.2/03_all_configure-decl.patch b/emacs/29.2/03_all_configure-decl.patch
new file mode 100644
index 0000000..dbee941
--- /dev/null
+++ b/emacs/29.2/03_all_configure-decl.patch
@@ -0,0 +1,52 @@
+Fix implicit function declaration in configure.ac (XOpenDisplay)
+Backported from master branch
+https://bugs.gentoo.org/898304
+
+commit 6c1413d5ef0d1fea639b0d8c83a0c0065d99359b
+Author: Florian Weimer <fweimer@redhat.com>
+Date: Fri Dec 23 18:49:25 2022 +0100
+
+ configure: Remove obsolete check for -b i486-linuxaout
+
+--- emacs-29.2/configure.ac
++++ emacs-29.2/configure.ac
+@@ -2695,39 +2695,6 @@
+ export LD_RUN_PATH
+ fi
+
+- if test "${opsys}" = "gnu-linux"; then
+- AC_CACHE_CHECK([whether X on GNU/Linux needs -b to link], [emacs_cv_b_link],
+- [AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
+- [[XOpenDisplay ("foo");]])],
+- [xgnu_linux_first_failure=no],
+- [xgnu_linux_first_failure=yes])
+- if test "${xgnu_linux_first_failure}" = "yes"; then
+- OLD_CPPFLAGS="$CPPFLAGS"
+- OLD_LIBS="$LIBS"
+- CPPFLAGS="$CPPFLAGS -b i486-linuxaout"
+- LIBS="$LIBS -b i486-linuxaout"
+- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
+- [[XOpenDisplay ("foo");]])],
+- [xgnu_linux_second_failure=no],
+- [xgnu_linux_second_failure=yes])
+- if test "${xgnu_linux_second_failure}" = "yes"; then
+- # If we get the same failure with -b, there is no use adding -b.
+- # So leave it out. This plays safe.
+- emacs_cv_b_link=no
+- else
+- emacs_cv_b_link=yes
+- fi
+- CPPFLAGS=$OLD_CPPFLAGS
+- LIBS=$OLD_LIBS
+- else
+- emacs_cv_b_link=no
+- fi])
+- if test "x$emacs_cv_b_link" = xyes ; then
+- LD_SWITCH_X_SITE="$LD_SWITCH_X_SITE -b i486-linuxaout"
+- C_SWITCH_X_SITE="$C_SWITCH_X_SITE -b i486-linuxaout"
+- fi
+- fi
+-
+ # Reportedly, some broken Solaris systems have XKBlib.h but are missing
+ # header files included from there.
+ AC_CACHE_CHECK([for Xkb], [emacs_cv_xkb],