aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'emacs/28.3/04_all_tramp-version.patch')
-rw-r--r--emacs/28.3/04_all_tramp-version.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/emacs/28.3/04_all_tramp-version.patch b/emacs/28.3/04_all_tramp-version.patch
new file mode 100644
index 0000000..757f7ac
--- /dev/null
+++ b/emacs/28.3/04_all_tramp-version.patch
@@ -0,0 +1,58 @@
+Adapt Tramp versions
+Patch from emacs-28 branch
+
+commit dec958258b133b4c21224c594da433919d852800
+Author: Michael Albinus <michael.albinus@gmx.de>
+Date: Fri Feb 24 19:42:27 2023 +0100
+
+ Adapt Tramp versions. Do not merge
+
+--- a/doc/misc/trampver.texi
++++ b/doc/misc/trampver.texi
+@@ -8,7 +8,7 @@
+ @c In the Tramp GIT, the version numbers are auto-frobbed from
+ @c tramp.el, and the bug report address is auto-frobbed from
+ @c configure.ac.
+-@set trampver 2.5.4-pre
++@set trampver 2.5.4
+ @set trampurl https://www.gnu.org/software/tramp/
+ @set tramp-bug-report-address tramp-devel@@gnu.org
+ @set emacsver 25.1
+--- a/lisp/net/trampver.el
++++ b/lisp/net/trampver.el
+@@ -7,7 +7,7 @@
+ ;; Maintainer: Michael Albinus <michael.albinus@gmx.de>
+ ;; Keywords: comm, processes
+ ;; Package: tramp
+-;; Version: 2.5.4-pre
++;; Version: 2.5.4
+ ;; Package-Requires: ((emacs "25.1"))
+ ;; Package-Type: multi
+ ;; URL: https://www.gnu.org/software/tramp/
+@@ -40,7 +40,7 @@
+ ;; ./configure" to change them.
+
+ ;;;###tramp-autoload
+-(defconst tramp-version "2.5.4-pre"
++(defconst tramp-version "2.5.4"
+ "This version of Tramp.")
+
+ ;;;###tramp-autoload
+@@ -78,7 +78,7 @@
+ ;; Check for Emacs version.
+ (let ((x (if (not (string-lessp emacs-version "25.1"))
+ "ok"
+- (format "Tramp 2.5.4-pre is not fit for %s"
++ (format "Tramp 2.5.4 is not fit for %s"
+ (replace-regexp-in-string "\n" "" (emacs-version))))))
+ (unless (string-equal "ok" x) (error "%s" x)))
+
+@@ -104,7 +104,7 @@
+ ("2.3.3" . "26.1") ("2.3.3.26.1" . "26.1") ("2.3.5.26.2" . "26.2")
+ ("2.3.5.26.3" . "26.3")
+ ("2.4.3.27.1" . "27.1") ("2.4.5.27.2" . "27.2")
+- ("2.5.2.28.1" . "28.1") ("2.5.3.28.2" . "28.2")))
++ ("2.5.2.28.1" . "28.1") ("2.5.3.28.2" . "28.2") ("2.5.4" . "28.3")))
+
+ (add-hook 'tramp-unload-hook
+ (lambda ()