summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-10-22 20:40:25 +0000
committerThomas Sachau <tommy@gentoo.org>2010-10-22 20:40:25 +0000
commit091d8a4d0860e5a709a8a2f8059aa6df9fcfbf58 (patch)
tree4a9ddbd3d4f62c6451b79c89a6e2b6c03d99b803
parentUpdate python-e_dbus to use PYTHON_DEPEND and to support multiple python ABIs (diff)
downloadenlightenment-091d8a4d0860e5a709a8a2f8059aa6df9fcfbf58.tar.gz
enlightenment-091d8a4d0860e5a709a8a2f8059aa6df9fcfbf58.tar.bz2
enlightenment-091d8a4d0860e5a709a8a2f8059aa6df9fcfbf58.zip
Update python-evas to use PYTHON_DEPEND and to support multiple python ABIs
(Portage version: 2.2_rc99-r1/svn/Linux x86_64)
-rw-r--r--dev-python/python-evas/python-evas-9999.ebuild38
1 files changed, 26 insertions, 12 deletions
diff --git a/dev-python/python-evas/python-evas-9999.ebuild b/dev-python/python-evas/python-evas-9999.ebuild
index 771c9fc..3ae7aaa 100644
--- a/dev-python/python-evas/python-evas-9999.ebuild
+++ b/dev-python/python-evas/python-evas-9999.ebuild
@@ -1,27 +1,41 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-NEED_PYTHON="2.4"
+EAPI=2
+
+E_CYTHON=1
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
ESVN_SUB_PROJECT="BINDINGS/python"
-inherit enlightenment distutils
+inherit enlightenment
DESCRIPTION="Python bindings for EVAS library"
HOMEPAGE="http://www.enlightenment.org/"
LICENSE="LGPL-2.1"
-IUSE=""
+IUSE="static-libs"
-RDEPEND=">=x11-libs/evas-9999
- dev-libs/eina"
+RDEPEND=">=x11-libs/evas-9999"
DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9.0
- >=dev-python/cython-0.9.6.12
- dev-python/pyrex
- dev-python/setuptools"
+ >=dev-util/pkgconfig-0.9.0"
+
+src_prepare() {
+ enlightenment_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s enlightenment_src_configure
+}
+
+src_compile() {
+ python_execute_function -s enlightenment_src_compile
+}
-src_unpack() {
- enlightenment_src_unpack
+src_install() {
+ python_execute_function -s enlightenment_src_install
}