summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-10-22 21:15:46 +0000
committerThomas Sachau <tommy@gentoo.org>2010-10-22 21:15:46 +0000
commit151239c86b553110f0452da0cf7ebfcbfb2cd306 (patch)
tree4e1262557cd24065ec794cbd6339fcc37fdd0489 /dev-python
parentMake static libs optional (diff)
downloadenlightenment-151239c86b553110f0452da0cf7ebfcbfb2cd306.tar.gz
enlightenment-151239c86b553110f0452da0cf7ebfcbfb2cd306.tar.bz2
enlightenment-151239c86b553110f0452da0cf7ebfcbfb2cd306.zip
Update to support PYTHON_DEPEND and multiple python ABIs, also make static libs optional
(Portage version: 2.2_rc99-r1/svn/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-ecore/metadata.xml3
-rw-r--r--dev-python/python-ecore/python-ecore-9999.ebuild43
2 files changed, 34 insertions, 12 deletions
diff --git a/dev-python/python-ecore/metadata.xml b/dev-python/python-ecore/metadata.xml
index 832c5fc..46ac67c 100644
--- a/dev-python/python-ecore/metadata.xml
+++ b/dev-python/python-ecore/metadata.xml
@@ -5,4 +5,7 @@
<maintainer>
<email>enlightenment@gentoo.org</email>
</maintainer>
+<use>
+ <flag name='evas'>Enable ecore-evas support</flag>
+</use>
</pkgmetadata>
diff --git a/dev-python/python-ecore/python-ecore-9999.ebuild b/dev-python/python-ecore/python-ecore-9999.ebuild
index 5e22c52..74c7a8b 100644
--- a/dev-python/python-ecore/python-ecore-9999.ebuild
+++ b/dev-python/python-ecore/python-ecore-9999.ebuild
@@ -1,24 +1,43 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-NEED_PYTHON="2.4"
+EAPI=2
+
+E_CYTHON=1
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
ESVN_SUB_PROJECT="BINDINGS/python"
-inherit enlightenment distutils
+inherit enlightenment
DESCRIPTION="Python bindings for ecore"
LICENSE="LGPL-2.1"
-IUSE=""
+IUSE="evas static-libs X"
-RDEPEND=">=dev-python/python-evas-9999
- >=x11-libs/ecore-9999"
+RDEPEND=">=x11-libs/ecore-9999[evas?,X?]"
DEPEND="${RDEPEND}
- >=dev-python/cython-0.9.8
- dev-python/pyrex
- dev-util/pkgconfig
- >=dev-python/setuptools-0.6_rc9"
+ evas? ( >=dev-python/python-evas-9999 )
+ dev-util/pkgconfig"
+
+src_prepare() {
+ enlightenment_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ MY_ECONF="$(use_enable evas ecore-evas)
+ $(use_enable X ecore-x)
+ --disable-ecore-imf
+ --disable-ecore-win32"
+ python_execute_function -s enlightenment_src_configure
+}
+
+src_compile() {
+ python_execute_function -s enlightenment_src_compile
+}
-src_unpack() {
- enlightenment_src_unpack
+src_install() {
+ python_execute_function -s enlightenment_src_install
}