summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-10-23 15:25:00 +0000
committerThomas Sachau <tommy@gentoo.org>2010-10-23 15:25:00 +0000
commit808cfa0c6927e67b10c47467a384d3ea0c5f2db5 (patch)
treedc969a05fcfa649b40b2a55b8c6a5288508a5054 /dev-python
parentUpdate to support PYTHON_DEPEND and multiple python ABIs, also make static li... (diff)
downloadenlightenment-808cfa0c6927e67b10c47467a384d3ea0c5f2db5.tar.gz
enlightenment-808cfa0c6927e67b10c47467a384d3ea0c5f2db5.tar.bz2
enlightenment-808cfa0c6927e67b10c47467a384d3ea0c5f2db5.zip
Use PYTHON_DEPEND, support multiple python ABIs, make static libs optional
(Portage version: 2.2_rc99-r1/svn/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-edje/python-edje-9999.ebuild36
1 files changed, 26 insertions, 10 deletions
diff --git a/dev-python/python-edje/python-edje-9999.ebuild b/dev-python/python-edje/python-edje-9999.ebuild
index b1716e8..d05dd3b 100644
--- a/dev-python/python-edje/python-edje-9999.ebuild
+++ b/dev-python/python-edje/python-edje-9999.ebuild
@@ -1,22 +1,38 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-NEED_PYTHON="2.4"
+EAPI=2
+
+E_CYTHON=1
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="3.*"
+
ESVN_SUB_PROJECT="BINDINGS/python"
-inherit enlightenment distutils
+inherit enlightenment
DESCRIPTION="Python bindings for edje"
LICENSE="LGPL-2.1"
-IUSE=""
+IUSE="static-libs"
-RDEPEND=">=media-libs/edje-9999
- >=dev-python/python-evas-9999"
+RDEPEND=">=media-libs/edje-9999"
DEPEND="${RDEPEND}
- >=dev-python/cython-0.9.8
- >=dev-python/setuptools-0.6_rc9"
+ >=dev-python/python-evas-9999"
+
+src_prepare() {
+ enlightenment_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s enlightenment_src_configure
+}
+
+src_compile() {
+ python_execute_function -s enlightenment_src_compile
+}
-src_unpack() {
- enlightenment_src_unpack
+src_install() {
+ python_execute_function -s enlightenment_src_install
}