summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEd Presutti <epresutti@comcast.net>2007-08-28 05:04:11 +0000
committerEd Presutti <epresutti@comcast.net>2007-08-28 05:04:11 +0000
commitafb74d470323f1ff09a9ad40bac90dc8a5995aac (patch)
tree40c341d2ef83c7e02ff5bff9e85fd0e7a582b4f6 /media-libs/edje/edje-0.5.0.041.ebuild
parentCorrect some crazy build problems with this code and... Asparagus! (diff)
downloadenlightenment-afb74d470323f1ff09a9ad40bac90dc8a5995aac.tar.gz
enlightenment-afb74d470323f1ff09a9ad40bac90dc8a5995aac.tar.bz2
enlightenment-afb74d470323f1ff09a9ad40bac90dc8a5995aac.zip
Asparagus!
Diffstat (limited to 'media-libs/edje/edje-0.5.0.041.ebuild')
-rw-r--r--media-libs/edje/edje-0.5.0.041.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/edje/edje-0.5.0.041.ebuild b/media-libs/edje/edje-0.5.0.041.ebuild
new file mode 100644
index 0000000..f606b0d
--- /dev/null
+++ b/media-libs/edje/edje-0.5.0.041.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/edje/edje-9999.ebuild,v 1.6 2006/07/16 05:29:42 vapier Exp $
+
+inherit enlightenment
+
+SRC_URI="http://download.enlightenment.org/snapshots/2007-08-26/${P}.tar.gz"
+
+DESCRIPTION="graphical layout and animation library"
+HOMEPAGE="http://www.enlightenment.org/pages/edje.html"
+
+IUSE="vim"
+
+DEPEND=">=x11-libs/evas-0.9.9.041
+ >=x11-libs/ecore-0.9.9.041
+ >=dev-libs/eet-0.9.10.041
+ >=dev-libs/embryo-0.9.1.041
+ app-editors/vim-core"
+
+src_compile() {
+ export MY_ECONF="
+ $(use_with vim vim /usr/share/vim)
+ "
+ enlightenment_src_compile
+}
+
+src_install() {
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins data/edc.vim edc.vim
+ fi
+ enlightenment_src_install
+}