summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEd Presutti <epresutti@comcast.net>2007-08-28 04:46:03 +0000
committerEd Presutti <epresutti@comcast.net>2007-08-28 04:46:03 +0000
commitbc579d5802d9fda6e4fcfd5d7dc6b3d9c331c23e (patch)
tree20ba7210f6bbb31c548cf623286ad2d9a593be65 /media-libs/imlib2_loaders/imlib2_loaders-1.4.0.003.ebuild
parentAsparagus! (diff)
downloadenlightenment-bc579d5802d9fda6e4fcfd5d7dc6b3d9c331c23e.tar.gz
enlightenment-bc579d5802d9fda6e4fcfd5d7dc6b3d9c331c23e.tar.bz2
enlightenment-bc579d5802d9fda6e4fcfd5d7dc6b3d9c331c23e.zip
Correct some crazy build problems with this code and... Asparagus!
Diffstat (limited to 'media-libs/imlib2_loaders/imlib2_loaders-1.4.0.003.ebuild')
-rw-r--r--media-libs/imlib2_loaders/imlib2_loaders-1.4.0.003.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/imlib2_loaders/imlib2_loaders-1.4.0.003.ebuild b/media-libs/imlib2_loaders/imlib2_loaders-1.4.0.003.ebuild
new file mode 100644
index 0000000..52bfb2a
--- /dev/null
+++ b/media-libs/imlib2_loaders/imlib2_loaders-1.4.0.003.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/imlib2_loaders/imlib2_loaders-9999.ebuild,v 1.3 2005/04/10 03:43:09 vapier Exp $
+
+inherit enlightenment
+
+SRC_URI="http://download.enlightenment.org/snapshots/2007-08-26/${P}.tar.gz"
+
+DESCRIPTION="image loader plugins for Imlib 2"
+HOMEPAGE="http://www.enlightenment.org/pages/imlib2.html"
+
+IUSE="edb"
+
+RDEPEND=">=media-libs/imlib2-1.2.0
+ >=dev-libs/eet-0.9.9
+ edb? ( >=dev-db/edb-1.0.5.008 )"
+
+# The enable-eet switch is apparently broken upstream when using disable-edb.
+# Looks like some sort of error in the configure.in scripts. Probably a
+# copy/paste error or something.
+# For now, we'll install the dep using portage
+# and let the autotools detect it. (Seems to work fine on x86 this way)
+#src_compile() {
+# export MY_ECONF="
+# --enable-eet \
+# $(use_enable edb) \
+# "
+# enlightenment_src_compile
+#}