summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am4
-rw-r--r--Makefile.in34
-rwxr-xr-xautogen.sh9
-rw-r--r--configure.ac10
4 files changed, 9 insertions, 48 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..e92a315
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,4 @@
+bin_PROGRAMS = python-wrapper
+
+eselectdir = $(datadir)/eselect/modules
+dist_eselect_DATA = python.eselect
diff --git a/Makefile.in b/Makefile.in
deleted file mode 100644
index fcaeb15..0000000
--- a/Makefile.in
+++ /dev/null
@@ -1,34 +0,0 @@
-CC = @CC@
-CPPFLAGS = @CPPFLAGS@
-CFLAGS = @CFLAGS@
-WARNINGS_FLAGS = -Wall -Wextra
-LDFLAGS = @LDFLAGS@
-LIBS = @LIBS@
-EXEEXT = @EXEEXT@
-MKDIR = @MKDIR@
-INSTALL= @INSTALL@
-
-prefix = @prefix@
-exec_prefix = @exec_prefix@
-bindir = @bindir@
-datadir = @datadir@
-datarootdir = @datarootdir@
-
-all: python-wrapper$(EXEEXT)
-
-python-wrapper$(EXEEXT): config.h python-wrapper.c
- $(CC) $(CPPFLAGS) $(CFLAGS) $(WARNINGS_FLAGS) $(LDFLAGS) -o $@ python-wrapper.c $(LIBS)
-
-install: all
- $(MKDIR) $(DESTDIR)$(bindir) $(DESTDIR)$(datadir)/eselect/modules
- $(INSTALL) python-wrapper$(EXEEXT) $(DESTDIR)$(bindir)/python-wrapper$(EXEEXT)
- $(INSTALL) -m 644 python.eselect $(DESTDIR)$(datadir)/eselect/modules/python.eselect
-
-clean:
- rm -fr python-wrapper$(EXEEXT)
-
-distclean: clean
- rm -fr config.h config.log config.status Makefile
-
-extraclean: distclean
- rm -fr config.h.in configure
diff --git a/autogen.sh b/autogen.sh
index b7ee211..89dcaff 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -1,7 +1,2 @@
-#!/bin/sh
-
-"${AUTOHEADER:-autoheader}" || exit 1
-"${AUTOCONF:-autoconf}" || exit 1
-
-# Remove Autoconf cache.
-rm -fr autom4te.cache
+#!/bin/sh -x
+exec autoreconf -fi
diff --git a/configure.ac b/configure.ac
index 67b8580..6ee6606 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,11 +1,9 @@
-AC_INIT([eselect-python], [20100321])
-
-CFLAGS="${CFLAGS--march=native -O3 -pipe -fno-ident}"
-LDFLAGS="${LDFLAGS--Wl,-O1,--as-needed,--gc-sections,--hash-style=gnu}"
+AC_INIT([eselect-python], [20111108])
+AM_INIT_AUTOMAKE([-Wall foreign no-dist-gzip dist-bzip2])
AC_PROG_CC
AC_PATH_PROG(INSTALL, install)
-MKDIR="${MKDIR:-${INSTALL} -d}"
+AC_PROG_MKDIR_P
AC_USE_SYSTEM_EXTENSIONS
@@ -31,8 +29,6 @@ else
fi
CFLAGS="${old_CFLAGS}"
-AC_SUBST([MKDIR])
-
# Create output files.
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([Makefile])