summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 662653a..46291cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([eselect-python], [20091230])
+AC_INIT([eselect-python], [20100321])
CFLAGS="${CFLAGS--march=native -O3 -pipe -fno-ident}"
LDFLAGS="${LDFLAGS--Wl,-O1,--as-needed,--gc-sections,--hash-style=gnu}"
@@ -9,7 +9,10 @@ MKDIR="${MKDIR:-${INSTALL} -d}"
AC_USE_SYSTEM_EXTENSIONS
-# strndup() was introduced in POSIX.1-2008.
+# setenv() was introduced in POSIX.1-2008.
+AC_CHECK_FUNCS([setenv])
+
+# strndup() was introduced in POSIX.1-2008 and is also an implicitly declared built-in function in GCC.
AC_MSG_CHECKING([for strndup])
old_CFLAGS="${CFLAGS}"
CFLAGS="${CFLAGS} -Wall -Werror -Wextra"