aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-05-20 09:59:09 +0200
committerUlrich Müller <ulm@gentoo.org>2014-05-20 09:59:09 +0200
commit2996ee3ab94c875f7d000ce73ea1918d748793c5 (patch)
tree4cf6f705dd59bdd952635b7267326468bdf5cb80
parentAutomake doesn't play well with leading whitespace in variables. (diff)
downloadeselect-2996ee3ab94c875f7d000ce73ea1918d748793c5.tar.gz
eselect-2996ee3ab94c875f7d000ce73ea1918d748793c5.tar.bz2
eselect-2996ee3ab94c875f7d000ce73ea1918d748793c5.zip
Use "%" instead of "," as delimiter for sed.
* bin/Makefile.am (dosed): * libs/Makefile.am (dosed): * man/Makefile.am (dosed): Use "%" instead of "," as delimiter.
-rw-r--r--ChangeLog4
-rw-r--r--bin/Makefile.am8
-rw-r--r--libs/Makefile.am8
-rw-r--r--man/Makefile.am2
4 files changed, 13 insertions, 9 deletions
diff --git a/ChangeLog b/ChangeLog
index d5ddaef..d9dd9fd 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,9 @@
2014-05-20 Ulrich Müller <ulm@gentoo.org>
+ * bin/Makefile.am (dosed):
+ * libs/Makefile.am (dosed):
+ * man/Makefile.am (dosed): Use "%" instead of "," as delimiter.
+
* configure.ac: Replace "git rev-parse" by "git describe", now
that git-r3.eclass supports it (bug 489100).
diff --git a/bin/Makefile.am b/bin/Makefile.am
index 7ba2996..20902c1 100644
--- a/bin/Makefile.am
+++ b/bin/Makefile.am
@@ -1,10 +1,10 @@
bin_SCRIPTS = eselect
EXTRA_DIST = eselect.in
-dosed = @SED@ -e 's,\@BASH\@,$(BASH),g' \
- -e 's,\@DATADIR\@,$(datadir),g' \
- -e 's,\@EPREFIX\@,$(EPREFIX),g' \
- -e 's,\@VERSION\@,$(VERSION)$(EXTRAVERSION),g'
+dosed = @SED@ -e 's%\@BASH\@%$(BASH)%g' \
+ -e 's%\@DATADIR\@%$(datadir)%g' \
+ -e 's%\@EPREFIX\@%$(EPREFIX)%g' \
+ -e 's%\@VERSION\@%$(VERSION)$(EXTRAVERSION)%g'
% : %.in
@echo "Building $@..."
diff --git a/libs/Makefile.am b/libs/Makefile.am
index bab373e..027ef73 100644
--- a/libs/Makefile.am
+++ b/libs/Makefile.am
@@ -27,10 +27,10 @@ EXTRA_DIST = \
tests.bash.in
dosed = @SED@ \
- -e 's,\@SED\@,@SED@,g' \
- -e 's,\@PORTAGEQ\@,@PORTAGEQ@,g' \
- -e 's,\@ENV_UPDATE\@,@ENV_UPDATE@,g' \
- -e 's,\@CANONICALISE\@,@CANONICALISE@,g'
+ -e 's%\@SED\@%@SED@%g' \
+ -e 's%\@PORTAGEQ\@%@PORTAGEQ@%g' \
+ -e 's%\@ENV_UPDATE\@%@ENV_UPDATE@%g' \
+ -e 's%\@CANONICALISE\@%@CANONICALISE@%g'
%.bash : %.bash.in
@$(dosed) $< > $@
diff --git a/man/Makefile.am b/man/Makefile.am
index f93b85b..c4bbdce 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -14,7 +14,7 @@ EXTRA_DIST = $(man_MANS)
MAINTAINERCLEANFILES = Makefile.in
# turn foo-<suffix> into foo.eselect.5
-dosed = @SED@ -e 's,^\(.*\)-.*,\1\.eselect\.5,'
+dosed = @SED@ -e 's%^\(.*\)-.*%\1\.eselect\.5%'
install-data-local : $(foreach f, $(symlinks), install-symlink-$(f))